A lot of App's not working - With Log's - [Discord, Komoot, Maps, SteamLink and Spotify]

I have a completely new FP5 bought directly from Fairphone-Shop, Started it and Updated to the newest Version FP5.TT3P.A.112 with the Systemsettings.

Then i installed all my needed Apps and the Apps mentioned above do not work.

The Android Bug-report has some interesting information for some of the Apps:

 Process: com.google.android.apps.maps, PID: 4561
 ukj: Exception while extracting native library.
 	at com.google.android.apps.gmm.jni.util.NativeHelper.b(PG:30)
 	at com.google.android.apps.gmm.jni.util.NativeHelper.a(PG:5)
 	at ine.run(PG:8)
 	at ahya.run(PG:18)
 	at java.lang.Thread.run(Thread.java:1012)
 Caused by: ukj: Zip entry 'lib/arm64-v8a/libgmm-jni.so' not found in APK '/data/app/~~MP34IVGJM8x102O1hmsA9A==/com.google.android.apps.maps-uHbhYN90PA1FEw-n58pF5g==/base.apk'
 	at com.google.android.apps.gmm.jni.util.NativeHelper.b(PG:11)
 	... 4 more
 Caused by: java.lang.UnsatisfiedLinkError: dlopen failed: library "libgmm-jni.so" not found
 	at java.lang.Runtime.loadLibrary0(Runtime.java:1077)
 	at java.lang.Runtime.loadLibrary0(Runtime.java:998)
 	at java.lang.System.loadLibrary(System.java:1661)
 	at com.google.android.apps.gmm.jni.util.NativeHelper.b(PG:1)
 	... 4 more
 Process: com.discord, PID: 5768
 java.lang.UnsatisfiedLinkError: dlopen failed: library "libkv_storage.so" not found
 	at java.lang.Runtime.loadLibrary0(Runtime.java:1077)
 	at java.lang.Runtime.loadLibrary0(Runtime.java:998)
 	at java.lang.System.loadLibrary(System.java:1661)
 	at com.discord.kvstorage.discordapp.DiscordMobileApi.initialize(SourceFile:3)
 	at com.discord.app_database.AppDatabaseModule$Companion.initializeAppDatabaseAsync(SourceFile:5)
 	at com.discord.app_database.AppDatabaseModule$Companion.access$initializeAppDatabaseAsync(Unknown Source:0)
 	at com.discord.app_database.AppDatabaseModule$Companion$initializeAppDatabase$1.invoke(SourceFile:2)
 	at com.discord.app_database.AppDatabaseModule$Companion$initializeAppDatabase$1.invoke(SourceFile:1)
 	at cg.a$a.run(Unknown Source:2)
 Process: com.valvesoftware.steamlink, PID: 6402
 java.lang.UnsatisfiedLinkError: No implementation found for void org.libsdl.app.HIDDeviceManager.HIDDeviceRegisterCallback() (tried Java_org_libsdl_app_HIDDeviceManager_HIDDeviceRegisterCallback and Java_org_libsdl_app_HIDDeviceManager_HIDDeviceRegisterCallback__)
 	at org.libsdl.app.HIDDeviceManager.HIDDeviceRegisterCallback(Native Method)
 	at org.libsdl.app.HIDDeviceManager.<init>(HIDDeviceManager.java:108)
 	at org.libsdl.app.HIDDeviceManager.acquire(HIDDeviceManager.java:37)
 	at com.valvesoftware.steamlink.SteamShellActivity.onCreate(SteamShellActivity.java:42)
 	at android.app.Activity.performCreate(Activity.java:8305)
 	at android.app.Activity.performCreate(Activity.java:8284)
 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1418)
 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3627)
 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3783)
 	at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:101)
 	at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:135)
 	at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:95)
 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2308)
 	at android.os.Handler.dispatchMessage(Handler.java:106)
 	at android.os.Looper.loopOnce(Looper.java:201)
 	at android.os.Looper.loop(Looper.java:288)
 	at android.app.ActivityThread.main(ActivityThread.java:7918)
 	at java.lang.reflect.Method.invoke(Native Method)
 	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:548)
 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:942)

Maps complains about being installed incorrectly, while the other apps just crash instantly. All other apps I use work perfectly.

I did also try a factory reset multiple times. Once Spotify worked very shortly. Once WhatsApp joint the Apps that do not work for one boot.

I don’t use a SD-Card.

Tested logged into Google and not logged in. Same result.

Any idea?

I dont’t think that is the cause. Every App works good except these. It seems like something in the System is causing the issues. Especially because even Security heavy apps like Banking, E-Mail and Google Stuff works perfectly. It seems like a missing Dependency. Did you read the Logs?

To me this looks too far off to have a simple fix, especially because the apps don’t complain about one common library not being found but all different. I’d first reset the phone, then only check the apps in question. If that doesn’t work I’d re-install the phone to ensure that all data is where it is supposed to be.

Hello, just to let you know that I have had no issues with Spotify nor maps so I guess it is an issue of a very particular configuration.
If you wish me to test any other apps, please do let me know.
Good luck

I thought of reinstalling the hole OS with the manual from Fairphone:

Issue is that there is no Sideload Package and if i want to go the Fastboot then i need to unlock my bootloader it says. I lose my warranty if i do that right? Or if it is actually a broken main board then i have an even bigger problem on my hand in regards to replacements. I very sure a fresh OS install could fix it (had it in the past with other phones and it always fixed very obscure issues like this) but what about the warrenty?

1 Like

No. Should you brick the phone, it can be fixed by Cordon and the price is around 30€.

However if you want an official statement, contact support

Well. I unlocked it, Flashed it and same result. But i found something. The apps that did not work ONLY work if i install them from the PlayStore DIRECTLY. From a Backup or over ADB they still crash. I have never seen something like this. Is that a normal stock rom behavior?

Try Aurora store, Spotify works flawlessly

Just a wild guess: are those apps so-called split APKs?

If yes, did you install all required files or just the base.apk?
And if the backup was from a different phone model it migh just not be compatible with a different model.


I have another suggestion: have you also tried deleting the cache and the saved data for those apps after the backup restore?
The backup systems tend to also port data over, but since the environment where the app is running has changed (i.e. different Google Play Services), it might be that the data available to the app is “corrupted” or not compatible with the new environment.

It is kind of comparable to a disk swap on a laptop: the system was running with a certain set of drivers and was expecting certain peripherals which have now changed, so it might cause instability.

If you ever tried swapping disks around with Linux distros installed you probably know what I’m talking about :wink:


I got the APKs from there. ADB, Aurora store and APKs they dont work. From the playstore they do

Haha i do know that xD. But i just installed apks with adb. and tryed the aurora store. but only from he playstore the apps work.

Then You just installed wrong version of the apps, from gplay everything works?


Hmmm… Maby Aurora fd up with its automatic spoofing will tests it.

Thats more than weird I use Spotify from Aurora since years and now since 2-3 months as well on the FP5…


In Aurora Store the Default was “FP5-default” with “arm64-v8a,armeabi-v7a.armeabi”. With that DEFAULT setting it did install the apps but the apps crash on start.

With the Setting “Google Pixel 7a” with “arm64-v8a” all apps work.



*I always used APKs i downloaded on the FP5 with Aurora Store and wanted to install them with(ADB/APK). now i can use the APKs from these Apps with the "“Google Pixel 7a” setting set in Aurora with ADB too and they work. It actually was just aurora having issues detecting the right architecture it seems like.

Good it works and just for the recorfs: That still cant be the only reason, thats my setting I use without issues.

I checked everything multipl times. It ONLY works from any other source then the PlayStore if Aurora is set to Pixel 7A. Then all APKs/ADB/Aurora Store installations work (The APKs and ADP obviously are dumped from the phone after Pixel 7A is sett in the settings in Audrora and getting them from there)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.