English

4g problems with dual sim and moving to e/os FP3

Hi,

I moved to e/os yesterday, and since I have problem to get the 4G.

I have two sim cards in my phone, one is a belgian one, the other a franch one.

When activate the 4G of my french sim card, it’s not working, I don’t have any signal. Before moving to e/os, i was using it and did not have any problem.
When I cativate the 4g via my belgian sim card, it works.
The problem, is that I have an 4G internet subscription only on my french sim card.

and clue how i could make it work?

I already tried inversing the two sim cards, truning off and on…

thank you!

I would advise to check APN settings of the french card, the provider can provide the correct settings.

2 Likes

thank you, i already tried, but no changes

solved!

I rewrote again all the APN setting, and clicked up right on save (i have forgotten athat step :wink:

it’s working now!

5 Likes

So it was solved, but i keep having troubles:

when i shut down my phone, and turn it on, the 4g is working on my french sim card, but if i turn off the 4g, and not the whole phole, than i cannot turn in on anymore, i do it but it’s not working. So i have to turn my phone off, and on to make it work again. any clue why this is happening?

How do you turn of 4G? Only 4G or mobile data?

i click on the data icon (the one with two arrows)

How long do you wait after enabling mobile data again? What happens when you disconnect using the airplane mode instead? How old is the SIM card? Can you interchange the SIM slots?

When I enable the Data of my belgian sim card, i get internet instantly, but when i enable the data from my french sim card even if i wait a few minutes i doesn’t work or only i I turn off and on my phone .

when i switch to airplane mode and off without touching the data button, the 4G is still working.

the sim card is new

if i interchange the sim cards it’s the same

what is weird is that on the small ‘signal icon’ (that looks like a triangle), when i turn off the data and on again, the 4G icon apears but on the signal icon there is a small cross at the bottom

Strange…so when you use airplane mode, mobile data stay on,or when you turn off airplane mode, 4G comes back without issues? I think also on the FP3 you can use only 1 SIM for mobile data at a time. So could you change the Belgian SIM to 2G as long as you do not use it? As the SIM is new and not working good, but another is, did you contact your provider to see if they can find any issues at their end and changing to e/OS is just a coincidence? What happens when you take off the Belgian SIM completely?
Sorry just thinking out loud what I would try, without knowing if anything helps…

As Yvmuell has indicated you can only use one SIM slot for data. Have you selected a particular slot?

Although the info is for the default OS

Like almost every Dual SIM device on the market, FP3/FP3+ implement the standard Dual SIM Dual Standby (DSDS). This means that both SIM cards are ready to be used at any time, but you can only use one of them at a time. For maximum performance, you can enable 4G on both SIM cards

To set your SIM card(s) to 4G: go to Settings → Network & Internet → Mobile network → tap on the name of your provider/SIM card → Preferred network type→ select 2G/3G/4G auto
https://support.fairphone.com/hc/en-us/articles/360047781111-FP3-Set-up-and-troubleshoot-a-mobile-data-connection-3G-4G-