English

19.08.1 upgrade and "secure startup"

I want to update my FP2 with the latest Open OS. It’s currently running 19.02.1. I guess I missed 19.05.1 somehow. The updater seems to want to update straight to 19.08.1.

It wants me to disable “secure startup”, and I do not understand how I’m supposed to do that. I get a message that “The Android 7 upgrade cannot be installed on encrypted devices with secure start-up enabled”. This is similar language to a warning box on both the 19.05.1 and 19.08.1 release notes:

If you are coming from Android 6, the Android 7 upgrade cannot be installed on encrypted devices with secure start-up enabled. Please disable secure start-up first: go to security settings and re-enter your current screen lock, but leave secure start-up disabled. You should undo this after installing the update.

I can tap through to security settings, but there is no option there that looks like “secure start-up”. I do not understand at all what “re-enter your current screen lock” means. How can I leave secure start-up disabled, given that the whole point is that secure start-up is now enabled?

I also do not understand why I am seeing this at all. The warning says that this should only apply if I’m coming from Android 6, but I’m not, I’m coming from Android 7.1.2.

This documentation is terrible. It does not match what a user sees on the device. It does not explain why it is forcing the user to jump through hoops like this. The instructions very much sound like a bad idea from a security point of view, but there is no explanation of the risks of disabling these settings, or what they actually do.

Every time I’ve tried to install an Open OS update it’s been a disaster one way or another. So I’d like to have a better idea of what I’m getting into before I wreck my phone yet again.

Can someone explain what this thing actually expects me to do?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

hi, I’d like to upgrade my FPh2 to a newer android and am having precisely the problem that was reported here:

and closed unresolved 6 months later. Can anyone offer advice?

That simply means that you should delete your screen lock in the security settings and add it again, and there you should have an option to disable secure startup.
@tbhanson Does this help you?
Do you have accessibility services enabled? (Settings→Accessibility)