16.11: Starting problems

Hi everybody.

I installed FPOOS 16.11 and got myself F-Droid and a few apps (ABP, TOR and the like).
When the phone restarted there was a screen to choose between rooted and unaltered mode as well as a prompt. I chose the unaltered mode and it froze rebooting.
Had to take the battery out to restart.
Since then, I cannot find any “Developer”-options and am unable to install e.g. upgrades of ABP, other apps show a lack of root power needed according to their preferences (root options greyed out), some work just fine (camera, telephone etc.).

I understand being root may do harm if I am not sure what I am doing. Also not being root reduces possibilities.
In the wiki I can’t find anything about start options (e.g. switch combinations for a certain mode).

I am kind of a WAU (worst assumable user) and would like to do it right.^^
Any hints?

edit: I found out what TWRP is (v2.8.7.0 installed) and how to start it (hold UP&MAIN for booting).
Anyway, the backup failed, even though I included ‘/data’ in the settings:
E:Unable to mount '/data’
Backup failed.
Cleaning Backup Folder

Also I do not see where the root options are accessible.

You have to activate developer settings first. Go to settings, scroll down to “about the phone”, scroll down to build number, and tap a couple of times (5 to 10, not sure) on the number. This will activate the developer settings. You can then there enable root.
And yes, if you don’t know what you are doing with root, it can be dangerous, but it can also help you - with using some tools - to secure your phone. Just read into it, there’s lots to find online.

1 Like

I appear to be root now.

Some things still do not work:

  • ABP gives msg, download works but still would run into “X not installed”

  • “E-Mail” does not show up in the Preferences -> Apps (I want to delete it as I have another client successfully running)

Any hints?

1 Like

should be in
settings - apps - all
but it is a system app, you can’t just simply uninstall it. you can easily deactivate it though.

1 Like

I had already installed “autostarts” and kept it from being lauched.
Now it is deactivated as well as the Browser.
Thanks a lot.

There are two things at hand now:

  • getting the current ABP update properly running (no idea so far, though the app itselfs seems to be working)

  • getting Xposed installed (I cannot open the *zip-file in TWRP to install it, as it is in /storage/emulated/0/ which seems unaccessable)

I installed the TOR-components and let most apps act through there.
Could it be that things become blocked here?

If you did not encrypt your phone, the location should be accessible. Maybe you need to mount /data first.
Certainly the external SD should be available, so if you have a microSD, just leave your xposed file there.
Then, in TWRP, you don’t need to open the .zip file. Just enter the menu point “install” in TWRP, uncheck signitaure verification, and point the installer to the xposed zip file.

Maybe that is why I could not acess /data in the first place - FS is encrypted.
Is it possible to decrypt /data from TWRP?

Anyway I got the xposed-apk called in TWRP now, thanks to your hint copying it to the external sd-card.
Only, there seems to be no app showing up.
How can I make sure I got the framework installed?

And: There ist no link to Titanium backup available in the APK-Downloader.
Is there any alternative or setting in the TWRP?

With the current TWRP port it is not possible to decrypt, thus mount /data.
In TWRP you don’t install any xposed app, but only the framework. This does not make any visible change in your OS. But with xposed framework in place, you can install the xposed-installer app, which gives you access to all kind of xposed modules. See: http://forum.xda-developers.com/showthread.php?t=3034811

Not sure what you mean by this. Titanium backup is unrelated to TWRP, it is a regular app.

I fail by mounting of /data in TWRP:
“Cache” and “MicroSD” are checked, “System” can be checked, “Data” will not accept checking.
Prompt keeps saying:
E:Unable to mount '/data'.

Anyway, TWRP has 08.01.1970 as default date and keeps changing the system date to that.
Also, any backup becomes marked with the result “Failed”.

Yes, sure.
I tried to get a link to a download outside GRGL, and there is no such thing available.
As backups do not seem to work on TWRP, I meant to install another app for this.

Also the XPosed framework does not seem to work: Nothing available at all.

What do I do wrong?

As I said above: it does not work in this TWRP port to mount an encrypted /data partition.[quote=“mungo, post:9, topic:24196”]
TWRP has 08.01.1970 as default date and keeps changing the system date

This is because of a bug:

Again, this is because you can’t mount an encrypted /data partition in this TWRP version.

There’s a download link on the app’s website: Titanium Backup for Android – Historical Website

Did you install the xposed-installer app? What does it say? Can it find the framework?

1 Like

I tried to install xposed-v87-sdk-arm.zip through TWRP as you suggested.
The XPosed Downloader has three options

  • Reboot to Recovery (not tried)
  • DL Xposed Installer APK (no effect)
  • Settings (API is set to sdk22)

I fear there has no installation of the framework taken place for ‘/data’ could not be mounted due to encryption (no decryption, no installation I suppose).

So, is the only option to reinstall without encryption?

Xposed is not installed on /data but in /system so the encryption issue doesn’t matter.
You need to install the framework in TWRP, but it will first have no visual effect when you boot into your OS. In the OS you need to install the xposed-installer apk. Only after both components are installed you can use xposed and it’s modules.

That is the mentioned xposed-v87-sdk-arm.zip I tried to install via TWRP.

I had mistaken that one for the framework, which is in fact de.robv.android.xposed.installer_v33_36570c.apk.

I guess, now I should install first the framework-apk and then again the installer-zip via TWRP.

edit: The framework-apk is not installable via TWRP, as far as I can see. There are only the *.zip-files shown in that directory after calling “Install”.
Am I to use “Updater” or “Amaze” to install the *.apk?

Now you got the two files mixed up :wink:

Please follow the instructions from the link I posted above:

I quote:

xposed*.zip from http://dl-xda.xposed.info/framework/: Must be flashed with a custom recovery (e.g. TWRP) to install the framework.

This is the zip file you have downloaded. Just make sure that you use the file from SDK22. That would be this one: http://dl-xda.xposed.info/framework/sdk22/arm/xposed-v87-sdk22-arm.zip
But then you also need to do this:

XposedInstaller_3.1.apk from this thread: Must be installed to manage installed modules, the framework won’t work without it.

The xposed-installer (i.e. the apk file) need to be installed from within Android, not from TWRP. Make sure that you have allowed installations from unknown sources (in settings-security).

You may find more information also here:

1 Like

Many thanks for taking your time.
Now I have not only understood, but also successfully opened the Xposed-Installer after installing it via Amaze.
Only, my internet connection seems to time out, so I do not have any things to try out.

Going to check for that one tomorrow.

Now I have all the possible Xposed-apps at hand - and can’t test them.
The framework says:
Xposed is not (yet) compatible with the Android-SDK-Version 22 or your processor-architecture (armeabi-v7a). CANNOT LINK EXECUTABLE DEPENCIES: library "libdvm.so" not found.

So far no fumbling around.

Usually this means that you flashed the wrong version of the framework. You’ll need the version for SDK22 on arm system architecture (so not SDK21 or SDK23, and not arm64 or _x86). Also, make sure to use version 87 (or newer). In short:

I installed
xposed-v87-sdk22-arm.zip (newest available) via TWRP and
de.robv.android.xposed.installer_v33_36570c.apk via Amaze.

Result is a seemingly functioning framework, lots of downloads - and the above msg.

If you got that one via the Xposed Module Repository (e.g. here), than that could be the problem - there’s a warning that it isn’t compatible with Android 5.0 and higher. The version that is offered via the XDA forum (linked from the page in the module repository that I mention above, or here) is the one you probably need: XposedInstaller_3.1.1.apk - attached to the first post of the XDA topic.

1 Like

Yes. This is obviously the one I needed.
First I downloaded it directly into the phone. Didn’t work, for there was some mysterious “decryption error” (I suspect my provider of it…). Then I tried it via my desktop and USB. No problem.
Uninstalled “v2.7 Experimental” and have Xposed Installer v3.1.1.

Thank you everybody.