1.8.7 update failed

Hello all,

I’m owning an FP1, currently running 1.8.5 w/Google Apps, and today I decided to follow the upgrade…

I went to Fairphone Upgrade, where I was suggested to upgrade to 1.8.7: I tapped “Installer la mise à jour” (French), and there it went for the file download, so far so good. Then I tapped “Redémarrer” (reboot), and the phone rebooted to a spinning Android sphere that said something like “Installing system files”. I was a little puzzled because I didn’t see any progress bar, as I did during a previous upgrade. Then it rebooted again, and I was hoping to be about to re-install the Google Apps, but I noticed that the update actually didn’t seem to have taken place :frowning: When launching Fairphone update again, it showed 1.8.5 as current, and offered to update as if nothing had changed.

Can you explain this ? Should I retry ? Should I carry out some verifications before ?

Thanks a lot.

Yes, but first go to Settings > Developer options, tick “stay awake” and plug in your phone.

This will keep your screen on at all times during the update and hopefully result in a successful update.

1 Like

Yes, the Stay awake did the trick. Thanks a lot !


Keeping the phone on the charger and changing the developer options did not do the trick for me. After rebooting I can enter a sort of bios where I can select different options (restart, update from cache, etc). They don’t do anything for me though. Any ideas?

But you don’t see a resting robot and the “no command” message?
Maybe you could still try to get to recovery mode from there and then follow this guide:

I do get the no command message. Then when I press the power on off button I get into that menu.

Oh ok, then that guide is exactly right for your situation.

I selected the SD card option but there was no folder called updater. I also checked the download folder but no update.

Ok @Francis reported the same problem. He moved the file to a location that is visible in recovery mode and then it worked.

Okay, moving the zip file to another folder worked. Had to do the same trick to reinstall Google apps :slight_smile: thanks!