Wrong Timezone displayed

The clock of my fairphone is showing the wrong time (1 hour ahead). I can select home time and then it dispays the correct time ( Amsterdam) in the home time window when I open the clock. However my alarm and clock are still sisplaying the wrong time.

Where is the option that lets me fix this?

It’s always best to use the time provided by the network. Go to Settings > Date & Time and check Automatic Timezone.

Does this resolve your problem?

1 Like

Yes it did resolve my problem, thank you

1 Like