Writing speed very slow with USB


Currently copying folders to internal FP4 storage to use it as my main device.

Copying folder is super slow, like a 100mb folder took me 15min to write on internal storage.

All that using USB3 connection…

Anyone got the same issues ?


Have you had quicker transfer rates from the same device (computer) to other devices?

Did you install a virus protection app or something like that on your FP4? This might slow down things.

Hey Zeiko,

Here I experienced kind of the same issue, but not completely I guess. When I started copying folders to my phone, it went quite rapidly. I copied a lot at once (+/- 1Gb of over 1000 small files (my Whatsapp folders)) and after a while the copying slowed way down. I decided to start again with the copying and then it went rapidly again, until after 10-15 minutes again it started to slown down. So in three bulks I copied everything quite quickly. I don’t know what was happening, but this helped a lot.

Good luck,
Kind regards,

1 Like


Transfer from and to my old device Honor 9 it is way faster.

I ended up transfering by bluethooth a 100mb archive it took about 7 min.

No antivirus on the FP4, I’ve removed a lot of google default bloatware but it should not impact perfomance imo.


If you have several ports on the computer, they may not all be USB3. On my laptop there are three, but only one is USB3, the others are USB2.

However, even USB2 should be delivering better than 116kB/s!

Try cleaning the ports and cable connectors and try a different cable.
Turn off devices before cleaning ports. Possible methods according to amount and type of dirt: Vacuum cleaner+brush attachment (it helps to get a few bristles into the port to dislodge debris) ; compressed air ; wooden or plastic toothpick ; I advise against isopropyl alcohol (last resort with dirt that’s difficult to shift, apply with caution, make sure you’re not leaving strands of cotton behind, leave to dry thoroughly).

I’ve seen this too, particularly with win-doze. The file copy utility seems to get constipated.

My solution when transferring large volumes is to use a vb script I wrote which sends the individual files one after another. I also use it for backups.

1 Like

This is not a port problem,

Compressing everything in a single archive fix the problem.

So imo the phone as trouble with batch files copying, maybe it is a hardware performance issue or a software

1 Like

OK good but you used BT not USB?
There really shouldn’t be a problem transferring by USB. There might be a defect with the phone’s USB module.

No, I tried again to transfer with USB but instead of +500 files for a total of 107mb it was an archive of 99mb


On my FP3 over USB2 I just did a test,

  • 1 file of 1 GB took 34 seconds.
  • A folder of 51 files totalling 2 GB took 1 minute 32 seconds.

Without doubt, the more numerous the files, the longer it takes. But I see this with any Windows environment, it doesn’t appear to me to be a FP or even Android thing. Each file must add a lot of file system overhead that ends up costing almost as much as the raw data. So, good idea to zip them up for transfer.


Thanks for the suggestions (more specifally the suggestion to create just one zip archive from multiple files before starting file transfer)!

I really always had lots of issues with transferring (MTP) simple music files from my old Mac (but also a friend’s Win10 laptop) to my FP3 (in fact more severe problems than when I still had the option of a USB transfer to my trusty old FP1U). It wasn’t primarily about speed, but about stability – the transfers just kept aborting mid-transfer regularly after just a couple of files, forcing me to re-start the whole procedure anew time and again until everything was moved. Now I just created one zip archive from my (say: 150ish) music files, then started the file transfer – and it transferred in one go, flawlessly and if my impression is right, even quite quickly.

(To be honest, I’m not sure anymore if I read this suggestion from you first a couple of days ago, but I have tried to find where exactly I picked it up and while I’m still not sure, you seemed to be the most plausible source :wink: )

1 Like

I can confirm this issue. On my side the problem was the USB3 cable. It was working fine with my Honor 9 (backing up the WhatsApp folder, like @Willeke did :slight_smile:) but not with the FP4. There the connection did break down right when I started the copy process.
When I used the USB2 cable from the Honor 9, the copy process was stable. But as USB2 with so many files is just too slow, I used the strategy with zipping the files in advance. Then it is much faster.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.