Working out a special software-related battery problem

There are several threads about this. Unfortunately they are mixing different issues: defective batteries, bad connections (there are different length of micro-USB, the shorter ones won’t work with the phone in the protection cover) and so on.
I started this new thread, because I want to describe a special charging issue, which is in my opinion pure software related. It is hardly to reproduce because it happens only now and then.
The facts: After plug in the USB-Cable the phone seems to charge. The red LED is on, the battery icon in the status bar is twinkling and there the lightning to be seen. However, it does not. After some time I noticed, that the charging percentage won’t change (not up, not down). When I unplug the phone this time, the percentage fells immediately on a lower value, depending on the length of time the “charging” was. This happens with different charging devices (USB-hub, CoolerMaster laptop power device, laptop-USB-port.
I was able to capture this behavior with screenshots. The first one was taken before the cable was pluged off, the second two minutes later after plug off:

Sometimes it works again after reconnect, mostly it don’t. One thing seems to help: a reboot. I took some photos in a testing situation.
First pictures shows the phone with red charging LED, but the indicator in the power supply is just green. The multimeter shows the voltage (4,998), the second picture shows the current (0,004 A), its nothing.

Then I made a reboot. Just during the boot screen the red LED from the power supply get red, and the current raises up to 0,481 A, which is quite normal:

So this can’t be hardware related, because I changed nothing between the two pictures.

Why do I write this?
First it is an issue, which should be solved. It is very difficult to notice, whether the charging is working or not.
Second, I’m afraid that this could damage the battery. If I try to charge a quite empty battery and it won’t work, the battery got discharge. It seemed, that the software to control this had completely stopped, so it cannot take notice of a fully discharging of the battery, which is very bad for every Li-battery.


I changed the category from Help to Software and Apps.

I guess, if you mean “software related”, you refer to a lower level hardware driver, or something similar? I don’t believe the OS handles charging tasks.

Could you, @Marco or @anon90052001, comment on this?

I agree to the category. I had in mind, that there is a categorie about bugfixes, but I didn’t found it.
And Yes, I mean software at any kind. But the deeper the bug is, the more phones might be affected, not only fairphones.
And I forgot to say, that I updated to 1.8. It was a bit bumpy, but it worked. The behavior described above happend before and after the update.

Noticed the same thing on mine while trying to charge it via the usb port of my Thinkpad T530 at work. USB mode was set to charge only. Never had any issues while using dedicated chargers, though. But the battery statistics are borked and mostly useless anyway with battery usage by apps not even being displayed.