WLAN and IPv6 issue (is stateless DHCPv6 an issue?)

Today I moved from the FP2 to FP5. The copy process as recommended at https://support.fairphone.com/hc/en-us/articles/10464413605137-Switch-to-your-new-Fairphone worked flawlessly. So all apps are also present on the new phone, All available software updates have been applied, too.

An interesting issue I have found: The WLAN always appears and disappears. Only when I disable router advertisment on my pfSense firewall then I get a stable WLAN connection but with IPv4 only for all devices in the LAN.

So I would be great to put this as a bug/issue for the next Android OS update. It also may be helpful when there are some advanced WLAN setting to set the FP5 into IPv4 only operation for example as a temporary workaround.

If somebody has a working IPv6 dual stack Wifi connection on the FP5, please provide some details about the used router (model, firmware release and configuration details).

1 Like

i bought a fp5 and have a router that use ipv6 for lan but use ipv4 to connect to the internet. i maybe able to test it

For this you’ll have to contactsupport .

1 Like

IPv6 works for me on FP5 with an ipv6-test score 18 of 20 (only incoming ICMP is disabled).
Router: Fritzbox 5490
WAN settings: Native IPv6
LAN settings: RA enabled, DHCPv6 disabled (SLAAC only)

Thanks for all your feedback.

In the meantime, I found a working way: On the pfSense, a DHCPv6 server must be active (pfSense also wants a defined DHCP address pool even if you intent to use stateless DHCPv6 with a SLAAC address). But on RA (router advertisment), you have to choose the last “stateless” option.

After that I was able to allow my FP5 join into the home wifi after a reboot without the periodic disconnection effect and it even commincates fine to IPv6 reachable web sites. BTW: When you set DNS servers on the DHCPv6 server as well as activating RDNS on the RA, then both Microsoft and Android clients will be happy. :slight_smile:

Hey, since you transferred over your data from an old fairphone, you might have ran into a similar situation as me.
My network settings got copied over, but I have a static ip set for my phone. So my old phone and the Fairphone were competing for the same IP, since the Fairphone copied over the static ip setting from the old phone.
I hope your issue is also solvable with something simple like this. Copying over data from your old phone is a double edged sword sometimes haha

Thanks for your comment.

I always has use DHCP on the IPv4 side as well as SLAAC on the IPv6 side. I also discovered the new privacy feature with the random MAC address which can be disabled for the home wifi network. So in my case, I just had to define a new static IP address assignement on my Linux DHCP server (I am running a Samba AD infrastructure), so both phones can run simultaneously without any IP address conflict.

BTW: The static IP address assignement is especially used for the MyPhoneExplorer app.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.