Wifi stopped working

My Fairphone2 has been working fine for 2+ years, but for the last week or so it has been unable to connect to any wifi - neither at home, at my friend’s place nor at the local public wifi hotspot.

When I try to connect using the settings -> wifi page, I see it go through: saved, connecting, obtaining IP address, connected and then “wifi-connection failure” (all in about a second). While going through those steps, the wifi symbol quickly appears in the menu bar - but disappears again instantly.

Coincidentally, I installed a new DNS proxy at home recently, which is working fine for all of my other gadgets - I could imagine there being a problem with that, but not when using a public wifi or my friend’s wifi.

I’ve tried rebooting, forgetting the connection and re-configuring, DHCP and fixed IP addresses but what I can’t find is anything to do with DNS, or any kind of logfiles with more detailed error messages.

I assume that the phone is trying to connect to a server on the internet and failing, which it then attributes to “no internet”. Is there a way to completely reset the networking caches (e.g.: flush the DNS cache)

I’m running Fairphone Open 18.04.1, I’m not using a http proxy.

Thanks in advance for any tips!

still no information, logs etc, however, after reading some more posts here I checked the app caches via settings -> apps. There I discovered the “wi-fi privacy police” app which seems to block wifi traffic so badly that the connection is dropped. Disabled the app, everything is back to normal.