Wifi-selection dialog buggy?

Hi,

my FP2 with most recent software update (1.2.8) seems to have troubles connecting to my wifi-hotspot (which leads to a closed LAN instead of the internet).

At first I connected and it just worked. Then I moved around, lost connection and tried to reconnect as soon as the signal was strong enough again. But I didn’t succeed (not even after a reboot - rebooting the accesspoint solved the problem until I loose wifi signal again; rebooting the AP isn’t necessary with other smartphones).

Then I found out that the wifi-selection tool behaves strange in several ways. Sometimes it tells me that I’m connected but I am definitely not. When I open the advanced dialog I see that it’s oscillating between “connection will be established…” and “connection saved” all the time.

Another minor problem is that the advanced wifi-dialog is hard to tap because the buttons are opened behind the main-UI-buttons (dunno what’s their name), see this screenshot:
imgur.com/fVT9qm5

Another issue in this cause is that the FP2 tries to look up for system-updates continuously while I’m connected to the non-internet-hotspot and I can’t find a way to stop it from trying.

Aaaand last but not least another network related issue: The mobile connection symbol on top of the screen tells me that my mobile connection is edge, 3g (btw the 3g-symbol is of a lower resolution than the other mode’s symbols), hdspa, hdspa+, alternating in a ~2-3sec. interval all the time. It’s changing really fast and I haven’t experienced this with my former smartphones on this exact location. I have suspect this behaviour might be linked to the fact that the battery-performance of my FP2 is really poor (about half of the standby time I had with my previous phone - Z3 compact).

It’d be nice if someone could help me with these problems. Otherwise consider this posting as some kind of bugreport.

Sometimes forgetting the network, and the re-adding it solves some of the weird glitches (but sometimes it doesn’t). By the way, is your access point running in 2.4Ghz or 5Ghz mode?

This is a known issue and is included on the bugs list:
https://forum.fairphone.com/t/wifi-more-settings-behind-navigation-buttons-still-in-1-2-8/12292?u=johannes&source_topic_id=16836

The system updater will check for updates on just about every network state change. As your network is LAN only it spends a long time trying. I haven’t yet seen a solution other than disabling auto start of the updater app - but this was for the FP1 which allows root access. Not sure how this would work on the FP2.

For the mobile network issue - as far as I know you’re the only one to experience this so far (unless I missed the relevant topic). Have you tried removing and reinserting the SIM? Take care not to damage the pins if you decide to try.

Side note: the forum is a community forum, Fairphone staff do occasionally read topics, but far from all of them. Consider filling in a support request if you want to make sure Fairphone is aware of your issues.

Thanks for the quick reply!

I tried that now - and it worked, although I was waiting for an ip-address for at least a minute. Anyway, thanks for the workaround. But I hope they’ll get it fixed soon; re-entering the wifi-password each time I’ve lost connection is a nuisance. It’s a simple 2,4Ghz AP btw.

At least they know about it - thats’ quite something.

I just checked if simply disabling this app would help - not possible. But ok - this is just a minor bug I can live with… as long as it’s not the cause for the poor battery performance.

Actually i had a similar suspicion and found out that my SIM, being a nano SIM with a loose micro SIM frame, is slightly thinner than normal micro SIMs. So I added a small piece of thick paper in the Slot to apply some more pressure to the pins. To no avail though. Gotta add another layer of paper maybe next time I’ll have it open again.

But I will report the issue to support if I can’t get it solved.

Just be careful with the pins, as there have been some reports of users who accidentally ripped the pins from the motherboard when they got caught between the adapter and the SIM card!

Thanks for the info. I’ll be careful when removing the SIM.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.