Wifi seems to be constantly activated

Hey @paulakreuzer and the community!

Here is one more bugs, based on my experience, that is not on the list:

The WiFi (on my Fairphone 2) seems to constantly be ativated, as shown by a long uninterrupted bar in front of the WiFi section in the battery consumption details, knowing I almost never activate it - the icon in the menu is grey and I even have desactivated the automatic use of WiFi for locations to try, without any difference. NB: an exclamation mark sometimes appears for a fraction of second when I scroll down the grey menu from the top of the screen, even though the WiFi icon is supposed to be off.

I am especially wondering if it would drain the battery, which is not making the day at all, as soon as the usage seems to be a bit frequent, not even really intense…

Anyone has the same pb? Any idea how it could be fixed?

1 Like

Well the topic about the list of bugs is not the right place as it would get very confusing if we discussed all issues there, so a new topic is better and since one of your issues is already discussed (and solved I’d say) that leaves one new topic about your second problem.

Just edited it :wink:

I can confirm to have a unbroken bar in the WiFi section of the android battery stat screen, although it was at least sometimes disabled.
But I observed it only sometimes. But I would doubt that we can claim this for a high battery consumption, as WLAN is not one of the highest battery usage in my opinion.

But in general you are right for sure, that this WOULD be a non-neccassary battery consumption, if the WLAN module indeed is switched ON, although we told Android that it should be switched OFF.

One way to check could maybe to observe the logged-in devices at the WLAN-Router (e.g. at home), and check if it fits to the android reported WLAN on/off times…

1 Like


I’ve tried looking for similar posts but couldn’t find anything, sorry if I’ve missed something.

The last week my FP2 has been running out of battery very fast. Often within an hour it’ll go from around 25% to switching itself off, even if I’m not using it at all. I checked the battery usage and it shows that the wifi is on pretty much all the time. I don’t use the wifi at all when I’m at work and at home only turn it on to check things. I rarely leave it switched on when I don’t have the screen active. I’m getting the battery usage reading shown below:

Does anyone know how to solve this and make sure that the wifi isn’t always draining the battery?



Did you turn off the “…” - “Advanced” - “Scanning always available” setting?


Thanks very much. That’s helped a lot. Still poor battery life but lasting long enough to still be useful.

1 Like

For me it was “Location” that was causing the uninterrupted Wifi bar in battery stat.

The only solution I found is to go on “Location”, then activate the GPS, change the mode to “Device only” and stop the GPS. This will deactivate the Wifi consumption in the battery stats.
But next time you will use your GPS, it will automatically be set up to “High accuracy”… The only thing that works for me is when I stop the GPS again, I go to “Location”, then “Device only” and then stop the GPS.