English

Wifi is disconnecting after 10 minutes in standby

##Info:


##Workaround:


##Original Post:

I found several posts concerning wifi issues, but none of them looks like it already covers the problem I am facing.

On some days or certain circumstances the wifi connection drops continuously after 10 minutes. E.g. when starting using Spotify and turning the phone off, it will work and play the music without problems for exactly 10 minutes. After that, the wifi will be switched off and the mobile connection will be used. A slow/bad mobile connection will lead to a skipping playback, which made me discover this issue. When reactivating the phone the wifi will be reconnected immediately and after a while the skipping will stop.
I did not investigate this in full detail, so I don’t have any clues why it sometimes works and sometimes not. But when it occurs it is reproduceable for an unspecified time frame.
The wifi setting for standby behaviour is set to “always” and the phone is in a place with a good connection to the router.

Is there anyone else encountering these issue or is someone able to reproduce it?

Cheers,
Freubert

5 Likes

Hi,

I also have this issue, and so does my boyfriend. I have checked all options I could find to keep the connection alive, including some programs that apparently can keep the connection alive. But it didn’t seem to help. :frowning:

I guess I have the same issue. I didn’t recognize your behavior, but what I can see is the “exclamation mark of death” as described in this topic. When I try the workaround the exclamation mark is gone. But the next time I check my phone it show up again. So obviously it was turned off during standby…

Same here! I noticed the mobile data Symbol onec i reactivat the phone. It skips back to the wifi mode then…

I have sometimes the same issue (“but no exclamation mark of death”).
WLAN setting is at “always on” and I can see the WLAN symbol just appearing at the moment I enter the lock screen.
But I also have the feeling that it is not always…just sometimes…But I could not find any regularity.

Luckily I don’t use the mobile data and have not problem with this.
I find it just annoying, that the FP2-WLAN does not behave like expected.
Furthermore I have the subjective feeling, that the WLAN (activated but not used, FP2 in standby) eats quite some battery. To that I am not used to from my FP1 - where WLAN on/off did not make any difference in battery consumption - that was very good!!

I’m seeing the :grey_exclamation: as well (permanently), but obviously not the one of :skull:. When I have the :small_red_triangle_down: with or without the :grey_exclamation: the wifi is always used. I can tell that, because my mobile connection inside my house is very slow/bad connection.
I just checked that the workaround for getting rid of the :grey_exclamation: is working as well, but objectively makes no difference on my device.

I didn’t stop the time but my FP2 also loses the wifi connection in standby.

Mi wifi works well. May I ask if you use any energy saving options? Some years ago, I had a similar issue with a laptop. As soon as I switched off the energy saving mode, it worked as it should…

1 Like

Which energy saving options do you mean? The only one I know is the Energiesparmodus (power saving mode?) which can be activated automatically at 15% or 5% of battery charge. Are there any other modes somewhere in the settings? I didn’t activate anything actively since I have the phone.

To be honest, I don’t know much energy saving options, since I don’t use them. It was just an idea, that the problem might be related to it. For example there is an option in the advanced wifi settings, about if wifi should always be active in standby mode.

IMHO if you go to settings->battery->battery saver and you turn it to “on” it’s always on and not only at 5 or 15 percent.

That’s true, it’s permanently on when you turn it on manually. But when it’s turned off and you have either 5% or 15% selected from the drop down it will be activated automatically as soon as the battery charge reaches that percentage. You can see that it’s active by the orange colour of the Android status bar as well as the permanently shown notification.

Hi, energy saving is off for me and the phone disconnects always after a couple of minutes. This is really annoying if I use a installed softphone and the connection always breaks then.

However it really seems to be connected to: https://forum.fairphone.com/t/wifi-reconnection-problem-exclamation-mark-after-reconnecting/11753/9

Google lead me to:

http://forums.androidcentral.com/android-5-0-lollipop/484781-why-there-exclamation-mark-beside-wifi-lollipop-5-0-2-a.html

Where users reported for a Moto G that putting the SIM card into another slot helped. As i have 2 SIM-cards I switched them in the slots. Voila: no exclamation mark anymore. So for me I get no exclamation mark if the SIM-card with mobile data is in slot #2.

Hope that helps
Frufo

Did this also solve Wifi disconnection problem for you (i.e. does it happen for you only when you see exclamation mark)?
I’ve checked my logs and Wifi remains connected during hours (screen on or off doesn’t matter). There’s no exclamantion mark for me with Wifi connection as I’m turning on mobile data only when there’s no Wifi available.

Hi Volker, sorry it seems I was too quick. It seems it was merely the reboot which only temporarily fixed it. After some time the exclamation mark came back and with it the connection issue.

Th exclamation mark seems to be only there when mobile data and wifi is enabled. At least only disabling Wifi + enabling it again does not make the exclamation mark away but disabling wifi + mobile data and then first enabling wifi and afterwards mobile data does for some time fix the exclamation mark.

Frufo

Hi frufo, for me it’s reproducible: wifi + exclamation mark only appears when mobile data was on while wifi connects.

@Volker and @frufo:
Until now we have no prooved connection between exclamation marks and de-activating WLAN, right?
Therefore your discussion seems off-topic and you could continue there. Or did I missed anything?
I will also ask there about the 10-min-issue.

For sake of completeness:
Inside the battery statistic the WLAN bar is also discontinued when the WLAN does switch off (after 10 min, but only somtetimes). I am using 2.4GHz only and have “Always on” enabled and no battery saving enabled. I see this behaviour also without having seen the exclamation mark and I normally have mobile data switched-off.

Any further clues until now?

Hey,

I’ve got the same wifi-problem. After some time I could find some “habits”.

The problem appears usually, when I leave the wifi-area (i.e. leaving the house) and let the wifi on. Now, when I return to the wifi-area, my FP2 see my wifi, but doesn’t connects to. After a few seconds (~30sec) it connects to the wifi but lose the connection after a few minutes when I turn off the screen. A reboot fixes the problem and the FP2 still holds the wifi connection.

When the wifi connection is disabled (without disconnecting first from the wifi) before leaving and enabled after returning the same behavior occurs. However, the FP2 does not act like this when I’m connecting to the wifi at my working place or at uni (does anyone noticed the same behavior?).

My Settings:

  • Settings > Wifi > Advanced > Wifi always on
  • Settings > Wifi > Advanced > Frequency automatic
  • No energy savings
1 Like

I want to add that this bug is still persistent with FPOS 1.2.8.

For sake of completness: Bug reproduction:

  1. If you freshly disable and enable WLAN, all is fine. WLAN will stay connected with your WiFi, also in Standby mode of the FP2.
  2. Now to provoke the bug: Enable WLAN, if not done before, and send FP2 to standby (PowerButton)
  3. Leave the coverage area of your WLAN without connecting to another WLAN, for ~10mins
  4. Come back to your own WLAN and wait 1 minute
  5. Now switch ON the FP (from standby) - probably you will see, that in this seconds the WLAN is just beeing reconnected, instead of doing it during the first minute back in the WLAN area.
  6. From this moment on, you should see the bug, if you don’t change the WLAN status:
  • Ensure WLAN is connected as before,
  • send the FP2 to standby for e.g. 10-15 min (maybe less),
  • switch on FP2 and you will see that WLAN is NOT connected anymore and is doing a reconnect in this seconds.
  • You can repeat this with sending FP2 back to standbay and wait 10-15 mins.
  1. You only can leave this faulty mode by disabling WLAN and re-enabling. Than everything is fine, until you leave again your WLAN coverage area.

As often stated above, WLAN settings are set to “Always on” and no further power saving mode is enabled, only 2.4GHz is choosen.

Hi,

When I’m connected to a WiFI network, and the phone goes into standby, it loses the connection and switches to 3G. So my Jabber connection is renewed over 3G, which causes unnecessary status updates and traffic usage.

In Settings / WiFI / Advanced, “Keep WiFi in standby” is set to “Always”. It just doesn’t work… anyone else with this problem?

FP2, FP OS 1.2.8