Wifi is disconnecting after 10 minutes in standby

Did this also solve Wifi disconnection problem for you (i.e. does it happen for you only when you see exclamation mark)?
I’ve checked my logs and Wifi remains connected during hours (screen on or off doesn’t matter). There’s no exclamantion mark for me with Wifi connection as I’m turning on mobile data only when there’s no Wifi available.

Hi Volker, sorry it seems I was too quick. It seems it was merely the reboot which only temporarily fixed it. After some time the exclamation mark came back and with it the connection issue.

Th exclamation mark seems to be only there when mobile data and wifi is enabled. At least only disabling Wifi + enabling it again does not make the exclamation mark away but disabling wifi + mobile data and then first enabling wifi and afterwards mobile data does for some time fix the exclamation mark.


Hi frufo, for me it’s reproducible: wifi + exclamation mark only appears when mobile data was on while wifi connects.

@Volker and @frufo:
Until now we have no prooved connection between exclamation marks and de-activating WLAN, right?
Therefore your discussion seems off-topic and you could continue there. Or did I missed anything?
I will also ask there about the 10-min-issue.

For sake of completeness:
Inside the battery statistic the WLAN bar is also discontinued when the WLAN does switch off (after 10 min, but only somtetimes). I am using 2.4GHz only and have “Always on” enabled and no battery saving enabled. I see this behaviour also without having seen the exclamation mark and I normally have mobile data switched-off.

Any further clues until now?


I’ve got the same wifi-problem. After some time I could find some “habits”.

The problem appears usually, when I leave the wifi-area (i.e. leaving the house) and let the wifi on. Now, when I return to the wifi-area, my FP2 see my wifi, but doesn’t connects to. After a few seconds (~30sec) it connects to the wifi but lose the connection after a few minutes when I turn off the screen. A reboot fixes the problem and the FP2 still holds the wifi connection.

When the wifi connection is disabled (without disconnecting first from the wifi) before leaving and enabled after returning the same behavior occurs. However, the FP2 does not act like this when I’m connecting to the wifi at my working place or at uni (does anyone noticed the same behavior?).

My Settings:

  • Settings > Wifi > Advanced > Wifi always on
  • Settings > Wifi > Advanced > Frequency automatic
  • No energy savings
1 Like

I want to add that this bug is still persistent with FPOS 1.2.8.

For sake of completness: Bug reproduction:

  1. If you freshly disable and enable WLAN, all is fine. WLAN will stay connected with your WiFi, also in Standby mode of the FP2.
  2. Now to provoke the bug: Enable WLAN, if not done before, and send FP2 to standby (PowerButton)
  3. Leave the coverage area of your WLAN without connecting to another WLAN, for ~10mins
  4. Come back to your own WLAN and wait 1 minute
  5. Now switch ON the FP (from standby) - probably you will see, that in this seconds the WLAN is just beeing reconnected, instead of doing it during the first minute back in the WLAN area.
  6. From this moment on, you should see the bug, if you don’t change the WLAN status:
  • Ensure WLAN is connected as before,
  • send the FP2 to standby for e.g. 10-15 min (maybe less),
  • switch on FP2 and you will see that WLAN is NOT connected anymore and is doing a reconnect in this seconds.
  • You can repeat this with sending FP2 back to standbay and wait 10-15 mins.
  1. You only can leave this faulty mode by disabling WLAN and re-enabling. Than everything is fine, until you leave again your WLAN coverage area.

As often stated above, WLAN settings are set to “Always on” and no further power saving mode is enabled, only 2.4GHz is choosen.


When I’m connected to a WiFI network, and the phone goes into standby, it loses the connection and switches to 3G. So my Jabber connection is renewed over 3G, which causes unnecessary status updates and traffic usage.

In Settings / WiFI / Advanced, “Keep WiFi in standby” is set to “Always”. It just doesn’t work… anyone else with this problem?

FP2, FP OS 1.2.8

Sorry, missed your post initially. In the other topic the OP clarifies that they’re also losing cellular connection when in standby (though to be fair, there’s probably another topic about that somewhere too). As you’re describing only issues with wifi, I’ve moved your detailed description into this topic (which is seems more relevant).

I’ve also moved @j-unique’s post here, as it sounds like the same problem.

The bug exists also in the FP Open Source OS 16.04.0.
Did someone find a workaround for this?

For me, this problem seems to be gone with FP Open Source OS 16.04.0.

I just did some tests:
1 .Start a big download (1GB) with wifi on
2. Turn screen off/ Set FP2 into standby
3. Turn on again after 30minutes

Wifi symbol was hidden after I turned the FP2 on. After ~5 seconds the FP2 reconnected to the Wifi.
Also the majority of the download was done with 4G instead of Wifi (Could be really expensive in some cases…).

I have experienced this issue a few times, but not always.

Since I use connection to my wifi at home for smart lock, disconnection is obvious as I get asked for a password then.
Running FPOSOS, I didn’t have this problem for 2 weeks. Just a couple of days ago it appeared, after putting in my pin I saw the wifi symbol reconnecting.

I don’t know why and when it disconnects, haven*t yet found a pattern. Though, while charging the phone does not disconnect wifi (that I realized).

Now, my FP2 (still with FP Open OS 16.04.0) has started disconnecting again… :frowning:


I got a Fairphone two weeks ago, notice that it often loses connection with the wifi. Have been following this thread with interest, have a few things to try now. Hope it gets better.

1 Like

I also have this issue for a longer time. It seamed better but since the last update it is present again. I use the SONOS app and each time I want to check/change loudness or anything after a short time the WIFI connection is lost and the app tries to reconnect. That situation is very annoying - please repair this bug.

Still reproducable using FOS 16.06.0. The “Always on”-option doesn’t seem to work, when the phone isn’t charging.

Update: I experienced a couple of times that Wifi also turns off even while charging.

I had to use my FP2 with Fritzphone-app as spare for a wireless phone and found, that the wifi-connection gets lost after 10 minutes. My Fritzbox showed this quite well. The settings/wifi/advanced is set to “Wifi is always on”. No energy-saving, frequency-band: 5GHz, distance from Fritzbox: about 2,65 Meter. My OS: FP2_gms56_1.4.2

My wife’s Wiko-phone with Lollipop stays connected on standby (setting is Wifi off on locked state).


1 Like

Just a little detail to add - my wifi even disconnects after some time in sleep mode if mobile data are turned off. It annoys me because messages won’t arrive at time. Also turning on mobile data and wifi at the same time seems a bit inconvenient since it just wastes battery (wifi is more battery efficient than mobile data) and makes me run out of highspeed data way sooner.

I could solve this problem - for me it works now as it should. And I did:

Wifi is on
uncheck "Wifi off in sleep mode"
switch wifi off
switch wifi on
connect with your wanted network

Still having this problem in current open OS (16.07). If I wake up my phone at home I can see the mobile data is on and wifi shows an exclamation mark. A second or so after wakeup wifi connects and my data connection turns off.
This means that all mobile data goes over my data plan even when I am at home within good reach of my home wifi. This is quite annoying as it uses up my data plan without reason.
I have “leave wifi on during standby” set to “always”, so that is not it. :frowning: