WIFI is connected but still doesn't work (O2 router Fritz-Box 6431)

Don’t close the topic yet. The Wifi Connection Problem with the O2-Router occured about 2 weeks ago on my phone. So far I didn’t solve it. I wasn’t aware that so many people are having the same problem (everything as mentioned in other posts, except that very few times a day my WiFi works).
I would like to try the solutions mentioned above tomorrow. Would be nice if you wont close it until than. Thanks!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Unfortunately the problem is back, at least for me. After spontaneously fixing itself (I still don’t know what happened), the grayed-out wifi icon is now back with my O2 router after I updated to Kola Nut.
Again the problem is only with this router and it occurs occasionally. If I switch wifi on and off several times it will work for a while. Restarting the router sometimes also works. I’m flummoxed.

Lesson: If you have this router and haven’t updated yet, don’t do it just yet.

I’m not sure if this is the case here but sometimes after a OS update you have to re-enable Google’s Synch function by downloading any app from the play store before the wifi symbol turns blue again.

It think Paul is right.

We discussed related issues here and here, when resetting/updating, your phone gets issued a new Android ID and Google Cloud Messaging ID (I forgot the correct term and acronym). Either you restore from a backup (TitaniumBackup can do this, I think - at least for the Android ID, this is even prompted on opening after the app after an update) or you re-register your apps by turning off sync and/or messaging capabilities in each app.

HTH. :slight_smile:

Thanks for your help, guys. However I honestly don’t think that this is the problem, because I do get a connection with any other router, and even on my router after fiddling I get it to work for a while… until I leave the house, lose the connection and when I come back it’s gray again.

As I understand, if the problem were the Android and/or Cloud Messaging ID, the problem would be consistent and occur on any WiFi connection, right?

I really do think the issue is somehow with the router, but then again I’m not techy at all and what the hell do I know :wink:


You are right that sounds like it’s the router. Did you try contacting O2? Or Fritz(?)?

Briefly said: not just a wifi but an internet problem!?


I am having a o2 problem too (o2 box 6431). It seems to be rather similar to the problem described in this thread. But only similar!
For me it is hard to go into internet via wifi although some wifi checking apps (“Wifi manager”, “Fing”) show, the wifi is working fine. But when I try to access the internet (e. g. via the “Inetify” app or simply via browser), it won’t work. The problem seems to be specific to o2. But it is not just o2 on its own, since my family doesn’t have any problems accessing the internet via wifi with their smartphones (Samsung). So I am afraid, it is the Fairphone that does not deal with the o2 box rightly :weary

Who can help?


Do you have a MAC filter enabled? Is your phone listed there?

At home I have no MAC filter aktiv, but in my office I have, with my Fairphone’s MAC beeing registered, so it is allowed to enter the internet.


Try accessing

Hi guys,

i´ve had the same Problem. My wifi connection didn´t work at home. I could see the wifi icon - at the beginning in blue and then, sometime latter, in grey. Off course all the apps that are working with internet connection also didn´t work. That´s the reason beacause i´ve used all the time my O2 mobile connection.
Off course i have the same O2 box 6431.
Four days ago i read this forum and i tried only the solution from Frankenpflaz WIFI is connected but still doesn't work (O2 router Fritz-Box 6431)

If you follow the instructions of that link, you would see that once you are log in in your o2.box site and see the site “Heimnetz” - “WLAN” without style (ohne Stil) you have the possibility to change one parameter that otherwise is no visible in the normal view of that page. With out this i´d never find a solution to this annoying issue.

I´ve tried this last 4 days and my wi-fi works PERFECTLY since then at home! so you try!


  1. go to o2.box
  2. Log in
  3. Go to Heimnetz
  4. go to WLAN
  5. In firefox menu go to view (Ansichten)
  6. go to “page style” (webseiten Stil) . then choose without style (keine Stil)
  7. The Site change like in Text form.
  8. Go to “WLAN Modus” (You can´t see this in the Standard Style view!!!)
  9. Change manually to 20 Mhz
  10. click on Safe (Speichern)
  11. Then again: View (Ansichten) - Website Style (Website Stil) - Standard Style (Standard Stil)


I would love to hear that actually works and we won against O2 once more!
i don´t know what could happend without this forum. Specially thanks to Frankenpfalz! who is actually who found a solution for me!


I’ve used 2 versions of Fritz!Box with 11n in 40Mhz “mode”. My Fairphone had 0 issues. Maybe it’s some incompatibility with this particular Fritz!Box model? I think you should notify AVM also.

1 Like

Many thanks to Frankenpfalz and Sebastian for their good piece of advice. I am testing that solution now. I going to report.


After 24 h of testing I happily report that this solution seems to work for me perfectly. Once again thanks to all who have worked on it.

It has been stated here before already, but I’d like to repeat two important things to the issue:

  • The problem has nothing to do with Google or Non-Google and therefore nothing with the colour of the wifi symbol. I am running a de-googled Fairphone and thus my wifi symbol is always grey.
  • Secondly, it is not a wifi issue but an internet issue in the way, that the connection from the phone to the router was perfect while it wasn’t possible to connect to the internet. At least, my wifi status app showed a perfectly working wifi connection and also showed all machines having connected to the wifi while it wasn’t possible to get any website loaded to the browser.



I am glad to hear that Kristof!
I have no problems since then ( 7 days !!!)


I’m not affected, but I think a big KUDOS to @Sebastian is in order. Should this solution go somewhere more visible, perhaps? Also, have you contacted AVM about this and got any response?


I was affected for 4 weeks as well (after receiving a new modem by O2 due to moving the flat). I am so happy I found this threat, the solution of Sebastian and Frankpflaz directly helped!

Thank you + vielen vielen Dank!

1 Like

The solution can be found here.