Wifi @ Fritz.Box after latest Update Android 11

Hello! :slight_smile:
A few days ago an FP4 update / Android update was installed. I am not 100% sure, if this update is the cause, but it seems so: I cant connect to my wifi FritzBox anymore! The Network SSID is shown, the connection is maybe for 1-3 secounds established, and then the connection is lost. Signal is very strong. I tried a lot at the AP: enabled 5G, set another Passwort, tried to connect with WPS, disabled WPA3…
Have someone an idea an can help me? I searched a lot in google and here in this forum with FP4 and wifi problems: All I found was older and about FP3 and so on… :-/

greetings and thx!

Maybe the old problem is back.
Try using only 2,4GHz WIFI.

Can you try this?

Who knows, maybe your WiFi is using a channel that your Fairphone may not use due to localization settings. Like channel 13, or maybe other reasons. Without knowing your WiFi we can only guess. Maybe also share a screenshot of your WiFi settings on your router.

I had a similar problem that was caused by a broken IPv6 configuration on the Fritzbox. Apparently Android tries to do something with that and then decides that the network is crap and disconnects. I have yet to find the exact location of that setting.

Edit: I think I found it. It was a broken DNSv6 Server setting. Fritzbox → Home Network → Network → Network Settings → IPv6 Settings (translated from German, so the actual labels might be slightly different)

I had similar problems with my Fritzbox 7490.
Sometimes it works well and suddenly it doesn’t had connection to the internet, but WLAN signal was strong.

I changed the names of the ssids, the 5ghz now has a different name.
I reconnected the fp4 to the newly given ssid and deleted the old 2,4GhZ network on the fp4.
Do not forget the other WLAN devices if they can use 5ghz.
Now it works like a charm.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.