Why do I get "Call not sent. No valid number entered."?

Sometimes when I use the basic dial pad to place a phone call, I get a popup showing a message “Call not sent. No valid number entered.” with just the OK button. In all cases, I’m sure I want to dial a correct number.

When it happens, it usually goes like this:

  1. I open the standard Fairphone (2nd batch) dial pad
  2. I:
    1. press the buttons that form a partial name until the name of the person I’m trying to reach comes up in the list, then press the horn button next to that person, or
    2. press the buttons that form a partial phone number until the number/person shows up in the list, or
    3. dial a complete number, starting with +31 70 (for Den Haag in the Netherlands) or 070 (calling Den Haag from within the Netherlands)
  3. I select the SIM to use for this call (I have one private and one work SIM card, both active)
  4. I get the message “Call not sent. No valid number entered.” and can only go back or press OK.
  5. in rare cases, I get the “Select SIM” dialog again and the call is made after selection. In other cases, I go back to the dial pad like nothing happened.

What is happening here and how can I stop it?

I think I understand how you are trying to dial. When you use tap in the name, you have to make sure you don’t dial the partial number only.

When this is happening, can you see that the correct number is being dialled and that it’s not the partial number that you pressed to represent the name? I have done this a couple of times myself so thought it worth checking

@bencomp are you still experiencing troubles with dialing?

Yes, I do. It usually works the second time that I try, but it still annoys me when it happens.

Setting a phone number in “Settings > SIM management > SIM information: [SIM] > Enter phone number” for both SIMs did not help. I recently discovered however that neither SIM has a phone number in “About phone > Status > SIM status > [SIM] > My phone number”.

On the other hand, I haven’t tried to reset the phone to factory settings and see if that helps. Am I really the only one having this problem?

Stefan Brand schreef op 13-03-15 om 13:14:

Can it be that your Problem is similar to that one:


Phone number should not have brackets or slashes.

I have not experienced this. If it annoys you a lot, you should probably do a factory reset.

Sorry for not responding sooner. No, the issue is unrelated as far as I can tell.

I did a factory reset yesterday and didn’t get the message on my first call. But that was just the first call, I’ll hope to see that it has really been solved.

1 Like

I get the same thing - and I did a full reset of my phone recently, in hopes it would solve it.

I now get it about 1/2 of the time rather than 90% of the time.

No brackets, slashes, or non-numeric characters (i.e. if I dial 02036700550 (my office) it does it - the call goes through if I press OK or “back”.

Really annoying.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.