English

Weird battery drain episode

Last weekend I had a really strange experience with my Fairphone 2:

I was out looking for a geocache (so I had the c:geo app running, as well as OsmAnd, GPS enabled).
Initially, the battery was at about 50%. I had a very bad GPS reception for the first half hour or so, and only occasionally turned on the screen, draining the battery to about 45%.
When I went for the final (for non-geocachers: I wanted to find a spot with specific GPS coordinates), things started to get very weird:

While GPS and screen were enabled, I was loosing approximately 10% of battery PER MINUTE without the phone getting overly hot (the outside temperature was approximately 10° Celsius, so I couldn’t tell if the phone just wasn’t getting hot at all or if it was cooled enough by the cold air for me not to feel it). It was down to about 25% before I was realizing what was going on (so after about 1-2 minutes). I turned the screen off at that point, but the battery drain continued; I checked periodically and would say that overall, basically in 5 minutes 45% of charge had gone down to 1% (at which point the phone of course turned off automatically)!

Not sure if it’s of relevance, I’m running Open OS with GApps (pico), and currently the “Google Play Services” keep on crashing.

This was a single occurence so far, the battery discharges “normally” again now.

I’d be interested to hear if anyone had a similar issue or knows what could have been the cause? I’ve never seen such a fast discharge unless some app was stuck (and that was typically linked to the phone being sluggish or not reacting at all, which wasn’t the case here; also the phone would be getting hot, which I also didn’t notice this time).

The battery status (unfortunately I didn’t think of taking a screenshot) didn’t show any of the two GPS-using apps as using much battery - the highest-up items only where “Other” and “Display”, so of not much use in debugging this… Anyway, “Other” (Sonstiges in German) seems to always be high up on the list, if not the highest, what does fall into that category?

My last feature phone did stuff like that occasionally (well, not that dramatically, but still). Taking the battery out and putting it in again used to fix this for a while every time, so I betted on either the battery becoming not properly seated over time or the battery simply being broken somehow.

Perhaps you can see to it with some paper or stuff that there’s no way the battery could move in its compartment, so that would be ruled out as a cause.

1 Like

My phone has occasionally lost power dramatically overnight, with nothing obvious going on.

1 Like

Well, my FP2 has also a non-smooth battery indicator. Over 25 %, the discharge is “normal”. But below 25 %, it goes down by 1 % per 20 seconds. Maybe the battery indicator is not calibrated correctly.

1 Like

This was just a one-time thing so far; typically the indicator works quite fine. So I don’t think it’s a calibration issue for me, but thanks for the input anyway!

I’ve had things like that at times when using Maps.Me. I once lost 10% in an instant, or at least so it looked in the battery stats. Using the normal OS but with Google’s location via wifi disabled.

A post was merged into an existing topic: FP2 Battery Problems (drains quickly, CPU gets hot)

Please continue here: