Very slow internet

Hi guys,
I’m Form Austria and using Drei , the internet on my new FP2 is extremely slow (google browser, 9gag App, and so on) . but everything is fine with WiFi (but slow with mobile internet). Do you know what the problem is? How can I solve it?

1 Like

If I do understand right, your web-browsing is fast, if you are connected via Wifi and slow, if you are connected via mobile data? If so, what letter is shown aside zur bar graph of the mobile network?


Sounds like you are stuck on a 2G mobile network. Did you check the symbol next to the signal indicator? If it says “E” then you are only on a 2G connection (EDGE at best). If it says “3G” or “4G” it should be faster.
Another possibility is that your provider limits your connection speed. For example in Germany Congstar offers a “messaging flatrate” that is free (i.e. 0€) but only gives you 32kbit/s - even via 4G.

Yeah right!
No letter, its the R for roaming… Cause Drei can use also other network operators (I don’t pay for roaming… Cause it’s roaming inside Austria) do you understand? :slight_smile:

Is your “Drei” SIM card maybe set to “2G only”? Check it out at “Settings” - “Wireless & Networks” - “More” - “Cellular networks” (“Einstellungen” - “Drahtlos & Netzwerke” - “Mehr” - “Mobilfunknetze”) and change it if necessary. If the option is greyed out, you have to set the other SIM card to “2G only” before.

1 Like

It’s set on 4G/3G/2G … So I think it’s a different Problem… :pensive:

I don’t like it either that you can’t see the actual connection “speed” (G, E, 3G, H+ or 4G) when on roaming. Maybe you can force it manually to connect to the “real” Drei network just to see if you phone is actually “able” to use 3G or 4G. If not, there might be a problem with you APN settings.

Can you try the SIM card with another 3G- or 4G-capable phone and looks if it works with that other phone?

Yeah… That’s a bit weird.
I can choose manually a network (Drei) than there is mostly H+ , but after a while (or when I turn the mobile data off and on again it’s roaming again…

Ok, so it seems that your FP preferrs the other network, that maybe offers a stronger signal but a slower connection.

Do you really get H+ speed when connected to Drei?

Then you could just choose it manually in the list of available networks. Your phone should remember this selection.

But keep in mind that then it won’t connect automatically to other networks if Drei is not available.

1 Like

I often choose it manually, but like I mentiones before it skips back to roaming after some minutes

What happens if you disable data roaming? Does it disconnect completly?

1 Like

Yeah that’s right :pensive:

If you have Xposed Framework installed you can get rid of the “R”-sign for sim cards using permanent roaming via installing the module “Roaming Control”. There you can set up your actual network as saved network and enable “saved network roaming”. Now you can see the connections type/speed (E,3G,…).

Connection type: -> Settings/About phone/Status/Subs status

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.