English

Using TWRP on two phones

Hello everybody,

today I’m stuck using TWRP to backup and recover. First of all, my phone should be sent to france for repair. So what do I do without my phone? This simple case shows, that the level of redundancy is not sufficient. Today it shows, that the number of fairphones I own, directly affects the system reliability inverse proportional…

However, this is, what I did with phone A:

  • Removed old backups from SD-card
  • Reboot to TWRP
  • Backup to SD-card
  • cp -r /data/media /external_sd/
  • Poweroff
  • Remove SD-Card and insert into the computer
  • rsync -av /sd-card /whereever
  • Remove SD-Card and insert into phone B
  • Boot into TWRP
  • Wipe everything (but not the SD-card…)
  • //edit: I forgot to mention, that I create a new backup and delete it afterwards, just to make TWRP create a backup folder for the new device. Then, I copy the real backup to the newly created folder.
  • Restore (seems to work well so far)
  • rm -r /data/media
  • cp -r /external_sd/media /data/
  • chown -R mediadrm:mediadrm media

However, after reboot it stucks in the boot process with the fairphone logo, leaving the CPU temperature at 75 °C. I even tried to spare the last three steps and tried to restore the backup at phone A and now I don’t have a working phone at all; both phones don’t boot.

Does anyone have any idea, what I might did wrong or can help me to restore my phone(s)? Did I miss something? I worked with Nandroid-Backups several times before and they always seemed to be so very reliable. Now one might say something like “Your backup files were broken”, but then I wonder, what are backups good for, when they only work occasionally? Any suggestions?

best regards
biomüll

The steps should good.
Just some small doubts/questions:

  • why did you use rsync with your computer? This might change files also on your SD card, right? (well, I didn’t check what the options -av do…)
  • did you only do the steps mentioned? I doubt it a little bit as my experience is that in different devices the TWRP backup folder is a different one. So"restore" wouldn’t find the backup if you don’t the rename the folder.
  • which TWRP version did you use?
  • as you said you’ve done it before: might you use an older backup?
  • was your device encrypted? So you might also need to format data partition?

Hey Volker,

I maintain a copy of my SD-card in case I lose my phone (one of my phones, acutally…). rsync shouldn’t change anything on the SD-card, although its name might imply writing operations on both sides.

Yes, definitely, you are right, sorry for that, I omitted the hassle around the folders TWRP creates for every device. I’ll edit my first post.

The TWRP Version is the latest version, I think, let me look it up, twrp-3.3.1-1-FP2, yes.

I will see if I find an older backup. But to be honest - I don’t want an old backup, I want my recent backup, because that’s what I created it for, right?

The device is not encrypted.

1 Like

I occasionally had problems to boot an OS immediately after an OS restore by TWRP, too.

What always helped me in this case was simply installing the fitting OS version again over the restored state of the installation.
(Was mostly LineageOS, though.)

2 Likes

Hey AnotherElk,

that sounds good, I’ll give it a try. … … can I use “fp2-sibon-19.11.2-manual-switcher” for that?
I’ll better see, if I can find the original ROM image…
“fp2-sibon-19.11.2-manual.zip” sound better, doesn’t it?

I come back to you in a few minutes.

Why? What does the page with this file on it say what it does? What do you want to switch :wink: ?

  • Wipe [X]
  • Restore [X]
  • Reboot to fastboot, and ./flash-for-unix.sh from fp2-sibon-19.11.2-manual.zip [X]

Rebooting.
Change is in your hands…

It F***ing works, AnotherElk! Thank you so much! I’ll try to get my /data/media back, and then I will see, if everything is allright, but now my wife wants me to go out with her despite the storm warning. Different priorities, right? :slight_smile:

1 Like

Hello everybody,

now I was struggling with /data/media for a while.

  • rm -r /data/media
  • cp -r /external_sd/media /data/
  • chown -R mediadrm:mediadrm media

didn’t work out, while “mediadrm” isn’t correct and it should be “media_rm”, anyway. So I did a complete wipe again, flashed Fairphone Open one more time and followed the whole process to see, how it is supposed to be with /data/media.

chown -R media_rw:media_rw /data/media/
find /data/media/ -type d -exec chmod 775 {} ‘;’
find /data/media/ -type f -exec chmod 664 {} ‘;’
restorecon -FR /data/media/

Ok, now it finally works, thank you everybody and good bye sunday.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.