Using Sailfish OS on the FP2 - Experiences and Issues

Download Aida64! In the ‘Sailfish’ section you can find your Android base.

Thanks, I had forgotten about AIDA64. Already had that installed.

1 Like

OK, it’s an antiquity :wink:
I thought >=16.11 was necessary, but obviously I am wrong. I can easily differentiate between 16.11 and 16.12 with SFOS if I use 16.11, everything works, if I use 16.12, my FP2 reboots every 30 minutes. so I thought that you could tell me which would be the better base for, but obviously you have a very different configuration than me. thanks for finding out !

Yeah, I’ve been scared to do any messing with base firmware after following most of the relevant threads and seeing people have trouble. My ancient thing Just Works™ right now. It does spontaneously reboot itself, but we’re talking maybe once in multiple weeks.

Hello Bobbel,
you can change the user (and group) of the directory the sdcard is mounted to the user nemo:nemo. I have ‘drwx------ 11 nemo nemo 4096 Feb 13 12:32 /media/sdcard/79736ddc-8f01-4648-af7d-a158549fe027’ and it work.
Normally only the user nemo write too this device. The directories Pictures, Playlists, Videos and the backup files have the group privileged. I think this is while root processes write the files and the directories, but they always are able to write to this partition.

Question to all users currently testing Sailfish OS on FP2, have any of you observed the UI freeze after calls issue on this latest version?

1 Like

I have no UI Freeze and no black screens after incoming calls at all. But this problem was solved, after i calibrated the proximity sensor under Fairphone Open.

At the moment i have very stable and very Fast Sailfish on the FP2 (Thanks again, mal)
Here are my steps again:

Install Fairphone Open 16.12
Calibrate Proximity Sensor
Install Sailfish (alpha3) from TWRP Recovery
Flash old Modem from FP2-gms-1.5.1
Change the repository to sailfish

Upgrade to Sailfish

I have created 2 Manuals for Installing / Updating to Sailfish on the FP2
In English and in German.

just ask me on Telegram: @Explit or XMPP: if you need it.


i mal-, thanks for the update!
yes, I still experience these freezes from time to time. but as before, they can be resolved by two-finger, just as.
what is more of a problem: i experience an excessive battery drain. it occurs when the phone is lying on the table or in my pocket, with mobile data switched on (haven’t tried flight mode yet).
my setup is nearly like described by explit, with 16.11 instead of 16.12 as the only deviation.
cheers !

This is my personal bug-free configuration without battery drain and black screen on incoming calls:

Installed 16.12 complete via fastboot
Started Fairphone Open
Calibrated Proximity Sensor
Boot into TWRP Recovery
Installed SailfishOS on Top of Android via TWRP
Flashed only the Modem Files from FairphoneOS 1.5.1


Are you sure you have the correct firmware installed? (the other partitions included in manual installation zip) Those need to be from the old version (FP2-gms-1.5.1).

yes, i am sure. i have updated from, where i had 16.11 as basis with modem files from 1.5.1. before i updated, there was only the usual drain which has drastically grown. but to be absolutely sure: is there any way to check which modem i have?

unfortunately i can’t take 16.12, as i experience crashes/reboots every 30 minutes or so.

I then assume you didn’t reflash the Android base? You need to look in dmesg, journalctl and /usr/libexec/droid-hybris/system/bin/logcat for any repeating errors that could explain the battery drain.

thanks for your help! i have a lot of lines stating that qup_i2c is not connected, each followed by a line saying something about synaptics_dsx_i2c in dmesg.
but maybe i should contact you at irc, when i have more time ?

Well IRC is the best place for debugging.

1 Like

ok, atm i am not at home and can’t connect with terminal. i’ll come back when i have a real computer at hand.

Try to flash system.img from 17.01 which is out today. It works for me also so far… No Problems yet with SailfishOS

Update: 17.02 is out nad working good on the FP2

1 Like

sorry for not reporting back, I’ve been a little bit ill. nevertheless, updating to 17.01 solved the issue.

I am using SFOS now for a week, amazing work! Flashed from 17.01, used old modem files as proposed in the installation wiki, and updated to SFOS Everything works flawlessly so far except the camera in video mode. When i switch to video mode, the app crashes reproducible as soon as I start recording. Photos mode works. Let me know if you need further information, I am glad to help to debug this.

On Jolla phones, the notification LED is color-coded depending on the notification, e.g. green for missed call, blue for text message and so on. On FP2, the notification LED blinks always white, no matter what the notification is. Can we have the color-coded notification LED on the FP2 too?

1 Like

I’m thinking about switching to Sailfish OS. But apps like Threema or Telegram are important for me. Does the SFOS version for the FP2 supports android apps? Does it make sense to use titanium backup with SFOS or does a similar app exists?
And how do i flash the modem files from 1.5.3? I cant find anything about it.
Thanks for your answer!