USB Tethering doesn't work

I’m running Ubuntu 14.04 LTS on my laptop. When I connect my Fairphone 4 I can do file transfers, but USB Tethering doesn’t work. It worked/works fine with my Fairphone 2.
Can anyone help?

Maybe check that it’s set up properly in your internet settings. I’m posting this from my OpenSUSE TW desktop tethered through my FP4, but I had to do some manual configuration to get it to work.

Notable stuff:

  • The phone appears as 2 separate wired connections, only one works
  • I had to manually change it from “Share my network”, though that may have been because the only wired connection I’ve ever used with this PC was configured that way
  • I had to disconnect & reconnect through the KDE network widget to get it to work after I configured it correctly
1 Like

Is there a specific reason to stick to 14.04? I’m currently using 21.10 and USB tethering works out of the box.

Regarding that you have “just” two more years of security updates left (if you have ESM enabled, otherwise support ended 2019), you could consider switching to a more recent version of Ubuntu and maybe launch that one special application in a virtual machine running Ubuntu 14.04.

2 Likes

Hmmm, thanks NGnius, but I think I’m out of my depth here. I’m not a Linux techie, so unless a solution is very simple, like run this/these commands, or select this option I won’t really know what I’m doing.
To be honest, I probably do need to upgrade my somewhat aged system to a better and later one anyway.

Well, only that my experience of every other Ubuntu update (not even a full system upgrade) that I’ve tried is that it has broken something. But basically you are right and I do really need to upgrade my now somewhat aged hardware and software.
Also, although my background is in IT, I’m not really a Linux techie, so fixing anything that goes wrong is usually difficult for me.
I just though there might be a very simple solution to the USB Tethering seeing as it worked for my Fairphone 2.
Thanks for your advice though.