USB devices not working anymore


I don’t use USB devices with my FP2 often but I just discovered that all of them stopped working (FLIR camera, endoscope camera, TREZOR hardware wallet). The last time they worked might have been before the Android 6 upgrade.
There is power provided to the devices connected (at least on the ones where I can check this) and I know my devices and cables are working as I can use them on another Android phone I have.
Normally I would expect a popup to make me choose an application to open for a device that has been connected but nothing happens.

I don’t think this is an hardware problem on the FP2 : I managed to use fastboot to boot TWRP on it which means fastboot could upload the boot image successfully using USB (so I suppose all pins should be connected properly).

I’ve tried changing the default USB mode in the developer mode options (Charging-only, MTP transfers, …) without success.

I installed USB Host Diagnostics and it didn’t detect any device (Kernel -> Claims support : Yes, Device deteted -> no).

Is there anything I could try short from a full reset of the device ?


Could be the micro USB connector anyway. OTG adapters / devices use pin 4 to switch the phone to host mode. This pin is not used at all when connecting the phone to a PC (or charging it). So this pin could be broken in the phone or in your OTG adapter / cable.

(My OTG devices work fine with FPOS 17.12.1.)

1 Like

Hi Lionel,

what operating system do you use on your computer?
Is there any info in the logs?

If you use Linux you should check with “dmesg” while connecting your phone.
Windows should also log something if you connect the phone.

Maybe it is only the cable. Some USB cables are only for charging and do not support data transmission. You should try a different cable to make sure that it is not the cable…

I think you misunderstood. He doesn’t have issues when connecting the phone to a computer, only when connecting USB devices directly to the phone (OTG mode).

You are right I thought it is the FP2 - PC connection…
Then I suggest catlog to check the FP2 log :wink:

I have the same problem, but after a update to lineage …

Thanks for the heads up on pin 4.

It could be in the phone (the OTG cable works fine on another phone). I disassembled the microphone/USB module but everything looks fine (unfortunately the soldering isn’t visible). I’m on the waiting list for a second FP2, I’ll try swapping the module between the 2 when I get it. In the meanwhile I can wait : I don’t use OTG often and I have a spare phone for that if necessary.

I tried but it needs a rooted OS :frowning:

I’m waiting for a second FP2 to test Fairphone Open among other things. If the USB module swap with the new phone doesn’t solve my problem (which would indicate an hardware problem) I’ll probably start investigating if a full reset of the OS or a switch to Fairphone Open can solve this.

for me the solution was to go back to unrooted os via manual installer :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.