USB connection to Mac not possible

I don’t know since when, but today I realized that I cannot connect my FP1 to my Mac anymore.
The Fp1 ist charged by connecting it via USB but it is not recognized by my Mac, although it was all the times before, and my phone does not ask me if I just want to charge the phone.
I have checked the debugging option but anyway there is no difference.
What can I do?


When you say the phone doesn’t ask you you mean there is no notification in your n. bar to switch between connection methods?

The first thing I’d try is a different cable.

its not the cable. the cable was working so far
i tried different ones

Have you done the storage update recently?

If so, you need the Android File Transfer tool to connect a Fairphone to a Mac.

1 Like

@ben: I have the same problem as Freddy_de_Vries.
I did not do the storage update and I have Adroid File Transfer installed but I always get the message that “no Android device found”.
I have tried to connect with several different usb-cables without success.
Anyone here with a working solution?

Have you plugged the cable right into the USB port or is there a protective case still on your Fairphone?

@urs_lesse: my Fairphone had no protective case.
I plugged the cable right into the USB port of my Mac Mini, I tried opening Android File Transfer before connecting the phone, I tried connecting the phone and then open Android File Transfer, nothing works :frowning:

Same problem here. Worked without a flaw until now, but when I tried today to connect via usb it doesn’t show anything on the phone or in the finder. Installed Adroid File Transfer, which gave me the same message as for pia.
As far as I remember it’s the first time I tried to connect after the latest fairphone-update, but not 100% sure. Tried four different usb-cables on both usb-ports without success. Charging is no problem on the ports.
Any ideas?

Just to make sure: You all did set the Fairphone to MTP mode when connecting it to your computer, didn’t you? Android File Transfer only works with that setting.

1 Like

All I can add here is that I have went through 5 usb cables that all worked fine with the fairphone in the beginning, but like all products made by unfair companies they are built to not last long. They all have a loose connection and I have to hold the phone and cable in the exact right position to not get the “no Android device found” message.
Currently I use the USB cable from my workphone and it seems to be better quality, but lets see how long that will last.

1 Like

Hi Urs,
it’s not possible to choose the MTP-option, as neither the phone or the macbook show any signs of a connection. Only thing that is working through usb is the charging.
I tried some more micro-usb-cables and realised, that for a very short time after pluging in the status line on top of the phones screen a sign pops up and disappears immediatelly, which shows an downwards pointing arrow and a base line.
Still no solution anybody? Thanks in advance for your help!

Well if its not the cables then it might be the USB socket of the phone. Good news: It can be repaired.

in my case I could solve the problem. in the end it might has been the cable, as it was working with another one. anyway I don’t think the cable I took in the first place is wrong as it was working fine weeks before.
thanks anyway. always a great help here in the forum!!!

1 Like

4 posts were merged into an existing topic: USB connection with Mac not working