Upgrading LOS for microG to 15.1 (feedback/issues)

I solved Magisk problem with a workaround…
I get it installing MagiskManager before Magisk 17.1 itself, and then installing Magisk 17.1 and disabling Magisk Hide.
Not the perfect solution, but at least you can still install your preferred Magisk modules.

I find this solution here: https://forum.xda-developers.com/apps/magisk/beta-magisk-v13-0-0980cb6-t3618589/post77377587, as @theofruitrouge already posted somewhere in this forum.

I don’t know whether this is a microG-specific issue (probably not) but it occurs in my LOS for microG 15.1: my phone does not remember I have developer settings turned on.

In LOS 14.1, I used to have a shortcut to developer settings on my homescreen, which I used to quickly turn root on and off again (as I need root for automatic F-droid updates, but it has to be turned off to be able to use my banking app). These days, when I try to use the shortcut, it almost never works, I first have to turn on developer’s settings again: go to the build number, tap it 5 times etc. If I tap my shortcut right afterwards, it works, but it won’t a few hours later, even if I didn’t reboot in between.

Does anyone recognize this behaviour?

What? :astonished:

Sorry, meant Yalp store. All these app stores.

1 Like

I come back to this battery drain related to mobile network standby. I guess that what I experienced these last days is well understood by the most tech-savy amongst you, but I wanted to put it down clearly on the forum for everyone.
So, 2 days ago, I was in a foreign country, inside a building with Wifi. I put my phone on airplane mode with Wifi on and I used my phone like that the whole day. I even changed Wifi network 2-3 times in the evening. I may have used my phone less than usual, but it had more than 80 percent left when I went to bed around midnight.
I just made some tests at home yesterday and today: I turned off data and had Wifi on the whole day. I end up with 75-80 percent in the evening. The “mobile network standby” is down to 1%.
I knew that it would have an effect, but I am amazed that it had such a positive effect on the battery. I had the idea that the mobile network standby also concerns mobile network without data. Some people say for example that the battery drain may be linked to a bad network connection.
In my case, the battery drain is only linked to the data connection. I will do some more tests this week by selecting preferred networks.


After some days of testing, I can confirm that setting the preferred network to 3G is much more battery-efficient than LTE. I first tried with 3G and Wifi on most of the day. It was better than only LTE. Then I have used only 3G during 2 days and I have much better performances. Today: 80% left at 7pm with a phone disconnected (100%) at 6.30am. Yesterday: a bit less but much more use. It was around 55-60% when I went to sleep.
I will continue with 3G until the end of the week. Then I will switch back to LTE to test it once more.

It may depend on your LTE network coverage and switches between 3G and LTE.

Are there any text-to-speech apps you can recommend for a google free FP2?
I only need it for osmand navigation.
Flite seems the only usable one in F-Droid. But it has only english and a view indian languages.

Hey I am running LOS 15.1 with microG included on my FP2. Is there any way I can invoke the updater manually? I sometimes get the notification that there is an update, but I don’t find a way to open the dialogue by myself.

Also is it necessary to install the updates in order or can I just install the newest? Anything else I must look out for with the OTA update?


  1. Settings / system / about the phone /lineage updates
  2. You can install the latest and skip an update if you want

Did you find some clues during your tests?
My “wokraround” with this issue is to switch to Wifi as soon as I can and disable mobile network. And when I don’t have LTE coverage also disable mobiel data (or switch to 3Gfor a longer period) … all in all not very pratical :unamused:

Well, there has not been a lot of testing since everything goes well when I stay on 3G. It’s been almost 2 weeks and I always have more than 40% when I go to bed, often more. So it’s quite conclusive.
As promessed, I will now put the settings back to LTE and give it a try this week to see if it’s as bad as it was before.


the phone does not automatically boot into recovery mode after the latest update (20.10.2018) has been downloaded and the installation has started.
The phone restarts completely.
I have to manually bring it into recovery mode and then immediately starts the update process.

TWRP version


the phone does not start in recovery mode when I choose to reboot in advanced mode …

… and you can’t turn off the phone, it reboots instead?

Consensus up until now is … For LineageOS and Fairphone’s Android 7 this currently doesn’t work with the new camera … unless you activate the flashlight before rebooting/turning off (relatively new workaround).

If you have the new camera … did this really work for you before?

TWRP 3.2.2-0 has a problem with OTA updates on encrypted phones, TWRP 3.2.3-0 fixed this.

1 Like

I have now installed TWRP Started now in recovery mode :slight_smile: and i have the new cameras (front/back).
Thx for help.

My phone two has LineageOS without gapps (google) and now TWRP and does not start in recovery mode and shutdown causes a reboot. Is a new phone with new camera modules. That’s crazy…

I noticed, when my phone is either in LTE or mobile is deactivated, the battery life is excellent.
So it seems that the network standby issue has a significant impact.
Does anyone know, if the lineage community is working on resolving this?

Boot in Recovery Mode dos not work. (TWRP and LineageOS with and without gapps. Last week, it still worked on one of the two phones. :frowning:

LineageOS-Version: 15.1-20181029-NIGHTLY-FP2

With the new camera? It seems that would be an anomaly.
Anyway …

Yes, new Camera Modul and the “flashlight-workaround” worked only shutdown.