Upgrading from *official* 14.1 to 15.1 (feedback/issues)

This does look stalled to me:

35 pull requests?

The last release was a pre-release on April 2 2018?

Plus, as I said, it doesn’t have material design. You just need to see the interface to know how out of date this software is. Its like from pre-2015. Terrible.

To each their own, but this is why I prefer pEp. Which seems to work well on Oreo, so its worth mentioning.

Was your FP2 on the charger? If yes, do the reboot without charger with full battery.

Yes, it was on the charger. Thx for the hint, I’ll try it without.

Judging a project by their opened PRs is superficial, honestly. Specially for a a non-lucrative, independent, open-source project run by volunteers. Definitely not fair. Latest commit 2 days ago, BTW.

Again, superficial. C’mon, user interface is outdated, sure, but code isn’t. You can’t judge code by its UI: not all developers can (or should, anyway) build good UIs. Furthermore, K-9 mail is a quite developed fork of the AOSP pre-ICS era mail client. It’s quite the work to overhaul a UI of that age, specially on ever-changing Android.

BTW, pEp is built on top of K-9. They deserve some respect for that quantity of years working on such a good software, no matter if you like their UI or not.


I tried both, before the full wipe, but it didn’t help

2 posts were split to a new topic: LOS 15.1 Settings app crashes

pEp is based on K-9. The K-9 developers could just import pEp’s UI changes. They don’t, for whatever reason. Hence why I say, consider the fork. Its completely reasonable to suggest that.

Did the upgrade now without connection to the charger.
The installation finished after 5-6 minutes, all fine now :+1:

No issues so far, I’ll continue testing.

Again, you’ve done a great job, thx for this!

After a few days of testing, I figured that I have one big problem.

Since I updated, my FP2 to LOS 15.1, I can get only “E” connexion, no more H or H+ either LTE where I could before updating. (I also tried with another phone)

Is it a known issue ?

Sorry, but my FP2 and me are going crazy. I can not use my phone anymore: I can’t boot in LOS 15.1, nor restore or downgrade to 14.1.
I wiped system, dalvik, cache and data, flash again LOS 14.1 and got error 7 in TWRP.
I tried to restore my NAND backup, and got error 255.
I never got this kind of problems. Some help, please!

I made an upgrade from 14.1 with magisc 16.0 as root and systemless xposed.
after the recognition of a stupid error in the process (i forgot to disable xposed for nugat in magisc manager before updating -> that produced a bootloop) everything went quite well.
i formatet the system partition and installed in twrp lineage, gapps & magisc in one batch and the phone booted in about 4-5 Min.

At first it seems that everything was working as before, alle the former data was there, but then i recognized that there are some issues with installing (xposed) “unknown” apps. (new oreo settings were set for xposed manager) even installing via adb install wasnt possible…

All that wasn’t the case with the lineage root module.
I’m not sure but it seems that there issues with magisc and oreo on some roms. On XDA is a explanation what is maybe wrong here: https://forum.xda-developers.com/showpost.php?p=76265320&postcount=1615

Conclusion: Magisc (16.0 stable or 16.7 beta) + Lineage offical build from 20180813 are not usable at the moment.


Oh, how unfortunate! :disappointed_relieved: Is your TWRP up-to-date?

First thing you should do is make a backup of all your userdata and NAND backup to your computer. You can connect your phone in TWRP to your computer through MTP. Then I’ll recommend you updating your TWRP to the latest available and then formating your phone data (WipeFormat Data). This will remove encryption and ensure the filesystem’s clean. Then you should get the NAND backup on the phone again and try to restore it. If it still fails, try disabling “digest verification” to force it restore whatever it’s able.

I wish you the best of lucks.


Please check whether Settings - Mobile network - Advanced - Preferred network type is set to LTE.

Else … does it perhaps work in the other SIM slot?

1 Like

The settings are already on LTE.
I just removed my Chinese SIM card and now I can get the LTE on the Belgian one. Which slot didn’t change anything.
Is this due to dual sim ? Is it because the Chinese SIM are … invasive ?

The Fairphone 2 doesn’t support LTE on both SIM slots, you have to set one slot to LTE, and the other one will be limited to 2G.
I don’t use Dual SIM, so I don’t know what the settings look like in this case, but it sounds like it would have to be related to that hardware restriction.


Ok I understand. Thank you for explaining.

Since this is not related to LOS, maybe should be better to move it elsewhere.

There are currently two issues:

  • I’m hearing audio books every day, but no music player works:
    • Google Player: it shows only one track of an interpret, and not all tracks. This one track can’t be started
    • LOS music player: when starting a music track, no music can be heard, and the launcher trebuchet crashes. My home screen is completely empty, the only way to go ahead then is to restart the phone
  • 2nd SIM: when booting the FP2, at one moment you’re asked to enter the PIN for the SIM’s. I can enter the first PIN, but before getting the chance to enter the PIN for the 2nd SIM, the lock screen appears, and the 2nd SIM remains inactive.
    My workaround to solve this: toggle back and forth to and from ‘flight mode’: when clicking on ‘flight mode’, I’m asked to enter the PIN for the 2nd SIM.

Is this here the right place to drop this, or should another thread be opened?

Hello, I was wondering two things:

  1. The update is beta or stable? This is my only phone so i would need some “stable” OS.
  2. The update erases apps, configs, data or other informaction in your phone? Or is it like a regular update?


I would first try to get it into a known good state and then try to restore the backup.

In that case: do the manual install of FPOS described at https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2
Then see if that boots. So far that never failed me.

1 Like

The builds now are official (no test builds).

However, using LineageOS you are using OS builds which are being built automatically without a beta tester process before release. Things can break, no guarantees.

Most of the time LineageOS is running just fine, but Fairphone OS and Fairphone Open OS in comparison are being tested by beta testers before releases, so I would consider them more stable in the sense of the term.

Experiences differ. There are users for whom upgrading went through without losing anything … and there are users who got stuck and had to wipe their phone.
Make a backup of all your important data and be prepared.

My personal opinion is that in general it’s better to install the phone from scratch when upgrading the major Android version, and I know it means investing time and work.
But if something doesn’t work out, there’s one less question to ask … Could just upgrading the existing installation instead of installing from scratch have caused the problem? (Answer to this mostly is: Yes, making troubleshooting more complicated.)

1 Like