English

Upgrading from *official* 14.1 to 15.1 (feedback/issues)

I upgraded tonight, it seems to work properly. I flashed su-addon and F-Droid privileged extension (was that necessary after wiping system partition?) right after the Oreo image.

Boot time has improved a lot.

Yes, naturally, they live in system.

2 Likes

I successfully upgraded my encrypted phone without GApps and have not lost any data :slight_smile:.
However, two of my most frequently used apps crash frequently :confused:, namely, K9-Mail and OSMAnd (installed via F-Droid). I already reinstalled K9-Mail but now I am not even able to launch it at all – before, it crashed whenever I opened an email, so I was at least able to access my inbox.
Does anyone have a suggestion what to do? Do you know whether it is Lineage or App related?

1 Like

10 posts were split to a new topic: LineageOS for microG vs. LineageOS + UnifiedNlp without microG

My K9-Mail works as before… I use LOS+microg but that should not Change anything, i guess.

Since upgrading to 15.1, I notice that my K-9 Mail sometimes has the status “synchronization disabled”. I haven’t had that at 14.1 yet. Has anyone had a similar experience?
Workaround: Disable- and Enable mobile data.

I also observed this with 14.1, since adding K9 as an exception in battery saving optimisation it never happened again.

3 Likes

I can make photo’s, but can’t record video’s, “could not start media recorder can’t start video recording” is the error. Anyone facing the same issues?

3 Likes

Thank you very much for the info!! Will wait fort an update then

K-9 development is rather stalled.

p≡p is a K-9 fork with material design and opportunistic GPG. Works fine for me on Oreo thus far.

EDIT: It is free on F-Droid, btw.

1 Like

This doesn’t look stalled IMHO: https://github.com/k9mail/k-9/commits/master

2 Likes

Hi. I tried to update Official LineageOS 14.1 to 15.1 via TWRP following instructions founded
here.
First time I wiped system and cache before flashing, but I got endless loop on system reboot.
Second time I wipe data too, but still got endless loop on system reboot.
I tried to restore the backup I had done previously, but I got un error.
Tried again after a fresh dowload and SHA256 verification, but still endless loop until battery go down…
May someone help me please?

Great job done, thanks to all, especially @chrmhoffmann !

My upgrade didn’t run so smoothly yet:

  1. installed twrp-3.2.3-0-FP2.img
    Then in TWRP:
  2. wiped system, cache, dalvik
  3. installed lineage-15.1-20180813-nightly-FP2-signed.zip and open_gapps-arm-8.1-nano-20180815.zip
  4. Reboot to system,
  5. My FP2 is encrypted, so after a short time I entered the decryption PIN
  6. Reboot continued, but didn’t end
    After > 60 minutes I rebooted again into recovery.
    This time I swiped almost all (system, cache, dalvik, and also data), and again did the installation of LOS and GAPPS.
    Now the reboot finished after around 4-5 minutes, with a fresh LOS 15.1, without any apps installed.
    As I my FP is also my business phone I need again today, I restored yesterday back to LOS14.1.

I’ve read that @lklaus faced something similar, and continued later with wiped data partition.
Has anyone had the same experience, and might give some advice?

Later this afternoon I’ll try again to run the upgrade.

This does look stalled to me:

35 pull requests?

The last release was a pre-release on April 2 2018?

Plus, as I said, it doesn’t have material design. You just need to see the interface to know how out of date this software is. Its like from pre-2015. Terrible.

To each their own, but this is why I prefer pEp. Which seems to work well on Oreo, so its worth mentioning.

Was your FP2 on the charger? If yes, do the reboot without charger with full battery.

Yes, it was on the charger. Thx for the hint, I’ll try it without.

Judging a project by their opened PRs is superficial, honestly. Specially for a a non-lucrative, independent, open-source project run by volunteers. Definitely not fair. Latest commit 2 days ago, BTW.

Again, superficial. C’mon, user interface is outdated, sure, but code isn’t. You can’t judge code by its UI: not all developers can (or should, anyway) build good UIs. Furthermore, K-9 mail is a quite developed fork of the AOSP pre-ICS era mail client. It’s quite the work to overhaul a UI of that age, specially on ever-changing Android.

BTW, pEp is built on top of K-9. They deserve some respect for that quantity of years working on such a good software, no matter if you like their UI or not.

4 Likes

I tried both, before the full wipe, but it didn’t help

2 posts were split to a new topic: LOS 15.1 Settings app crashes