Upgrading from *official* 14.1 to 15.1 (feedback/issues)

What encryption method does your wifi router use? CCMP (AES) forced should be the way to go.

And does it force protected management frames? The latter made me have problems with my FP2’s wifi - setting them to optional made everything great again. :wink:

1 Like

Thanks for the hint with PMF, which were added in Fritz!OS 7 for my AVM router. As I’m also suffering from massive connection problems I’ll try to disable them again. I thought it would be nice security wise, but FP2 seems to not handle the protected management frames correctly :-/.

Yea, I use CCMP.

I can’t say anything about forcing protected management frames, because I still own a “castrated” ISP branded Fritz!Box Cable 6360 which doesn’t seem to mention anything about such things. Can’t even enable the telnet/ssh server on there. =
I’d switch to 5 GHz in a heartbeat if my Chromecast would support that.

I took a glance at the logcat output too. Couldn’t figure out much, other than a couple of errors which may or may not be related to the issue.

09-22 03:12:11.819   447   447 E wificond: Failed to get wiphy index from reg changed message
09-22 06:56:20.139   316   316 E android.hardware.wifi@1.0-service: Failed to get firmware debug dump: NOT_SUPPORTED
09-22 06:56:20.144   316   316 E android.hardware.wifi@1.0-service: Failed to get driver debug dump: NOT_SUPPORTED
09-22 13:15:58.319   447   447 E wificond: No Offload Service available
09-22 13:15:58.570   316   316 E android.hardware.wifi@1.0-service: Failed to get driver version: NOT_SUPPORTED
09-22 16:34:38.100  1261  1782 E BatteryExternalStatsWorker: no controller energy info supplied for wifi
09-22 16:34:38.100  1261  1782 E BatteryExternalStatsWorker: no controller energy info supplied for bluetooth
09-22 16:34:38.137  1261  1782 E BatteryExternalStatsWorker: modem info is invalid: ModemActivityInfo{ mTimestamp=0 mSleepTimeMs=0 mIdleTimeMs=0 mTxTimeMs[]=[0, 0, 0, 0, 0] mRxTimeMs=0 mEnergyUsed=0}
09-22 16:35:49.648  1261  1768 W BroadcastQueue: Background execution not allowed: receiving Intent { act=android.net.wifi.supplicant.STATE_CHANGE flg=0x24000010 (has extras) } to com.fjsoft.myphoneexplorer.client/.BroadcastListener

The “no controller energy info supplied”, “Background execution not allowed” and “modem info is invalid” error/warnings are like a LOT in the logcat I dumped (-db system; only Warnings, Debug and Errors).

1 Like

Depending on your router model you can maybe make the PMF optional, removing them completely still weakens the security of devices which can handle them correctly (my years old computer indeed does).

Well I disabled them, but my Wifi is nearly unusable. Because I’m using Orbot, which isn’t able to handle all these re-connects to my WLAN, I just disable WLAN on my FP2 at home. Sucks! I didn’t yet try to debug this. I’m also not sure if this was introduced by a recent LoS 15.1 update or by the Fritz!OS7…

My observation after updating from LOS14.1 to LOS15.1:

  • Update via TWRP, just by flashing LOS-ZIP
  • needed to flash also addonsu-15.1-arm-signed.zip (was not neccassary within LOS14.1-updates)
  • I installed no Google-Services (no MicroG or similar)
  • all data stayed untouched (I did no wiped any cach or partition during installation), except:
  • homescreen was empty (all symbols have to be re-added, also all widgets)
  • Google Maps is not working anymore (updated to v. 9.86.1 via Yalp), it starts but after loading the map properly it crashes & closes. In LOS14.1 it worked this way! Why? is now working - after I updated to v. 10.1.0 (in Yalp Store)!
    So it was not a problem of missing services, obviously.
  • Bug of LOS14.1 still there: PIN of SIM2 has to be entered twice (2nd dialogue sometimes just vanishes)

I quit using LOS 15.1 and reverted back to 14.01. I wiped and reinstalled EVERYTHING, Installed LOS14.1 and all my apps worked (Google Maps, Mamikreisel, Kleiderkreisel). Then updated to LOS 15.1. Then the first opening of Google Maps worked, found GPS… When I opened it the second time, it just dumped. Same with the other apps.
I will hope for FP Sibon to release th version with SuperUser and switch to that. Then I will get upates again.
I’m sorry it didn’t work - but I need my phone!!!

No idea why it didn’t work properly. I’m using maps well, just guided me from UK to Belgium and onwards back to France :disappointed_relieved:

1 Like

I regularly use a Wi-Fi (WPA2-PSK AES-CCMP-128) which has enabled optional PMFs. The FP2 actually uses PMFs and the network performance is good. (I’m on FPOS 18.09.1 (GMS), not Lineage.)

Does your FP2 use PMFs when you set them to optional on the AP?

Sorry to hear that. What setup are you using? Which zips (esp. which gapp packages) did you install on top of lineage? Did you install gapps directly when upgrading? Meaning no intermediate reboot after lineage? You know that you have to flash a new gapps package when upgrading?

Can you also provide logcat when it crashes?



Oh by the way… my issues with low WiFi bandwidth have been resolved after a recent update. I also how have a new router and use 5GHz WiFi on my phone.

One thing I keep running into are random reboots without any proper explanation. Anyone else seeing them?

Another minor thing I encountered with the PAYBACK app, when I wanted to use their PAYBACK Pay service, the app basically told me it detected an unsafe device and denied further usage. My phone is not rooted and even after deactivating Root over ADB I kept getting the same result. No idea what checks the app does, could possibly be that it just blacklists LineageOS or Custom ROMs.

I dont know on what it depends but since a couple of days i have problems with the SD Card. I cant move files from the internal storage to the SD card or even format the SD Card with the FP2. It tooks 5 attempts to copy files from the computer to the sd card (the phone was connected via USB to a linux computer). I dont know if it depends on LOS 15.1.
I had a similar issue fiew years ago. Formatting the sd card solved the problem but that doesnt work this time.
As i said i’m not sure if it depends on LOS 15.1. I cant say, if there is a connection to one of the last updates (i installed every update, so now i’m on the LOS from 29.10.18).
Even TWRP cant access the SD card when i try to make a backup and save it directly on the sd card.

How old is the SD card? Could it be it’s just broken? Do you have any other device with a card reader to check if it works there?

Two or three years. Its a SanDisk Ultra 64GB.
The cardreader from the laptop hasnt any problems deleting files.
I put another SD card in the phone. It is recognized without problems. When i put the 64GB card in the phone it even didnt get recognized now.
I will format it at the computer now.

I’m on 15.1 from download.lineageos.org/FP2 with installed openGapps.

  • I have crashes (i have logcat extreme running now to see where this comes from, so far I have an occasional warning;
    w/adreno-EGL(15107): qeglDrvApi_eglGetConfigAttrib:607:EGL_BAD_ATTRIBUTE); very often I experience it in connection with Firefox but other apps like maps and waze are triggering it too. I believe it is something with the memory as frequently triggering screen on/off with apps like “touch screen protector” while playing PoGo very often caused crashes too.

  • I cant shut down the phone with OS options, it keeps restarting instantly; running the shutdown option from automate or through terminal commands does work though. Wrong command linked to the powermenu option?

  • Updater and devOptions extended reboot options can not open recovery, need to hold vol+ to go there, then the scripts run

In case you have the new 12MP camera module, those two are known bugs:

  • cant shut down the phone with OS options, it keeps restarting instantly
  • Updater and devOptions extended reboot options can not open recovery

There is one workaround at the moment for both: turn on the torch before you shutdown/reboot to recovery (as silly as it may sound :wink: )

1 Like

Just stumbled over a problem with notifications. Looks like it started with LOS from Oct 29… Apps that select their notification via the media system (except oif listing notification sounds directly) don’t play a notification irrespectively which one i select. E.g Viber and k9 don’t play any sounds. threema does, for example


I’ve had several warnings in my logcat referencing a change to mediastreams for notifications. Must be a procedure change thats not had its updates come down from every developer.

1 Like

Seems, that you were right. The card seems to be broken. Isn’t a LOS problem. Tried to format the Card with Windows, Linux, Mac and another android device. Tried different tools like GParted, Partition Wizard, diskpart, Sd Formatter without effort.
I found this information at the SanDisk site.

Write protection errors occur when a flash drive detects a potential fault within itself. The drive will go into write-protected mode to prevent data loss. There is no method to fix this. To verify the issue is related to the flash drive and not your computer we recommend that you try plugging the USB drive into another port on your computer. You should also try the drive on another computer if possible.

I’ll buy a new one.


IMHO K9 has currently problems with Oreo notifications. If you set a notification sound it displays notification LEDs, that’s what I observed.

1 Like