English

Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Hello everybody,

I updated to 15.1. and everything seems to be working great so far, except for:
Davdroid Sync.
I noticed that my calendar won’t sync anymore (no error message, just nothing happening)
So I reinstalled Davdroid (also tried earlier versions) and now my contacts and calendar apps can’t find my davdroid account anymore, so all entries are basically gone.
The davdroid account appears in the system accounts list, but the apps can’t find it / can’t connect. Davdroid itself seems to be working fine.
Any ideas?

Hi @juniorprofi. I actually had a problem with DavDroid, but synchro works again after a few hours I think the problem was with my host. Have you read the DavDroid logs ?

Overall I’m happy with the upgrade to 15.1 but I preferred the previous version of Trebuchet.

I have no problems with Davdroid and Lineage 15.1. I synchronisize contacts and calendar with Posteo and a Nextcloud without problems.
Not really helpfull for you but maybe it could be seen as a general feedback concerning the synchronisation on 15.1.

2 Likes

today i had an unexpected reboot while checking done network info in termux…i was using an ‘ip route get ipadress’ when the system froze and rebooted. here is the last_kmsg: https://drive.google.com/file/d/138nqetpPrw4RqWRBXpzgfacewGRAUcGU/view?usp=drivesdk

Just a wild guess: have you checked the permissions as well as the Trust / Privacy Guard settings to make sure Davdroid is still authorized to access contacts or calendar?

1 Like

Hi,
I just upgraded to the latest build of lineage os 15.1 i.e. 27/08. I’m still having problems during a call in both directions (after making and receiving a call the display becomes dark and I have to remove the battery).
I also experimented the same problem with signal and telegram differently from what I wrote before.
As workaround I found that if I restart the OS and I make a call immediately, it works well. After some minutes (I do not the exact amount), it stops.
Do you think that it is a bug? What can I do? @chrmhoffmann
Thank you

I had the same problem after upgrading. First I set the developer option to end calls with the power button. Second I remembered that I had this problem before… Calibrating the proximity sensor with the built-in Calibration app did the trick again. Good luck!

1 Like

Thank you for the suggestion, but the calibration does not solve the problem.

Are you using the latest modem.zip?

See here: [✏ FP2 modem firmware]

1 Like

I updated to 15.1 from 27.08.18 and noticed that the ghost commander now isnt able anymore to switch into the root mode.
When i enable the root mode and then want to change the permissions from “read only” to “Read/write mode” the root symbol appears and disappears a view times in the status bar and Ghost Commander shows “busy…”. But i cant delete files then.

Can anyone confirm this? Or has a hint for a solution?
Before this update it worked not properly but it worked.

Root mode and deleting files seem to work for me (Edit: on LineageOS for microG).
Have you already installed addonsu-15.1-arm-signed.zip?

I can confirm Nextcloud + Davdroid + Simple Calendar works (syncs) with LOS 15.1 + microG.

Thanks for the answer.
Yes, i installed the addonsu. Other apps, like Titanium Backup, have no problems with root access. I also contacted the developer of Ghost Commander.

Thanks for all your answers!
It’s strange, davdroid and the calendar/contact apps have all the permissions they need.
And sync works on 3 other machines, so it can’t be the hoster (baikal).
But somehow the calendar/contact apps can’t connect with davdroid.
Will look further…

Remember that Macs with iCalendar need a different path than the rest. It says, in Nextcloud Calendar, on the bottom left “export” two different paths. Verify you’re using the correct one.

If that doesn’t help, please verify you followed these guides:

https://www.davdroid.com/tested-with/nextcloud/

https://docs.nextcloud.com/server/12/user_manual/pim/index.html

Some experiences since the 15.1 release:

  • Bluetooth is much more unstable: It takes a very long time before a connection is established. Very often I have to pair again and again to get a Bluetooth connection. It doesn’t matter which Bluetooth device I use (headset, car).

  • Deactivating SIM slot 2 does not seem to work. The signal bar disappears. I still receive SMS via SIM slot 2.

  • SIM slot 2 is always activated when restarting, although it has been manually deactivated.

  • The SIM PIN dialog often does not appear after a reboot. Workaround: Switch flight mode on and off.

Currently I am on the release 15.120180820-NIGHTLY-FP2.

Thx.

@chrmhoffmann now that FP have updated Android 7 to fix the crash when doing mobile connectivity test in Checkup, is it possible to implement this in Lineage? It’s remained broken since 14.1

[Edit, forgot the links:

https://forum.fairphone.com/t/fp2-android-7-beta-fairphone-os-fairphone-sibon-18-08-1/42557

https://bugtracker.fairphone.com/project/fairphone-android-7/issue/23]

1 Like

What is Checkup?

Chris

The Fairphone app to check modules and test the phone is working. It is in the play store too but so far there isn’t a new version released since 2016 so I’m not sure if Fairphone have made a change to the app or within FOS to enable that particular bit to work

2 Likes

Thank you. It solved both the problems: the one related to call and switch off of the screen and the one related to volume adjustment during a call.
I already upgrade to latest modem during lineage OS testing build and maybe after the upgrade to official build I should had to reinstall it.