Updater doesn't notify of Updates anymore

Hu-hum, in fact, I had no Updater notifications since Fairphone Open 17.06.4 installation.
Any idea on how to fix this ?

Have you tried clearing the updater app’s cache & data in Settings > Apps?
Do you have any apps installed that might be able to restrict the updater apps ability to access the internet?

So did I.
And I had some hope as effectively, some permissions were restricted. I got them enabled, wiped the cache & data, turned WiFi on, started the app, some traffic were exchanged, but the Updater still tells me that I’m up to date with my 17.06.4.

Hm. In that case I’d manually install the latest OS and then see if the updater works then.

Not working since June?
I remember there once was an update of the Updater app. Could have been around that time.

Maybe you should check against the playstore and the fairphone support website that you have the latest version of the Fairphone Updater app installed.

It was around that time, but slightly before. It was necessary to upgrade to Android 6, but 17.06.4 is already Android 6 so @siltaar must already have the updated updater.

Do you run a Firewall App like AFWall+ which could block the Updater?

Is your phone set to the correct time? (No joke, see end of the following post) …

Is the developer mode perhaps still there to trigger a manual check? …

(I’m on LineageOS and can’t check.)

Hi, thanks for your answers.

I’m at the correct date and time (I guess it’s picked up at boot time from cellphone network, and double checked by GPS from time to time).

I try disabling AdAway, as it’s the closest from Firewall app that I use from a Firewall.

Flushing the cache and data of the Updater, I lost the blue submenu of the app. New it says that I’m updated, and nothing more, the screen is “all” white.

How Lineage is getting updated ?


I remember that the Fairphone Updater app only downloads updates when connected to WLAN.

1 Like

Sure, as explained in my 2nd post, I’m expecting updates from WiFi :slight_smile:

Have you checked your settings? Maybe mobile data takes priority over WLAN.

I have a very short data plan (50MO) and would remark it quite soon. So it’s not the case.

I believe I can’t uninstall and re-install the app, but I would have like to try it.

I’m on FP Open 17.11.2 and got no info about a new update. WLAN is fine, mobile data is off, phone is rebooted, app data is cleared. No Firewall, adblocker only as a browser add-on, date/time is correct
Entering http://ota.fairphone.com/ instead of https://ota.fairphone.com/ after touching version number some times doesn’t change anything visible.

Up to 17.11.2 the notifications came very early, just at the time when they were announced here or even before. Is this lag normal behaviour and I just have to wait for some more days? Or do I have to install the update manually?

Because there is no update to 17.12.x yet.
What got updated recently to 17.12.1 was Fairphone OS, Fairphone Open OS should follow soon.


Uh, of course, thanks for clarification! :blush:


I tried to manually install FPOSOS 17.12.1, got stuck on parametrage at startup, then at moving FP logo.

So I installed LineageOS, it works great, it’s Android 7, and most of the Xposed features I used are builtin.


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.