Update to 1.8.7, no google play - old problem, no solution found

I know, this topic was discussed a loooot here in the forum. Actually I rummaged through the whole forum and possibly tried every “solution” described in here.

My fairphone is from the first patch and first I was really happy with it but now I’m getting really really angry and annoyed because nothing works fine. I didn’t update from Cherry to Kola Nut 1.8.5 and later 1.8.7 because I read about all the troubles fairphone users had when they tried to update. But now I thought it was time to try the “new” operation system because the old system always asked me to update and it was annoying having to delete the message all the time.

I tried to update from 1.6 to 1.8.5 and 1.8.7 and it didn’t work well. I didn’t know exactly what was the problem and asked my brother (who works as a software engineer!) for help. He updated my fairphone to 1.8.7 but now I have this problem with google play. Yesterday I spent the whole day trying to get google play to my fairphone. Today I asked my brother again for help and he also spent half a day trying to install google play. The result? It doesn’t work. I think we tried all the options given in the forum, we didn’t succeed.

I finally decided to use my fairphone without google play but it’s nearly impossible… too many apps ask for google… I bought this phone 2 years ago for having a good phone for a long time and also to help finance a fair phone. But now I’m nearly giving up and switching to the old iPhone of my father.

Perhaps someone may help.

What we did:

  • we updated to 1.8.7
  • we put the Storage Upgrade
  • I tried the Upgrad Fixer
  • there were problems with GApps-File not found in cache - my brother fixed this
  • no possibility to restart
  • I deleted cache of storage media
  • I deleted cache of Updater
  • finally my brother fixed the restart and cache problems
  • there were problems with installation aborted when trying to install manually from restore mode - my brother fixed this
  • I tried to reinstall 1.8.7, then install GApps through updater - didn’t work.
  • I tried to install GApps manually, app opens but closes inmediatly, so it’s not usable

What else should I do?! My brother already gave up!

Two wild thoughts:

Can you confirm that the Storage Upgrade actually succeeded? (Check the storage, if it still includes a “phone storage”, then the storage upgrade was not successful. If the storage upgrade was successful, then there should only be the “internal storage”).

Regarding the Google Play Store, I am far from being the best advisor (I never used the Google Play Store), but you might want to go into Settings -> Developer Options and make sure the screen stays active (this should be the third option in the list of developer options) all the way through the whole installation of the Google Play Store.

2 Likes

Thanks urs_lesse, it seems that Storage Upgrade didn’t succeed because I still see a “phone storage”. So I’ll try this again, but I think my brother said something about that it didn’t work and that I probably installed Storage Upgrade and 1.8.7-Update in false order - is this possible?

The screen stays active, that’s one of the tricks I learned here in the forum :wink:

I agree with @urs_lesse, and just want to add one thing: You should tick this option, plus, I think, your phone needs to be plugged in to a power source, if you want it to stay awake.

Well, a basic problem that your attempts to update might have suffered from is that your internal storage is just too full, and it can prove trickier than expected to clear enough space for updates. From my recent experience with FP1 users struggling to update or to install the storage upgrade I actually tend to recommend a hard reset as a first step (warning: This erases everything on your phone, but so does the storage upgrade – so backup beforehand if you haven’t done so already). The only other option would be a manual installation of the storage upgrade, but that is a bit more complicated.

1 Like

I actually made “a hard reset”. And in the Fairphone Updater there is no option to do the Storage Upgrade as described here: https://www.fairphone.com/tutorials-en/#/manufacturer/fairphone/device/fairphone/category/software-update/topic/install-storage-upgrade-for-v1-8-7/1.

So it seems that I will have to do it manually, that’s what I already tried and I think that’s what my brother tried. Right now actually I don’t have any idea how to upgrade the storage, just tried to find some kind of manual here in the forum which explains what to do step by step.

Sometimes the Support still is better than the forum… :wink:

See this article: https://fairphone.zendesk.com/hc/en-us/articles/202478028

Starting from point 1.3. you’ll find instructions on how to manually install the storage upgrade. :slight_smile: Tell us, if it worked!

Thanks Stefan, I found the same link and I’m trying to do the Upgrade. Will let you know if it works!

Hm… I think now my Fairphone is really dead. It could install the Storage Upgrade from the Recovery Mode and it seems that installation succeeded. Then I wanted to reboot the phone but it doesn’t do anything, there is only a blue display. It doesn’t even enter into Recovery Mode… that’s impossible!

Sometimes the bluescreen takes longer to vanish (could be the case especially after an upgrade). Hold out a bit, and if it doesn’t vanish, take out the battery and try again.

1 Like

I already took out the battery and tried again. Nothing.

Possible that I “bricked it”? http://forum.xda-developers.com/wiki/Fairphone_Fairphone/Guides#Bricked_your_Fairphone.3F

Aaaaah! You were right! It just loaded the Fairphone-Logo :heart_eyes: what a difficult patient (or I’m too impatient).

Phone storage is gone, so Storage Upgrade succeeded. Now I’ll try to install Google Apps.

3 Likes

People, you are the best!! It worked out! I just signed in my google account on my fairphone! :slight_smile:

THANKS A LOT!!!

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.