Update to 1.6.2 failed

I just tried to update my phone to version 1.6.2. On the restart I got the following message:

Finding update package…
Opening update package…
Verifying update package…
E: footer is wrong
E: signature verification failed
Installation aborted

What should I do in this case?

Seems like your download is corrupt.
Try to delete the file and re-download it.


I had the same problem with the last update. It worked just fine when I tried the second time. So I’d recommend another try.

Same for me. Second one was the good one.

Second one failed also, now i started the third one after having different message and choosing “reeboot now”. what will happen?

You can also check for manual installation, in the rare case that automatic update problems persist.

1 Like

Third time was a real “download” and could start installation via Updater. I tried also “manual installation” on another device … both working. Thank you!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.