Update gets stuck at "just a moment" after downloading

Hi @fosb,

The update finished. It took 4 hrs or so, but then it started going and restarted. Thanks for your help anyway of course. I was happy to know I did nothing wrong to start with.

Regards Mariekekeke

I did the update with the ‘advanced mode’, but again it’s already 1 hour on the “wait an instant”-screen… Before, I tried it 3 times with the automatic update and the last time was already for 3 hours on the “wait an instant”-screen.

Hi all,

Not sure if you can see my answer to @fosb so for you as well: after about 4hrs the phone asked for restart and got updating allright. Everything now seems to be working ok. I know some of you have been waiting longer so not sure if my experience is of any help to you…

Regards Mariekekeke

Ok, then I’ll wait a little longer, thanks :wink:

Hi, I tried all the suggested solutions from this thread:

  1. Waited for about 20h
  2. ‘advanced mode’
  3. cleared the cache and app-Data (Updater and Download-manager)
  4. removed the SD-Card
  5. removed both Sim-Cards
  6. rebooted many times and retried the update.
    Nothing helped in my case. I’m still seeing the “just a moment” (in my case the german version " Bitte gedulde dich noch ein wenig… ") message after the download is complete. Because of this I can’t click the reboot button. Rebooting with the power button doesn’t install the update.

Are there any other suggestions how to solve the Problem and is there someone working on a general fix for this?

Kind regards, Andreas

1 Like

You could try approach 2 in the help desk article. (Try without the optional step 4 first, as that will delete your data).

3. Boot the Fairphone 2 into the System recovery by holding the volume up button and the power button simultaneously until the Fairphone logo appears (up to five seconds);

not working for me. :frowning: My Phone is also rooted. Do not understand why the update does not work.

best wishes Steven

Hello Andreas,

I also tried all you tried, but it did not work for me neither.
But the Step 1 in the help desk article as Johannes wrote, worked for me.
I simply let the update download the file => it got stuck on the “Just a moment” screen.
Then I stoped the updater app, cleared the cache, reboot the phone and opened the download folder, clicked the update file and opened it with the updater app.
Then it relatively fast resumed the update process (perhaps about 1-2 Minutes in the “Just a moment” screen).

I hope it will work for you too.
Best regards,

I tried what @smo also did, and I immediatly could restart my phone to ‘complete the update’. But now I have this screen and I really don’t know what to do! :confused:
I’m afraid that I lost everything? I have a backup, but still…
On Google, I only find solution for rooted phones, but my phone is not rooted?

It looks like it hasn’t made any changes. It should be safe to restart (but the update will not have taken place).
The error you get could indicate that there is a problem with your specific update file - sometimes things go wrong when downloading, which is why the system first verifies that the file is an intact and valid system update. Downloading the file again may solve the issue in that case.
If you rooted your phone (more relevant for @StevenHachel) , the update will also fail with the same error message because the verification mechanism doesn’t work correctly with the recovery image that is installed as part of the rooting image. For more details on that, see this topic.


Thanks for the fast respons! So wich option do I choose? The first one “reboot system now”?
(Phone is not rooted btw)

Yep, it should be safe to do that.

1 Like

I tried to update mine last night. Just as for many others it got stuck right at the end so I decided to just leave it over night and this morning the phone is just shut off and won’t turn on… Don’t know if there is anything I could do to fix it? Btw of course I have charged it, didn’t make a difference.

now, several hours later, the red light blinks when i connect it to laptop usb, it’s not steady as when charging thought. think its coming around??

If it doesn’t come round, try removing the battery and putting it back in again, then (try to) fully charge the phone before finally trying to turn it on again.

Thanks, smo.
This worked for me. My Fairphone was stuck for more than 12h over night.

Best regards,

I have the same problem. I’ve tried leaving it at “just a moment” overnight after clearing app data and cache, didn’t work. I’ve tried downloading the zip file onto my SD card and installing it from recovery mode, here it just got stuck at “verifying update package” for about 45 minutes after which I restarted (should I wait longer?)
Now I’m trying to install it by opening the zip file from ES File Explorer in the Updater app, it still sticks at “just a moment”.

I don’t know if I’m confident enough to try installing the update from ADB.

Anyone knows how to get my phone updated?

Hi Janosch.

I am in Chicago and have my Fairphone 2 here. Have you been able to properly update your operating system? Mine will download, but then puts up the swirling waiting circle image, and doesn’t allow me to select the button to restart. I have tried rebooting the whole phone, but this seems to completely stop the installation process.

Any thoughts?

@cstypka I moved your post here as I don’t believe your update troubles have anything to do with being located in the US.

I got a working solution from Fairphone themselves!

What I did, following their instructions:

  1. cleared cache and app data of Updater
  2. turned phone off
  3. reinserted battery
  4. after booting I changed screen settings to “turn off screen after 30 minutes of inactivity” (- I think this was the culprit before! Some sort of stall in the process when the phone went into sleep/lock mode.)
  5. went into advanced mode in the Updater and started the download and install. The “wait a moment” message disappeared after 1-2 minutes and I was able to restart.
  6. Voila! Working, finally :slight_smile: