Unstable Wifi connection

I have a 2nd batch PH and unfortunately, I have a problem with the WIFI connection.
The connection seems to be fine for the first couple of minutes, I get 4 bars, but after a few minutes, eventhough I still get 3 or 4 bars, there is no connection.
The only thing to do is to switch it off and on again.
All the time.
This is getting really annoying.
At first, I thought there was a problem with the wifi or the operator, but we have others devices connected to the wifi (smartphones, laptops) and only my Fairphone has problems.

I have tried to connect my fairphone using WPS, but my operator doesn’t offer this option.

Has anyone else had this problem, and what can I do to fix it?
Thanks a lot

1 Like

Hi @Armelle_Cailliau_Nad

I haven’t seen anyone with this issue, but nonetheless I can imagine it being frustrating. I’ve found something similar on the xda-forums, but it’s possible that your problem and the problem there is not connected. I’ll look around and see if I encounter similar problems.

Kind regards



I’m having the same problem since I updated to 1.6 (also on a 2nd batch phone, FP1U). The wifi icon will show a strong signal but it’s gray instead of blue, and then I need to turn it off and back on to regain connection. Not terribly frequent, but still annoying. I don’t remember this happening before updating.

@Armelle_Cailliau_Nad and @skilpat, please do also check out the other thread, there are some hints what you could do. You could join in finding a solution there. Guess @marta and @noctima would highly appreciate some input from others with the same problem, especially if you find a solution at some point.

Your comment made me wonder because I too have the grey icon but my connection works just fine.

I looked it up and it seems that the color of the icon depends on whether Google services are “connected” or not.

I don’t have Google stuff installed, so I suppose it is expected that I have the grey icon, but it seems one can have a grey icon simply because Google apps aren’t connecting properly, maybe because the connection is shaky.

I read somewhere that clearing cache data for the Google Play Services app fixes the Greg WiFi thing.

Problem with WIFI here as well. WIFI does not work after some minutes. WLAN says it’s on… If I try to turn off, it hangs. All other devices have no problem with wlan.
Fairphone 2nd batch, 1.6
Problems start with update and installing Google apps

I don`t have Wifi Problems at all. my fairphone second batch with 1.6 is doing great with wifi. I even have a better signal than my last SmartPhone had. Google apps also installed.

Hi @Peter_Goldi,

did you try clearing the cache of the Google Play Services as @Jerry suggested?



In the meantime I can’t restart my phone anymore… hangs on fairphone logo… (after I did a hard reset).

seems to be a bigger problem.

Could be a Problem, with the IP address. Maybe two devices in the network getting the same IP.

Try out to use a Static IP. To do so go to Settings > WiFi and click&hold on your network. Then choose Modify network. Tick advanced settings and change IP- configuration to static. Your IP-address should look like 10.0.0.xxx or 192.168.1.xxx. Instead of xxx type something high, e.g. “99”. For the gateway you need to insert “1” instead of xxx. Probably you need to copy the gateway-IP to DNS 1 also.

Tip: To findout your IP, open cmd in Windows and type “ipconfig”. The computer also has an IP like 192.168.1.xxx.

Edit: To make sure the IP is always reserved for your FP you can enter the IP into the router’s DHCP leases list. Then you can use any IP you like (doesn’t have to be a high one like 99).

Thanks for all your help.
My Fairphone does now start again as expected (dont know why it did not yesterday… I did not change anything, it just happens to start again, which is not very helpful in finding out the problem…)

Then WIFI worked without a problem. I could install several Apps, I could activate and deactivate WIFI without a problem. But after 2 hours or so… WIFI lost connection. No networks visible. I tried to deactivate WiFI on the Fairphone. But reactivating hangs saying ‘Activating WIFI…’ forever (WLAN wird aktiviert in german). I restarted the phone and WIFI worked again. for about half an hour, then it lost conection again. Deactivating reactivating did not help. And since then even restarting is useless. When the phone comes up again, In WiFI settings is still says ‘Activating WIFI…’

It’s not a problem with the router oe IP address, I have several Laptops and my old HTC connecting with WIFI with no problems. IP address are setup correctly (DHCP), no double IP addresses

I did clear the cache of Google Play Services several times, did not help.

I love the fairphone but with no WIFI its useless…

Hi Peter, I guess we have the same problem.
Kann ich schnell auf Deutsch schreiben oder verstößt das gegen die Etikette?
Magst du dir kurz meinen Thread anschauen? Ist das bei dir das gleiche?
VG Ati

Hi Ati

I go on with english, possibility is better that someone can hear us :wink:
It’s not quite the same problem, when my phone loses connection the grey stripes on the top are gone. In the WIFI settings no networks are shown anymore. But when I try to switch the Wifi off or on, it hangs on ‘Activating WIFI’.

Strange thing is that it worked, stopped working, and then again worked, and now doesnt work since yesterday. I tried reboot, sim card change reboot, hard rest and all.

It’s really annyoing…
Cheers Peter

Please, there is no problem if you guys write in German. If you find a solution, then it’s much appreciated if you write what you did in English.

Sorry Lidwien, you are right for sure :smile:
I was just asking if Peter has the same problem like me.
But anyway, if there’s no solution, what can we do?
Send back the fairphone? Or is there any other technical support that we can ask besides the forum?

Hi @atispricht,

sure there is. :smiley:

The forums here are completely community driven, so it’s a better idea to go the official way with a problem like this.



1 Like

I did write a request to the official support. But wo answer yet.

I let you know if I there are some news.


@atispricht: Bist du schon irgendwie weitergekommen?

I had the same Problems mentioned.
after reading this (and similar) discussions in this forum, I would like to post what I did to solve my WIFI-Problem. I also had the problems with the Play-Store and the Google-Apps, so here is the actual state of my Fairphone (2nd batch, received 5 Days ago) which is the only one that works out for me:

  • I restarted the phone
  • I did not Install any google apps and no Play store
    –> instead of this I use the amazon-app-store or download apps directly as .apk-Files
  • I am using jelly-Bean
    –> since I am “without” google-Apps I’m fine

the question is, how I get to Internet first time:

  • I enter WIFI by ONLY using the WPS connection (if you don’t know, what that is google it - wifi protected setup- it means you connect to your WIFI router by pushing an WPS-Button on your WIFI router and “telling” your Phone in the same Moment to enter WIFI by WPS. Problem is, that lots of people have older routers without WPS technology. For them the only solution could be an software update which is not existing yet, I guess)

  • still I have to reconnect the connection every 2-3 hours, when I wasn’t using my phone, but I can live with that

As you probably found out by now, I am neither a technic expert nor an native english speaker, so I hope there wasn’t to much information waste beyond. bye

@ Peter
Unfortunately not - I consider to try the way that MWilhelm suggested.
But if the ongoing reconnection is still necessary, it won’t be a satisfying solution…
Cheers, ati