Unresponsiveness, spontaneous rebooting, long reboots, gaps in battery usage history

My two-year-old FP is exhibiting some strange behaviour:

  • It reboots on its own, both while in use and while idle (I’ll take it out of my pocket and find it’s in the process of rebooting). This happens sometimes several times in quick succession, sometimes not at all for a few days.
  • It sometimes doesn’t react to the power button when the screen is off. Waiting a few seconds sometimes does the trick and the phone wakes up again, but at other times the only thing that helps is removing the battery and switching the phone back on.
  • In the latter case above, the reboot can sometimes take as long as 15 minutes, during which the phone heats up considerably.

After a spontaneous reboot, the battery usage history is sometimes reset. But it also happens, when I check the battery usage history without having noticed anything strange, that there are short or long gaps. The long one in attachment 1 and the shorter one in attachment 2 both happened when I was sleeping, so the phone had not been used for a few hours. And attachment 3… ski jumping, anyone?

The unresponsiveness started happening maybe six months ago - then the original battery bloated in September, and I assumed the symptom was related to the battery. But now all these things are happening more and more often with the brand-new battery.

Needless to say, this is quite inconvenient, and I’m a bit worried about wake-up alarms and other situations when it’s important to have a working phone. I realise the symptoms are vague, but is anyone experiencing anything similar? Any tips?


I’m having very similar problems. I haven’t checked the battery usage (In fact I don’t know how to!) but my FP is spontaneously rebooting, sometimes the power button is unresponsive, and last night it did fail to boot back up and so I missed my alarm call this morning! I had put it in to flight mode an I think had about 75% battery remaining when went to bed. When I did get to work and plugged it in this morning it said that it had 11% but I hadn’t been able to turn it on until it was plugged in so it’s possible it was lower than that. But on flight mode it shouldn’t have used much battery? Very concerning. I did have the battery bloating problem and replaced the battery over a year ago. The current battery is not bloating. I also noticed that it regularly tries to download a file which it then says is “invalid”. The most problems happen when an app is trying to update itself. I was planning a factory reset but need to find some time to do this. In the mean time I think I need a back up alarm clock!

It sounds as if you’d need a new battery. Fairphone changed their FP1 battery supplier when they started a partnership for the FP2 batteries. Thee newer batches are more reliable (I’m also on my third battery).

You can check out the battery statistics in Settings > Battery.

If you can confirm that the Fairphone Updater tries to download files, go to Settings > Apps > All Apps > Fairphone Updater and select Clear Cache. If that doesn’t help then Clear Data of the app.

PS: To find the app, which makes the download notification, long press the notification and select “App details”.

Thanks @Nathalie_Marshall, it’s good to know I’m not the only one!

@Stefan, my battery was replaced in September after the first one bloated. I don’t have the draining issues Nathalie is reporting, just the strange jumps shown in the screenshots. Is a new battery the solution for me as well? If so, will Fairphone replace it for me considering it’s only four months old?

@saraest that sounds more like this issue which is usually solved by performing the FP1 battery reset as described in the #batteryguide.

1 Like

Thank you! Will try a battery reset and report back.

@paulakreuzer Thank you very much for the tip - unfortunately it doesn’t seem to work for me. I tried resetting the battery a couple of times, but today the phone has been unresponsive several times, and once I had to remove the battery to get it to wake up.

Would anyone have any other tips? I’m thinking perhaps it’s time to contact support, because it’s getting to the point where I can’t trust my phone to be operational when I need it to…

Thank you for the advice. I purchased a new battery which I installed yesterday. I charged it to 100% before turning on, however I am still having problems. I have had 2 spontaneous reboots in the last 90 minutes, and the battery seemed to drain awfully fast last night when it was on flight mode. I’m also still getting invalid file download when it boots up (I think it’s part of it checking for system updates but it doesn’t say what application even when selecting and holding the download notification which isn’t up for very long.) I’m wondering if I need to do a reset and reinstall of the OS?? Or is the next version going to be available soon? Thanks for your advice. Nathalie

You might have a #wakelock . Plus, a hard reset isn’t a bad idea from time to time, after you’ve done a thorough backup.

FP1 running #kitkat alpha fell down, battery fell out, and I got this after booting:

My battery is half a year old, and it was not a software issue that caused the reboot, but my fault.

My problems are similar to saraest:
It reboots on its own.
It’s not always reacting to the power button or it takes a long while.
The phone can be very slow in general (especially while updating apps, that’s so frustrating! Is it possible to stop the updates and only doing them when I like?)

I’m planning to replace my battery, but I’m wondering if that will fix all the problems. Should my power button not be replaced as well? Or can it be the software that needs an update or reset?

My phone has the same problems with rebooting and unresponsiveness.

Sometimes I think it’s the power button, since I had a lot of moments that I didn’t even push the power button entirely and my screens goes on. When is push the power button normally I sometimes get the switch of or reboot screen.

It is not always though, my phone rebooted also when I was sleeping.

I have 3 sets of batteries, a 2 year old one and 2 new ones. I switched them several times to check if it is indeed the battery, but it didn’t change anything.

There are various possible causes and I ask you to see the #troubleshooting guide:

✏ A little guide to ... Troubleshooting your Fairphone (1 & 2)

Please come back after you’ve tried the methods there and tell us more details.

I also have the exact same issues.

what is the #wakelock that has been mentioned, and how do i resolve it?

If you do tags correctly (wait until you can click and #wakelock::tag appears ), you can read all topics that are tagged #wakelock . :slight_smile: Unfortunately your #wakelock is not clickable. :frowning:

A wakelock appears if an app needs background time from the CPU. Usually that is only seconds, but sometimes a malfunctioning app makes an indefinite wakelock that drains your battery.

Thanks - don’t understand tags, but will try.

1 Like

Here is a short intro to tags:

Hi everyone, my FP1 has the same issues for a few months now:
random reboots, unresponsiveness for seconds or minutes and fast battery draining.
I already replaced the battery last year and the one I have is not bloated.

I also did a hard reset a few weeks ago because of the reboots and the unresponsiveness. I thought that could help. Unfortunately it even seems to be worse especially with the battery problems.

I will check the wakelock thing now and I hope this helps.

I too am suffering from random reboots. Seems to be more prevalent when using facebook - I’ve removed this app now, let’s see what happens!

I have the exact same issue. Did the wakelock thing work?