[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

I used the FP1 image to sideloaded the launcher apk. I cannot remember any problems with the widgets. Not sure if this helps. Flipping through the Apps/Widgets was pretty fast, that’s all I can remember.

Are there other apps on the FP1 that need to be reinstalled from the image? I can’t remember right now.

I use the FP launcher daily on 4.4.4 and I have lots of widgets on all the desktop without any problem.
I also have gravitybox installed and it works very well although I noticed, after Xposed framework installation, some random strange behaviors like home button long pressing not responding always as expected (it seems to react with 1-2 seconds delay), but I didn’t investigate deeper if it is the launcher or Xposed or gravity box or…who knows? :stuck_out_tongue:

1 Like

Is it safe to install? and how?

There is a zip file on xda which fixes this problem with the standard Xposed installer, I included it in my system backup flashable zip (from which I took the FP launcher I posted) and I’m able to install xposed after flashing 4.4.4. If you’re interested I can provide you another flashable zip file tomorrow :slight_smile:

Yes please! thanks :blush:

Here you are :slightly_smiling:
I don’t remember well which operations I did, but I used an APK provided by “SolarWarez” XDA user, then I used Titanium Backup to get a flashable zip file.
If I remember correctly you have to install the XPosed installer, then you should flash this zip which should substitute the system’s app_process file with the XPosed modified one, and then this second zip which should set the permissions and install another part (XPosedBridge).
BTW: you should configure XPosed installer to use “manual recovery” installation method.
Hoping it helps you and if you can please provide a step by step howto in order to help other users because I did so many tries I cannot provide simple instructions :confused:
Thank you :slight_smile: Bye!
P.S. (both pwd are ‘djdas’ without quotes)

Sorry I wrote in french…

Do you know there’s a security alert for your site? susceptible to contain virus etc?

Tried… doesn’t work… I did download you 2 zip files. When I try to flash the first one I get the message that I should press “install/update” in xposed but this is not possible (it’s not available to press). The second zip works fine but I guess that without the first one it’s worthless.

So can you please try to remember what you did? pleeeaaaase!:wink:

No, didn’t know but maybe it’s because I self-signed my SSL certificate, as until now I didn’t think to share anything with others than my friends :stuck_out_tongue:

I would like to!!! :frowning:
Try by uninstalling the XPosed installer and look for the APK I mentioned before on this XDA thread
Good luck! :slightly_smiling:

We’re fairphone buddies!!! :joy:

I did that already, I’ll try again… Will let you know!

1 Like

This modified xposed installer was all I needed to get it running.

1 Like

Yes I followed your posts but it didn’t work for me, this is why I ended with this strange modus operandi with the two flashable zips…but it seems I did something more which I can’t remember… :frowning:

It worked! just with this XDA thread… I uninstalled xposed installer before and reinstalled from the link,

Thanks :relaxed:

Now I’m so happy with my FP1 I may come back to it and put aside my FP2 … One of the main reasons I bought it was that FP1 was stuck at 4.2. Now with this great job everyone is doing here… I don’t see why I would change from my FP1 that I simply :heart:

1 Like

Is it possible that you denied WhatsApp permissions to use the camera? Maybe you need to enable this permission for WhatsApp.

Also, what version of the ROM are you using? It works for me with version 0.9.2 (haven’t had time to update yet).

Have you heard of https://letsencrypt.org?

Somehow, now it works. Maybe it just needed a reboot. I’m running 0.9.3. I guess I’ll have to try to pin down the problem when it occurs the next time. I checked that I didn’t deny any permissions.

1 Like

Yes but my site is hosted on Godaddy and AFAIK I don’t have access to webserver config files nor will be able to install the necessary programs in order to use “let’s encrypt”.
On top of all as I use my site only for ownCloud purposes, I don’t want to spend too much time in SSL stuffs given the very poor users I give access to :slightly_smiling:
Bye! :slight_smile:

So… this is soooooo great I’m going back to using my FP1 (which I :heart:)… Everything works smoothly up to now…

I’m even thinking of sending back my FP2 (but that’s another story…)

I have a question: will the fairphone launcher zip function on my old samsung galaxy S3?

1 Like

Uhm I don’t know, I didn’t try the ZIP on phones other than my FP1U so I can’t tell anything about.
For sure if the recovery software needs a signed ZIP it won’t work, this is why I was able to create it (and other ZIPs for personal purposes) only after flashing CWM.
Good luck! :slightly_smiling:

I have cyanogen mod 13 on my samsung… what do you think? should I try?

It’s based on the pretty old Launcher2 so I’m pretty sure it will work with a S3. But maybe it uses some MTK only feature in the background (don’t think so, but I saw a mediatek-framework somewhere, but searching through the git I don’t see it being used).

Best way to find out? Use adb (install|uninstall) and just create a backup before.

Well, I created the ZIP only because I wanted the Launcher to be a system app, but you can simply extract the APK from the ZIP, copy to your phone and install as a normal app, if it doesn’t work simply uninstall it.
Bye! :slightly_smiling: