[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

Just about ready installing this great piece of work. Had to retry flashing 3 times and to wipe the data partition (has been encrypted before).
Everything seems to work fine right now, and: snappy!

Have a bit of trouble with the location of my osmand maps / can’t access sdcard, but that’s another story I am afraid.

0.4 released. Head over to XDA and give it a try.



You can’t access SD card from where?


Hi Allz… I installed Stock ROM 4.4.4 in light of instruction posted at XDA forum in my FP1(U) via CWM. The phone working great but sometime the upper slide does not work and I have to restart my phone. I don’t know why? May be expert can solve this. I also tried video recording / photo and work fine. I installed Google Play Store on the same method described in XDA forum. Thanks to all who created this nice stuff. Phone restart faster than its original rom. I did not check my phone thoroughly but I hope it will work fine. Thanks to all brothers

Only from osmand. I will explore, don’t bother yet. Maybe I typed in the wrong location. Will try the new Rom tonight, great work, no errors yet for me

Osmand works as designed, had to open the access to the storage using sdfix.
Testing 4.4.4 now

So far I found the following problems with latest 0.4 on FP1 (first edition):

  1. Stock camera: The maximum resolution setting is 3 MP resulting in pictures with a resolution of 2048x1536 (4:3). But Open Camera from fdroid gives full 8 MP (3264x2448).
    With both apps there seem to be some issues with the focus (both auto and manual), especially in low light conditions. Sometimes it is impossible to focus at all. The focus on 4.2.2 works much better.

  2. Display sleep timeout: Whatever timeout is set the screen goes off after about 10 seconds. This does not happen immediately after boot, it just happens after some time after boot. Activating “Stay awake” under developer options prevents the screen from going off though.

  3. After some time long pressing the middle button to show recent apps stops working.

  4. After some time the screen locking stops working. Neither pressing the power button nor the display sleep time out results in a locked screen. This is independent from the chosen lock setting.


Confirm#2 and#3, and #4. No application history for me either

Additionally, status bar/messages not expandable.

Still on 4.4.2 I confirm 1) and 3) from @ralf_xda post, I also add that for me 3) is a bit different: it seems the home button gets the event of a long press but there is a 3-4 seconds delay before showing the list of active apps (like a 3-4 seconds freeze).
I add two (I think) useful information:

  1. Bluetooth LE WORKS! :slight_smile: I tried with a prototype device at work and it connects to the device, pairs normally and receives data (can’t say more due to NDAs :wink: ); moreover I can’t see the device name in the list of devices, but eventually I don’t see it as blocking so much…
  2. battery consumption is very optimized, especially in standby I get about 2-3% fall in 8-9 hours (in Peace Of Mind mode) while on 4.2.2 the consumption was about 8-10%; this morning I had still 15% charge after a 2 days and 13 hours run of normal use, while previously I hardly reached more than 2 days!
    Bye! :slight_smile:

0.5 released that

  • fixes the first camera issue (resolution selection incomplete)
  • enables SELinux

@chrmhoffmann: I find it really awesome that you are taking your time to show us a possible future for updated Android on the FP1!
Some months ago it seemed a very sad and dying topic, but now I am highly encoured to follow your progress (even without having the possibility to help)!!
Keep on - I (we) like it!! Cheers, Robert

P.S.: Does it mean you bought a FP1 or got one from FP to test your builds?

1 Like

Both - the one I bought died. I am guessing something wrong with the USB plug.


But it was no official “sponsoring” from FP (which I would highly appreciate)?

And in one sentence, how you would now rate the future-proofness of the FP1 after your recent succes to port 4.4.2.? Are you optimistic (from the software-point of view)?

Great that you are in the FP-boat!

Yes, it was somehow official sponsoring. They sent me an FP1U unit - after my own one broke down.

I have troubles fixing the remaining instabilities. But I have some hope… After 4.4.x it will be really difficult as there is definitly no MTK support at all for this chipset AFAIK.



But IMHO 4.4.x would be a very nice end-state for this phone.


I just want to share the current Android History Plot from Wikipedia, to which I added the FP1+FP2 release dates (approx.)
Without any comments from my side for the moment …
Cheers, Robert


Any chance you are going to open source your build files along with build instructions?


0.7 released…

Changelog fp1-kk444-CH-0.7:

  • National roaming should be fixed (at least as good as CM). If you still have issue with national roaming, send me your mmc/mmn data.
  • Try original FP1 lens parameters for fm50af lens
  • Attempt to fix the problem where sometimes the scrollbar and recents screen stopped working.

Full CTS result for version 0.7:



On 4.4.4-0.5 I confirm all the previous @ralf_xda 4 issues.
I also add Xposed framework gives me a compatibility alert so I didn’t install it yet (on 4.4.2 it worked quite well).
I’ll try 0.7 ASAP :smile:

Thank you very much @chrmhoffmann for your great work!

+DjDas how did it go with 0.7?

1 Like