[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

Thankyou very much @chrmhoffmann for this ROM.
I installed the 0.9.3 yesterday on my FP1 and am very happy with it. No problems encountered so far. I am especially happy that my Pebble Time now displays content of messages in stead of only a subject which occurs in 4.2. I was temped to ditch my Fairphone because of this but with this ROM i will use my phone a lot longer!


I have a question regarding the People app on 4.4.4: Can I assign groups to contacts?

On 4.2.2. this doesn’t work (I need to assign groups in Thunderbird and sync them). Somewhere I have read that this feature works on Kitkat.

Edit: As @DjDas points out below, it is possible to assign groups to locally stored contacts, but not to contacts connected with an account like DavDroid.

Well it worked for me on 4.2.2 but I tried only with contacts stored locally on the phone.
Before 4.4.4 I decided to use ownCloud with DAVDroid and now my contacts are handled in this way and it still works either assigning the group to a contact on the phone or by setting it on Thunderbird/ownCloud interface.
The only annoying thing with synchronized contacts is that at every sync I loose SIM card assignments and ringtones per contact, maybe I’ll give a look at DAVDroid code and will try to add these features…

EDIT: @Stefan maybe I was not much clear: it works ALSO with DAVDroid, the only thing I didn’t try is on 4.4.4 to configure groups for contacts stored using the Contacts system app (I use only DAVDroid to handle my contacts); sorry for not explaining very well! :slightly_smiling:

1 Like

But in the DavDroid app you can’t modify contacts. Could you try to change the group of a DavDroid-contact inside the people app?

Yes it works even if I create a totally new contact; please keep in mind DAVdroid is only used to synchronize contacts but editing and displaying is done always within the People app.
What I meant is I can choose “where” to store contacts in People app and since 4.4.4 I use the DAVDroid account not the People’s internal one.
By doing this I can modify groups as expected (although I didn’t try yet to create a new group to be honest, but using the existing ones I created on ownCloud works as expected)
Bye! :slightly_smiling:

1 Like

Ok thank you for trying! :slight_smile:

Could you also try out, if you can achieve other LED colours than green, red and blue?

Maybe you can try with LED colour tester, as I did here.

Can I send you one? I’m very happy with all the effort that you put into this, and the functioning of the BT LE seems to be one of the few issues left with this ROM.


Can you make an tutorial for dummies? :open_mouth::wink:

Question 1: how to flash the recovery img? (normally I would go to download mode and odin but that doesn’t work here)
Question 2: why if I don’t flash a new recovery but I launch “install from sdcard” (recovery mode) nothing happens?


This is the tutorial I use



1 Like

It worked!!! thanks to everybody and especialy to [quote=", topic:10788"]

I’ll check it out and be back for impressions and comments…

I unzipped the FP1 zip (FP1-Fairphone_OS_v1_8_7_OTA_2015081400) but I can’t seem to be able to continue further… what am I missing? Thanks

PS I’m on windows 7 by the way…

I assume that’s your problem right now :slightly_smiling: You can have a look at the software below, but not guarantee. Make sure you use “good” sources for windows binaries (beware of viruses, rootkits).

Untested & no guarantee


The main idea is to extract the FairphoneHome.apk from the old FP1 image. For this one converts the old FP1 image into an easy readable ext filesystem and installs the .apk from there.

Else: Why not try a Linux-Live-DVD/CD/USB Stick for fun?

Or you could try this flashable ZIP (pwd: ‘djdas’ without quotes) which I created and use to restore the launcher when I update the entire system :wink:
Please consider it works only with CWM recover because it is not signed.
Have fun :slightly_smiling:

1 Like

Thanks but all this sounds Chinese to me… But then again everything till now sounded Chinese but I managed… I’ll give it a try. Thanks again.

How about gravitybox for this version?

PS si far so good… Everything seems to work nicely.

1 Like

Just let us know what your problem is. Else, @DjDas’s zip looks like a good alternative, I guess. Haven’t tested it, but I think it will just install what you look for.

@DjDas: I think you need to make a small howto for the recovery :slight_smile:

Rocks!!! thanks DjDas! I installed it and so far so good…

By the way, I have to say that I’m very proud of myself (:innocent::blush:)

Also installed OpenGapps without anyproblem… for the time being everything seems to work fine… not gravitybox though…


Install .zip into sdcard
Go to recovery (previsously installed to flash ROM).
Install zip from sdcard

Choose FP launcher when the system asks.


I have a problem with sending WhatsApp Videos. Usually there’s a preview screen when you send a video. I can only see a black screen and the send button.

Anyone else experiencing the same?

When I go through widgets I get the message “fairphone OS stopped etc”. Is it a problem for anybody else or is it because I installed DjDas’s zip for fairphone launcher?


How about Gravitybox? it’s difficult to go without it if you know it exists! :grin:

I used the FP1 image to sideloaded the launcher apk. I cannot remember any problems with the widgets. Not sure if this helps. Flipping through the Apps/Widgets was pretty fast, that’s all I can remember.

Are there other apps on the FP1 that need to be reinstalled from the image? I can’t remember right now.