Unlocking bootloader FP2

Could you describe what is not working? What have you done exactly and how do you know it’s not working?

Seconded.
If you want to quit Google apps and services, and not quit android altogether, I’d recommend to use a degoogled Android like LineageOS or /e/OS. As Urs said, /e/OS is done to be simple and user-friendly, while Lineage looks more like a stock android.

2 Likes

Yes, I think I should try Lineage first. I didn’t know that there was such a big difference. I’ve been using many apps from F-Droid, and the change will be easier, if it’s just “google-free”. I know that many things won’t work, but I wanted to see how much is actually still possible without google. Thank you!

2 Likes

I try to describe it:
I installed ubports installer, launched it and followed the process. The first time I tried it, snap was not yet installed, and I corrected that. At a later try, I found out, that USB debugging had to be activated, and I did so.
Each time I try to boot (Volume Down + Power), nothing happens: I tried both ways, phone connected and disconnected, but I just saw the loading screen of FP2 when it was off and connected, the normal FP2 booting screen during my first attempts, and during my later attempts, the Fairphone ubuntu screen. Several times when I pressed Volume Down + Power, the phone did not react anymore, and I could only switch it off by taking the battery out.

I’m getting the following failure messages (is this the problem?):
Failed to load module “canberra-gtk-module”
g_settings_schema_source_lookup: assertion ‘source != NULL’ failed

My first try:
info: device selected: FP2
info: Installing Ubuntu Touch on your Fairphone 2 (FP2)
info: configuring…
info: settings: {“channel”:“ubports-touch/16.04/stable”,“wipe”:true,“bootstrap”:true}
info: Downloaded file 2 of 2

My last try:
info: device selected: FP2
info: Installing Ubuntu Touch on your Fairphone 2 (FP2)
info: configuring…
info: settings: {“channel”:“ubports-touch/16.04/stable”,“wipe”:true,“bootstrap”:true}
warn: undefined
info: All done! Your device will now reboot and complete the installation. Enjoy exploring Ubuntu Touch!

It looked all good, the ubuntu installation finished, I selected the reboot at the very end, and it was again Android.

Your phone was probably in fastboot mode (which is correct in this case). At least while Fairphone OS was still installed you should see the LED slowly blinking blue when in fastboot mode.
It seems that at least Ubuntu start screen was installed during your attempts…

Did you try to long press on/off button? Pressing it for more than 15s will do a reboot while being in any status.

3 Likes

Yes, I tried that, pressing the on/off button “forever”, but no reaction.

2 Likes

Sounds strange. But well, if you tried it and it didn’t work - it seems there is some strange status where even this HW based function does not work… :frowning:

1 Like

The strange thing is that the reboot to recovery is not working. It get’s stuck at erasing the cache partition (I’ve deleted the cache already), nothing happens, it just says “erasing cache partition…” When I decide to stop waiting, and press the buttons as shown, it reboots in Android asking for my password. When I disconnect it from the laptop, shut it down again and press the buttons as shown, the second picture appear with “No Command”. Again nothing happening, just waiting for device, nothing else

.

It’s normal.
When on this screen you have to

  1. hold the Power button pressed
  2. briefly press Volume +

And yes, indeed, with all cables unplugged.
(you can check the #dic:recoverymode guide)

1 Like

As was said above it still might be easier to just install LineageOS or /e/OS…

1 Like

Yes, and that’s not working. The phone is not reacting anymore, and I can only shut it down by taking the battery out. And if I then press on/off plus briefly volume up, it boots in Android.
I think I found the similar problem described here: [FP2] Instructions to get into Recovery do not work as displayed · Issue #1436 · ubports/ubports-installer · GitHub
I think it doesn’t make sense to try further. I hope I’ll be more lucky with Lineage. :slight_smile:
Thank you all! <3

2 Likes

I’m having the same problem with LineageOS. I’m following this description: Install LineageOS on FP2 | LineageOS Wiki
I checked that adb and fastboot are installed.
~> adb reboot bootloader
~> fastboot devices
fcf9f660 fastboot
~> fastboot flash recovery twrp-3.5.0_9-0-FP2.img
target reported max download size of 536870912 bytes
sending ‘recovery’ (10406 KB)…
OKAY [ 0.329s]
writing ‘recovery’…
OKAY [ 0.251s]
finished. total time: 0.580s
I would say this looks good. But I simply can’t reboot into recovery by pressing Volume Down + On/Off. Each time, Android starts as usually and asks for my password.
I tried to reboot into recovery by using this command:
~> adb reboot recovery
but I get “no devices/emulators found”, in both cases, when the phone is off or on, doesn’t matter. I even did it now without the case, precisely pressing the buttons, but it doesn’t work.
Does anybody know why this is happens? I will not be able to install any OS if I don’t resolve that, I guess. Does this sound like a hardware problem to you?

It’s Volume Up + On/Off.

If you’re doing it while on android you need to have android debugging on in the #dic:developeroptions .

Otherwise as a workaround you can use #twrpwoflashing.

3 Likes

Ah, right, I I press Volume Up + On/Off, I get the same “no command” screen I posted yesterday, no wipe option, nothing. And after a while, my phone starts in Android as usually.

It probably only works directly after flashing it. As you’ve started your phone “normally” (according to your post above) it won’t do…
So I recommend your repeat (while you’re again in fastboot mode and fastboot connection is ok as mentioned above)
~> fastboot flash recovery twrp-3.5.0_9-0-FP2.img
then type
~> fastboot reboot
and press the vol+up key at the same time while you send the command (and keep it pressed for some seconds); in this special case the power on button is not needed
This should finally bring your FP2 into TWRP recovery. :slight_smile:

6 Likes

@Volker It worked! This was the solution! I prepared the command, hit enter and immediately pressed the Volume Up + On/Off buttons. No reaction. Without letting go the buttons, I disconnected the phone from my laptop and it worked. All the other steps were easy, Lineage is installed. Thank you so much! :smile:

4 Likes

I’m happy to read that! Thanks for confirming the solution and have much fun using LineageOS!

2 Likes

Hi folks,

looks like with this topic I finally managed to come nearer to an answer to my bootloader problem.
My original intention is quite the same as Felicias. I’d like to change my FOS to /e/OS.
And roughly I managed to do the same as Felicia in Jan.
And now the BUT - for which I hope for some good ideas.
I also checked that adb and fastboot are installed on my desktop computer (Windows 10). The device is found in the first attempt
~> adb devices => brings result
~> adb reboot bootloader => starts FP2 (in fastboot mode?), LED flashing blue
=> BUT: no more device can be found
~> fastboot devices => no result

I assume, the problem is the default USB Mode. Default is set to “charging”, not to “file exchange”.
But I’m not able to change that, even with developer options set and USB debugging allowed. Everytime I change the default to “file exchange”, after reboot it’s set back to “charging”.

Any good ideas or suggestions for me?

Thanks a lot already in advanced

I would check if all driver are up to date by
Connect FP in fastboot to your PC
Go to Windows Update
Search for Updates
Additional (or similar)
Driver
Install whatever shows with Google

The USB Mode is AFAIK not relevant when you work in fastboot/bootloader, and its normal that it will always start with USB Charging and you will have to change to data transfer or whatever you need

3 Likes

While this should be true, I can attest of someone who had the same problem, on whose phone (FP2 under FPOOS 19.08.1) data transfer was not working, neither was fastboot or adb (and after all the basic and advanced troubleshooting I was suspecting a hardware issue), before they booted in safe mode, noticed a bug that was resetting the USB mode always to a different other random one after reboot, and changed it back to file exchange (in safe mode), then booted in fastboot and it was working again. I’m not saying it’s a similar case here (and probably it isn’t), and I’m only mentioning to say sometimes informatics are strange and illogical.

2 Likes

only sometimes? :upside_down_face:

2 Likes