UnifiedNlp localization don't work anymore (Open 18.10)

Using latest Fairphone Open and microG, localization services from UnifiedNlp don’t work on my phone.

The tool checkup is as follows:

The system did not bind the UnifiedNlp service.
UnifiedNlp has no last known location.
UnifiedNlp do not have Location to test Geocoder.

What do I have to do to get UnifiedNlp to work again? Thanks!

You’re not alone with that issue.

Maybe you should report it to the #bugtracker if it’s not reported yet.


I had the same problem and was finally able to solve it!
You have to change the two apps “microg Services Core” and “microg Services Framework” to become System Apps.
In order to do so you need to move their app folders from /data/app to /system/app
You can do this with ES Explorer for example. The folders of the app are called “com.google.android.gms-2” and “com.google.android.gsf-1”.
Then you have to change their permissions as its written here:

After a restart of the phone it worked again for me.
Note: I originally installed the microg system via FDroid. I dont know if there are differences if you did install it manually.



Yup, it’s perfectly working! Thanks a lot!

For other users, I’d recommend MiXplorers instead of ES, though.

I used adb to move the folders. Works perfectly, thanks!

1 Like

Hi all,

I’ve the same issue. So I moved the folders to the system folder. But now I can’t see the microG settings app anymore. Is that the goal of it? Or did I do something wrong?

I had to reinstall microG from F-Droid after updating to Fairphone Open 19.02.1. After that I again had to make them system apps. This time I used Amaze from F-Droid to move them and change permissions which also worked just fine.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.