Unified NLP on Fairphone 2 Open OS

UnifiedNlp (no GAPPS) doesn’t work for me. I have an unrooted fairphone 2 running fp open os 16.06.0 without GAPPS, currently with mozilla and GSM backends. Nlps selfcheck says that:
android version supported
system supports location provider
unifiednlp is registered in system
location backend(s) set up
Network-based location enabled

are all ok. But it fails with:

UnifiedNlp has known location
UnifiedNlp provides location updates

Does anyone have a suggestion? I was under the impression that 16.06 didn’t need any patches for unifiednlp to work.

That doesn’t sound like failing but like success to me.?

Did you check whether you actually get a location in battery saving mode with a maps app?

Ah, sorry for being unclear. The selfcheck is a checklist with the things it should do, and the two last things are not checked. So what it’s saying is that unifiednlp lacks a known location, and that it doesn’t provide location update. Neither Osmand nor satstat can find my location in batterysaving mode

It looks like this

It looks the same for me, but it works anyways.

The “location backends set up :heavy_check_mark:” appears if you installed backends, but doesn’t mean that you actually set them up and that they are working. Go set them up and if you still don’t get a location in Osmand (Satstat won’t help in battery saving mode) try different backends. Some backends need a downloaded/imported database the others need an internet connection - all need you to have wifi enabled and/or a SIM inserted and to be somewhere where someone already added the nearby wifis and cell-towers to the database.

1 Like

Ok, I have now experimented some more.

Neither mozilla location service nor openbmap unified works while online. openbmap unified offers to download an offline databses, but nothing happens if I accept.

In GSM location service I can choose between “Download all areas and only save chosen” and “Download chosen areas from lacells (data may be old)”. The first alternative takes half an hour and does nothing, but the second actually kind of works! Osmand still thinks I’m about 3km from where I actually am though… How big does the margin of error tend to be in battery saving mode?

Do you still have this problem? Have you found a solution? The same happens to me (and by the way, how did you find out that the backends don’t work while online? I know Osmand can locate me but I don’t know what it is using to do so…)

Has anyone encountered this message: “microG Services Framework Proxy has stopped”? I get it almost every time I launch my weather app (Meteo Swiss). The app works, though…

@Linda_CH: This happen if you install it before “microG Services Core”, just reinstall “microG Services Framework Proxy”.

The two patches seem to be merged upstream from what I remember. So it’s not any more necessary to apply them - and therefore it’s not even necessary to recompile it.

I just tried it in a newly installed FPOSOS:

adb root
adb remount
adb shell

In the shell:

cd system/etc/permissions/
rm com.qualcomm.location.xml
cd /system/priv-app/com.qualcomm.location
rm com.qualcomm.location.apk

Then again:

adb reboot


1 Like

I installed UnifiedNlp via F-Droid today after updating Fairphone Open to version 17.08.1 – and it just works (at least with OsmAnd~).

The Self-Check in UnifiedNlp Settings still says Your system does not support this UnifiedNlp package. Either install a matching package or a compatibility Xposed module and UnifiedNlp is not listed as active location provider in Android’s location settings. But still, my current location is shown immediately after starting OsmAnd~…

Same situation with the self-check:

Have you tried changing the location mode?
When I’m in “device only” mode, I have a fix really quick with satstat, then quite fast with Osmand, but 150km away… But in less than 1 minute I have a perfect location.
When I’m in “Battery saving” mode, I get a quick location within Osmand, but 1 km away and I don’t get a better location after 5 minutes.
Something wrong!

Yes, but I have no problems (except the mentioned error message in UnifiedNlp). When I use GPS I usually get a fix in ~3-4 seconds.

In battery saving mode the device uses visible cellular networks and Wi-Fi networks to determine your location, so you won’t get a more precise location if you wait.

You can install Mozilla Stumbler to help collecting Wi-Fi networks – so you can help us all to get more precise locations in battery saving mode :wink:


Well, I wasn’t very clear… I asked if you had tried changing the location mode because I wondered if you only had tried in “high accuracy” mode, which would give you a location even if UnifiedNlp doesn’t work. Sorry that I wasn’t clear.
Anyway, I’m happy to know that I’m not the only one having the bad report in the self-check!

Mine also claims not to work, but will give me a fix any combination of GPS, mozilla and localGSM. When connected to mobile data its very accurrate even without GPS, but then I have used the Mozilla Stumblr app around by area quite a bit!

I see your patch has been merged but UnifiedNLP still complains about missing support of non-Google location providers.
Am I missing something?

Edit: it seems to work correctly. I guess that’s just a bug in the self-check.

Unfortunately this isn’t the case anymore. I’m using at least one app that will stop having access to GPS location when I disable com.qualcomm.location. Confirmed 3 times after rebooting, just to make sure it wasn’t a coincidence.

I switched to LineageOS which doesn’t include this stuff and works much better a long time ago.

Fine, but I’m inclined to believe that the Google Play Services and Google Location dependent apps that I mentioned wouldn’t run under LineageOS anyway, so this isn’t the issue. The issue is that com.qualcomm.location is necessary for some recent niche-market apps to fix a location, and I can only wonder why, maybe they use geofencing or some similar technology, the most problematic apps that I know are maybe not coincidentally tied to geographically-delimited services.

Why? Lineage OS is based on AOSP and it pass the Google CTS, AFAIK. I’m honestly curious.