Unable to use "Setup Wizard" for new users [FP Open OS 17.06.4]

Hi there fellow Fairphoners,

It’s my first call for help here, so please keep your fingers crossed for me. I also hope that I’m doing this right…
I have an issue with using multi users on the new Android 6-based Open OS.
During the Android 5.1-time, I used one Android user account exclusively for all Whatsapp-based stuff (because I heavily distrust Whatsapp but still everyone including his/her mom is using it), so I could isolate Whatsapp from my ‘regular stuff’ on the phone as much as possible. I wanted to go for the same approach on the new OS, yet setting up new Users is pretty much impossible:

Adding new Users to the system works pretty well. After switching to the newly created user, I arrive at the notification screen of the new user, so everything okay up to that point as well. If I now want to enter the system by swiping upwards, the system wants to run a “Setup Wizard”, which inevitably freezes the system to some point. In that state, of the three control symbols at the very bottom of the screen, only the left ‘back’-symbol is visible and visibly reacting, yet it won’t do anything. The upper system bar is visible, but unresponsive. The rest of the screen remains black.

By double tapping the power button to engage standby and wake the system directly after, the regular notification screen shows up and the phone becomes responsive again. If I swipe up again, the very same thing happens again.

From the notification screen, I can enter the system settings. I can even access the apps menu and close the “Setup Wizard”, which makes the two missing control symbols at the bottom reappear. However, this is not anything like a workaround, because the new user isn’t yet set up correctly and the “Setup Wizard” is started again, which makes me stuck at the same point.

In the Internet, I have seen a method to skip the setup by tapping in all four corners of the screen clockwise. Well, that didn’t work for me (I guess because the process is unresponsive).

After upgrading to Android 6, I have set my phone to factory settings because I have had some other issues. I also tried safe mode and I have tried removing SIM- and MicroSD-cards. Neither method worked for me. I’m pretty sure the issue is related to a bugged Setup Wizard or something related - a software problem.

It seems that the setup for new users is broken in the recent Fairphone Open OS. The problem affects every additional user on the phone including the guest account.

Is there a way to skip the setup or to add a new user which has already been pre-set up? Does anyone have any idea how to solve or bypass this problem?

Thank you greatly in advance and have a nice day!

The same bug existed when Open OS was first released and it seems it’s back with the Open OS upgrade.

Please file a report in the official #bugtracker (after searching if someone else already reported it).

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.