Unable to take screenshots in OpenOS 16.06


I can’t take screenshots on my FP2. I have OpenOS with OpenGAPPS pico and the XPosed modules GravityBox, BootManager and XPrivacy. The error message I get is “Screenshot nicht möglich. Entweder zu wenig Speicher oder die App/Ihr Unternehmen lässt dies nicht zu.” I have 17GB free in internal storage and 13GB on my SD card.
Does someone of you have the same problem and know a solution?

Just made a screenshot without a problem. But I don’t use any XPosed modules or the like.

I tried deactivating the modules, but it didn’t work…

What did you want to take a screenshot of? I know that there are some apps (like GMX Mail App) that don’t allow screenshots at all. So, maybe you could try to make a screenshot of your main screen. If this works, it’s very probably the app that is restricting your screenshots.

1 Like

Nope, doesn’t work on the main screen :frowning:

could refer to RAM. Maybe it will work after a reboot.
I don’t think it is due to the apps/components installed you mentioned, except for boot manager I have them as well; though no problems with screenshots.

So I would recommend to clear RAM and cache, mabye reboot, and then check again if it works.

Okay. Then maybe something is wrong with the folder where your screenshots are saved. Could you try to delete that folder? And then try again.


Yup, it seems that there is an errorous undeletable (screenshot-)file in the folder. But how do I get rid of it?

Is it on the SD card?

Can you also not delete it from terminal as su?

It is on the internal storage (standard screenshot folder). And I don’t know how to use terminal with supersu since I hardly managed to root my device at all…

I guess you already tried to delete this file through Amaze? Alternatively, you could connect your FP2 to your PC and locate and delete it through Windows Explorer.

The Open OS is rooted, you only need to activate it in the developer settings. When you open the terminal, you only need to type “su”, and you are superuser.
Anyhow, the reason why I asked about it is because I was thinking maybe some app with other rights created that file, thus as su you can change the file permissions (or maybe the folder permissions); respectively, as su you may have the privileges to delete a file you otherwise cannot delete.

So I installed Terminal and now I am a superuser (however I don’t feel super at all). What do I have to do to delete this file (which is named “Screenshot blablaba”, so I assume it is not created by a specific all)?
EDIT: I searched for the delete command and typed this:

u0_a140@FP2:/ $ su
root@FP2:/ # rm -r /storage/sdcard0/Pictures/Screenshots/Scrshots/Screenshot_2016-07-04-06-48-16.png <
rm: /storage/sdcard0/Pictures/Screenshots/Screenshot_2016-07-04-06-48-16.png: Permission denied
1|root@FP2:/ #

I don’t know what this means, but " Permission denied" doesn’t sound good to me… :fearful:
PS: Sorry for the Scrshot typo

Terminal is installed by default on Open OS.
When you are su, just go to the file location

cd /path/to/your/file

and remove the the file

rm filename.png

1 Like

Nothing scary, but also interesting. I just also tried to delete screenshots this way, and I have no problems as superuser. What does

ls -al

give you?

Nope… And by the way, it seems not to be a virus. At least Bitdefender says that

u0_a140@FP2:/ $ su
root@FP2:/ # cd /storage/sdcard0/Pictures/Screenshots
root@FP2:/storage/sdcard0/Pictures/Screenshots # ls -al
lstat ‘./Screenshot_2016-07-04-06-48-16.png’ failed: Permission denied
root@FP2:/storage/sdcard0/Pictures/Screenshots #

I don’t know much about IT, but my “Hausverstand” tells me that whatever created this file has had more rights on the system than SuperSU has which is (I think) impossible…

The interesting information would be in front of the file name; e.g., I have for screenshot files the following information:

-rw-rw---- root sdcard_r

which shows the file owner and permissions.
What you can try is (as root)

chown root:sdcard_r filename.png
chmod 644 filename.png
rm -f filename.png

This way you will change the owner, then the permissions of the file, and then try to delete it again.

u0_a140@FP2:/ $ su
root@FP2:/ # cd /storage/sdcard0/Pictures/Screenshots
hown root:sdcard Screenshot_2016-07-04-06-48-16.png <
chown: sdcard: invalid group name
1|root@FP2:/storage/sdcard0/Pictures/Screenshots #
sh: chown:sdcard: not found
127|root@FP2:/storage/sdcard0/Pictures/Screenshots #
sh: chown:Screenshot_2016-07-04-06-48-16.png: not found
127|root@FP2:/storage/sdcard0/Pictures/Screenshots #
/Screenshots/Screenshot_2016-07-04-06-48-16.png <
Usage: chown [-R [-H | -L | -P]] [-fhv] owner:group|owner|:group file …
chown [-R [-H | -L | -P]] [-fhv] --reference=rfile file …
1|root@FP2:/storage/sdcard0/Pictures/Screenshots #
chmod 644 Screenshot_2016-07-04-06-48-16.png
Unable to open Screenshot_2016-07-04-06-48-16.png: Permission denied
10|root@FP2:/storage/sdcard0/Pictures/Screenshots #

PS: I am very sorry for my typos and general incompetence in this topic…