English

Unable to reinstall FP OS after trying out /e/OS

After trying out /e/ OS on my new FP3+ I decided that I would go back to FPOS. I have followed the steps but each time it gets stuck with an “error reading sparse file”.

I have tried the last few versions of FP OS available on the main site and through the changelog page. Does anyone have any ideas how I can fix this.

The phone will boot into the bootloader, recovery mode works but doesn’t restore the device to working FP OS.

I would be very grateful for any help/suggestions.

Cheers,

Flash image

1.Erase user data
2.Keep user data

Please make a selection, and press enter:1

List of devices attached

error: no devices/emulators found

Waiting for 0 seconds, press a key to continue …
A209SR2R0202 fastboot
Unlock device
FAILED (remote: ‘unknown command’)
fastboot: error: Command failed
Rebooting into bootloader OKAY [ 0.000s]
Finished. Total time: 0.000s

Waiting for 0 seconds, press a key to continue …
Fastboot partition
Sending ‘modem_a’ (90112 KB) OKAY [ 2.076s]
Writing ‘modem_a’ OKAY [ 0.503s]
Finished. Total time: 2.860s
Sending ‘modem_b’ (90112 KB) OKAY [ 2.106s]
Writing ‘modem_b’ OKAY [ 0.506s]
Finished. Total time: 2.818s
Sending ‘sbl1_a’ (443 KB) OKAY [ 0.047s]
Writing ‘sbl1_a’ OKAY [ 0.016s]
Finished. Total time: 0.109s
Sending ‘sbl1_b’ (443 KB) OKAY [ 0.031s]
Writing ‘sbl1_b’ OKAY [ 0.016s]
Finished. Total time: 0.109s
Sending ‘rpm_a’ (170 KB) OKAY [ 0.031s]
Writing ‘rpm_a’ OKAY [ 0.016s]
Finished. Total time: 0.094s
Sending ‘rpm_b’ (170 KB) OKAY [ 0.031s]
Writing ‘rpm_b’ OKAY [ 0.016s]
Finished. Total time: 0.109s
Sending ‘tz_a’ (1495 KB) OKAY [ 0.062s]
Writing ‘tz_a’ OKAY [ 0.031s]
Finished. Total time: 0.156s
Sending ‘tz_b’ (1495 KB) OKAY [ 0.063s]
Writing ‘tz_b’ OKAY [ 0.031s]
Finished. Total time: 0.141s
Sending ‘devcfg_a’ (39 KB) OKAY [ 0.031s]
Writing ‘devcfg_a’ OKAY [ 0.016s]
Finished. Total time: 0.111s
Sending ‘devcfg_b’ (39 KB) OKAY [ 0.032s]
Writing ‘devcfg_b’ OKAY [ 0.016s]
Finished. Total time: 0.096s
Sending ‘dsp_a’ (16384 KB) OKAY [ 0.406s]
Writing ‘dsp_a’ OKAY [ 0.109s]
Finished. Total time: 0.578s
Sending ‘dsp_b’ (16384 KB) OKAY [ 0.407s]
Writing ‘dsp_b’ OKAY [ 0.111s]
Finished. Total time: 0.565s
Sending ‘splash’ (109 KB) OKAY [ 0.031s]
Writing ‘splash’ OKAY [ 0.017s]
Finished. Total time: 0.111s
Sending ‘aboot_a’ (1742 KB) OKAY [ 0.078s]
Writing ‘aboot_a’ OKAY [ 0.031s]
Finished. Total time: 0.156s
Sending ‘aboot_b’ (1742 KB) OKAY [ 0.062s]
Writing ‘aboot_b’ OKAY [ 0.031s]
Finished. Total time: 0.156s
Sending ‘dtbo_a’ (8192 KB) OKAY [ 0.203s]
Writing ‘dtbo_a’ OKAY [ 0.062s]
Finished. Total time: 0.328s
Sending ‘dtbo_b’ (8192 KB) OKAY [ 0.205s]
Writing ‘dtbo_b’ OKAY [ 0.064s]
Finished. Total time: 0.315s
Sending ‘vbmeta_a’ (8 KB) OKAY [ 0.031s]
Writing ‘vbmeta_a’ OKAY [ 0.016s]
Finished. Total time: 0.109s
Sending ‘vbmeta_b’ (8 KB) OKAY [ 0.035s]
Writing ‘vbmeta_b’ OKAY [ 0.016s]
Finished. Total time: 0.098s
Sending ‘boot_a’ (65536 KB) OKAY [ 1.534s]
Writing ‘boot_a’ OKAY [ 0.375s]
Finished. Total time: 2.051s
Sending ‘boot_b’ (65536 KB) OKAY [ 1.551s]
Writing ‘boot_b’ OKAY [ 0.372s]
Finished. Total time: 2.075s
Sending sparse ‘system_a’ 1/6 (516036 KB) FAILED (Error reading sparse file)
fastboot: error: Command failed

As you get various fastboot errors you might check the fastboot SW you’re using… Where did you get it from and on which OS is it running (Windows? Linux? Version?)?

1 Like

Thanks, I got the fastboot as part of the android tools download advised in the installation manual for /e/os. Is there anywhere else to get a copy that I can try? I’m on windows but I’ve got a Ubuntu pc I could try. Cheers