Unable to install some apps (Blendle) after 1.6 repartitioning

Same problem here: unable to update WhatsApp.

I did the unified storage and upgraded to 1.6. Restored using Titanium (free version). Honestly I don’t recall exactly what settings I used (or if I restored any of the google apps from Titanium), as it was months ago. I didn’t install google apps or the app store. Today I found out my version of WA would expire soon so I decided to install google apps (by the way, you can download the WA apk install file from whatsapp.com, I wish I had known this before!). Then it started auto-updating all my apps (WTF?! there are some I don’t want to update). So I turned off all data/wifi until I could find the setting to not auto-update. Anyway I got everything under control, then updated a few apps. Then when I went to update WA, it said insufficient storage. No problem, I uninstalled a couple apps and cleaned the cache. But when I tried again to update WA, still insufficient space even though I have over 11GB free. So tried to restore it again from Titanium, but it took forever and never finished. So I rebooted and tried again. Same problem. So I rebooted and uninstalled WA, thinking I could just install it over again from the app store. but no, still insufficient space. I installed a few other new apps without issue. I tried downloading the apk to my SD card and installing it that way, but still insufficient space. What’s going on? Why is this phone such a pain in the ass?

Update: There were no Google Play updates to uninstall. I did the wipe partition cache thing, which didn’t fix the issue either.

Update2: I did a hard reset and wiped cache partition. Google apps was still installed. It again tried to auto-update. I stopped it. I successfully installed WhatsApp, OneDrive, CBC Radio, and AnyConnect ICS+ (the rest of the apps I didn’t update because I was afraid that I wouldn’t be able to restore my app data from an old version). I closed the Play store and then it suddenly became a different version the next time I tried to open it (black edges around the icons), and now there is an option to uninstall updates.

Update3: then I restored via the stock backup and restore. No issues. Then I tried to restore via Titanium, only I deselected the Play store. Here’s where the wheels fell off. It wouldn’t restore those apps listed in my second post, plus a few others. So I lost the app data. But since many were already up to date from Update2, it’s ok for now. The others that wouldn’t restore via Titanium also still can’t be upgraded in Play store. I tried deleting them and reinstalling, but now I can’t install. WTF?! I also tried uninstalling the google play updates, no help. So I’m stuck again. Titanium sucks. Most of my settings didn’t restore. I’m really annoyed with this crappy phone/android. So many bugs, and each fix just breeds more bugs.

Update 4: tried re-doing the hard reset/wipe, tried restoring things in a diff order: stock restored titanium, then updated titanium (the changelog said it had fixed exactly this error!). Then I did titanium restore for everything except the apps I didn’t want to update (facebook, messenger) and not google play. then went to stock backup and restored personal data and those apps I had skipped. but only half of them would install; the rest failed (Facebook, but not Messenger).

So this is ridiculous. I will try again later skipping titanium completely (so really Titanium becomes useless and if they really did fix the error, it probably only works if you made the backup with the latest version, which doesn’t help me).

update to the list of apps I was unable to update:
AnyConnect ICS+
CBC Radio
FlightView Free

Hopefully you will manage consuela! What worked for me in the end was:

  1. Doing a hard reset.
  2. Install Google Apps. (Or perhaps this came automatically with the reset?)
  3. Just let Google Play update whatever it wants to update (perhaps itself).
  4. Installing Titanium Backup the normal way through Google Play.
  5. Use Titanium Backup to restore only specific apps that I really wanted (not Google/system stuff).
  6. Let Google Play update those apps.

It was a bit of a frustrating experience to figure out what needs to happen, but in the end it seems quite logical. There are so many things that are wrong though:

  • We probably didn’t follow all the instructions to the letter. But we shouldn’t have to expect so much trouble.
  • Titanium Backup shouldn’t restore apps that cause this kind of trouble, at least not without a warning.
  • Google Play should be able to figure out what is wrong and not break like that.
  • In general, syncing your app data shouldn’t be so ‘risky’ and troublesome.
  • The repartitioning shouldn’t have been necessary in the first place. (You can make an entire other list of what went wrong that caused the repartitioning to be needed…)
  • etc…

Nevertheless, I’m very glad that we have a phone that allows us to backup our apps and data without requiring someone else’s permission.

Same problem here. I haver version 1.6 but can not install/upgrade what’s app

Have you had a look here? Also, did you try the steps @Hugo_Buddelmeijer described above?

I have tried one of them, now going for the hard reset :frowning:
Not at all impressed by the android performance so far on this device…