UBports works or not? - Problems with installation

I’d use the RC channel, because the devel one is too much pain for a daily use :wink: By the way, for more informations about channels, you can visit this page @raphael68 : https://wiki.ubports.com/wiki/Release-Channels

I just tried with the Windows installer 0.1.9-beta from https://github.com/ubports/ubports-installer/releases and successfully installed the 15.04 RC channel.

Basically these were all the steps I took:

  • Enabled developer mode
  • Enabled USB Debugging
  • Connected the FP2 via USB
  • Allowed my PC to access the device and marked the checkbox to always allow it
  • Changed the USB mode to MTP (default was charge only)
  • Started the UBPorts installer and followed the instructions

A small video of the result is here: https://twitter.com/Ingo_FP_Angel/status/940683079047360513

3 Likes

Glad you succeeded @Ingo !
Did you also installed ADB drivers for Windows or it was not necessary ?

1 Like

I already had them installed previously to install LineageOS. So I can’t say if it would have worked without them.

2 Likes

Hooray it worked!

I made the whole thing on another Laptop (same ubuntu configuration) with the adb-things and the ubport-Installer…

3 Likes

Hallo I also need Help with installing Ubuntu touch on my new Fair-phone 2 with 12mp Camera Module.
I tried to install it several times did not work out. I did in on a win 7 system with CPT Installer but the installation went wrong (aborted at maybe 30 % of precess. Now I’m not able to start android or ubuntu or anything else. I think it only starts in bootloader mode but I’m not sure. There are two modes fist is the logo as in bootloader mode and second is black screen with only flashing a little red LED when I try to activate bootloader mode whit pushing Vol. down and Power button an same time.
Now I’m on a ubuntu running laptop tried UBports, CPT and magic device tool but all 3 are not able to detect the phone (in bootloader mode)

Can anyone help me, please?

I moved your post here as - even though the title doesn’t suggest it - this is a more recent topic discussing the same. Maybe you find some answers in the posts above.

I’m not sure I can help. First thing I would try is to check if in either of those two modes your FP 2 is seen by one of the following commands

adb devices
fastboot devices

How to set up those if youi haven’t yet can be found at https://wiki.lineageos.org/devices/FP2/install

Thank you Paula :slight_smile: Could you rename the title to something like “UBports Ubuntu Touch - installation instructions” and make it a wiki, so we all can summarise there what are the points to be tested in case of installation failure?

Well there is already a ubports wiki here:

You could include the install instructions there or (probably better) start a new wiki. Wikis generally work best as one-post-topics (so you know at one glance which #wiki’s were recently updated).
We can then link the guide in the first post (and the other ubports wiki) and even give it a unique tag so it can be linked to quickly (e.g. #installubports).

1 Like

I tried to install UBports with the installer for macOS, but the app couldn’t establish a connection with my Fairphone. This wasn’t a surprise, because I failed to install Fairphone Open on macOS either and had to switch to Linux for the installation.

So I switched to Neon VM and tried to install UNPorts with the installer for Linux. Unfortunately after rebooting the device in the recovery mode, the installation process got stuck. The video of UBPorts suggests, that the process should continue.

Has someone any advice? Maybe the installer is only working under Ubuntu?

At the UBPorts forum I didn’t get an answer.

1 Like

did you launched the UBPorts installer with “sudo” ?

did you checked that adb and fastboot is installed and your device recognized with “adb devices” (or with “fastboot devices” in bootloader mode) ?

1 Like

I have successfully used the ubports installer on Windows and Opensuse Linux, so it is definitely not Ubuntu-only. Can’t say for macOS, though. I think I remember someone in the ubports telegram groups saying there are not a lot of mac users so it could very well be it’s less tested on that system.

First you should follow the hints by oli.sax, i.e. trying to launch the installer with “sudo”. And if that doesn’t work, start debugging the issue by checking if adb and fastboot work standalone.

Additionally, the installer writes a log file. On my linux machine it is located at

<installation folder>/.cache/ubports/ubports-installer.log

There you could also look for messages indicating the problem.
Warning: don’t simply paste the whole logfile here. As far as I remember the installer logs all command lines it internally executes. That could contain your password when it’s called with “sudo”!

Yeah, their forum isn’t that active was my impression, too. They mostly deal with problems in the various telegram groups. Did you go to their welcome channel? Typically people are very helpful there (and when you run ubuntu touch I guess there is no way around Telegram anyway). Check https://ubports.com/page/telegram-welcome

1 Like

did you launched the UBPorts installer with “sudo” ?

No I didn’t. This is a good idea. I have launched the installer just with a double click

Edit: This worked fine. I will post a note in the UBPorts forum to update the installation guide.

did you checked that adb and fastboot is installed and your device recognized with “adb devices” (or with “fastboot devices” in bootloader mode) ?

Yes, but only with sudo I have access rights to execute commands.

I have successfully used the ubports installer on Windows and Opensuse Linux, so it is definitely not Ubuntu-only.

Ok, thus I will try it on my Windows VM either. The log file is a good point either.

Edit: There was an exception stacktrace in the log. The app did lost the connection to the phone. But after manually rebooting to the recovery mode, the app ciuld establish the connection again.

Thanks for your help.

2 Likes

I have the same and I get used to type sudo fastboot.
However, I didn’t tested yet but there is a way to change udev rules so fastboot can work without sudo…

If you are talking about “docs.ubports.com” you can even update it yourself with git by submitting a pull request :wink:

1 Like

Hi, I have a FP2 and I want to install another alternative OS because I don’t want to be under Google Apps. I’m thinking about Ubuntu because i saw that you just need to use a program (Im looking for easily installation). Works fine 100%? Thanks.

I would wait until OTA-5 which is scheduled for early October. Some bugs will be fixed by then.

What do you want to do with the phone? Which (type of) app do you intend to use?

2 Likes

Hi, normal use like email and surfing con the internet. Apps like Signal, Firefox, and things like that.

1 Like

Haven’t used UT in a while, but from what I understood, still email and browser (it’s not Firefox) are not working perfectly yet.

You can check what apps are available at https://open-store.io/
But beware, some apps are listed but only available for vivid (15.04), not xenial (16.04).

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.