UBPorts 16.04 updates + feature tests

Can’t say. Whenever there is talk about anbox in the UT telegram groups there are references about trouble with Qualcomm devices. But maybe this is just coincidence.
And as far as I understood, UT uses Mir, not Wayland.

1 Like

Thank you.
At least for me, camera isn’t upside down anymore (when I tried last time). It has correct orientation, but is incredibly laggy when you shoot a photo. So, as there seems to be progress in this issue, I thought that some progress might have happened to the flash in the mean time, too.

1 Like

Haven’t done any new testing, but just wanted to share that OTA-4 is out which means that now 16.04 LTS is the base of Ubuntu Touch :slight_smile:

Ubuntu Touch OTA-4 Release :uk:
Ubuntu Touch auf LTS-Basis gehoben :de:

It still has a few problems, so the automatic update for existing installations on the stable channel will switch to 16.04 with OTA-5 which is expected to arrive early October.

2 Likes

I’m on OTA-4. With some issues that need to be solved on OTA-5 (for example, Web Browser-next is not yet ready), but it runs really well. Very good OS. Dekko 2 Beta runs well, although needs to be “finished”. But I can see new mails, answer them… Flash is yet useless. But Camera runs very well (front camera is upside-down, but I think this is a “Stranger Things” reference, Isn’t it? Ho, ho…).

I hope OTA 5 will arrive with amazing changes too. And I heard that OTA 7 will bring Unity 8 and probably New MIR, in January. Great!

1 Like

Small update: there is a call for Anbox development testers in the UT forum

2 Likes

Ubuntu Touch OTA-5 succesfully upgraded from OTA-3, with the ubports-installer on Xubuntu, with sudo. :white_check_mark:

What works for me:

  • New browser: Morph. :earth_africa:
  • Dekko 2 community edition: sending and receiving mails (IMAP). :email:
  • Telegram, even for group messages. :arrow_forward:

What I’ll test later:

  • CardDAV/CalDAV sync. :calendar:
  • Linphone SIP VoIP calls :phone:
  • SSH connection with laptop :computer:
  • Libertine container :tophat:
  • Anbox ?..

What doesn’t work

  • Flash (new camera): known bug :flashlight:
1 Like

Just installed UT again on my device for testing and restored the contents of my home directory.
Wanted to try out anbox next, but the system.img only has 2GB which are almost full. I found some instructions how to enlarge that, but I’ll postpone that for later.

Edit: there is also some hint to clear the apt cache and set the reserved blocks in the image to 0. Then the space is sufficient.

2 Likes

First impression: anbox enabled (not actually running) already drains the battery a lot (phone is unresponsive and gets extremely hot).
So the most important command to learn was anbox-tool disable. :smiley:

1 Like

Now some real testing…

I pulled some APKs from my android phone using this description at Stack Overflow.

Then I pushed them to my ubuntu phone

adb root
adb push *.apk /home/phablet/anbox-data/data

Once the APKs where on the phone I installed them as described in the UBports anbox doc.

Refreshing the app scope made all the nice android app icons appear.

As I feared my bike sharing app doesn’t work. It uses Google maps but Google services are not available in anbox.

What does work is Spotify :slight_smile:

2 Likes

Would MicroG be available (now or in the future) ? It could do the trick :wink:

1 Like

Well, I even thought that it might be possible to install opengapps?! But I’m just as the very beginning of trying out anbox :wink:

Installed microG, but it simply doesn’t seem to work.

But good news (for some): WhatsApp works like a charm :smiley:

Edit: these are the apps that work for me

  • CatLog
  • Onleihe
  • Spotify
  • Threema (Polling instead of Push notifications)
  • WhatsApp (probably also polling)
  • my banking app

But please take note: I haven’t tested those in depth and am not using them on my daily driver, so maybe some problems went unnoticed so far

What didn’t work

  • AdAway (needs root)
  • Bücherhallen (doesn’t run without gapps; managing wish list works)
  • car2go (doesn’t run without gapps)
  • DB Navigator (crashes immediately on start)
  • Drive Now (doesn’t run without gapps)
  • Firefox (looks as if it works, but web pages are rendered entirely black)
  • iButtons (simply doesn’t start)
  • Real Drum (simply doesn’t start)
  • Stadtrad (doesn’t run without gapps)
  • vlc (upper third of screen remains black, the app window seems shifted down and lower part is not visible)
1 Like

I saw your video on the Telegram group, Whatsapp is quite fluid! :smiley:
What about the battery life (now that you installed android apps)? Does anbox still drains the battery or not too much?

1 Like

Actually, typing in Android apps is not as fluid as it seems on that video. When I’m not holding a camera in one hand and using the other to type while trying to get a video as stable as possible, the OSK is not as fast as I usually type.

Can’t say much about battery life. In general it’s not good on UT and the phone gets a lot hotter than on Android in any case. And while testing things the phone is usually connected to a power supply or at least via USB to PC because I’m using adb commands quite often.

I remember the first time I tried anbox the battery drain was higher than the charging via USB from PC. But last weekend that wasn’t the case.

2 Likes

Small update: in the corresponding github issue about not working external display, someone suggested to add one line to the apparmor config, because the root cause is a “permission denied” on some file.

See: https://github.com/ubports/ubuntu-touch/issues/781#issuecomment-423732902

I’ve tried that and now I can connect to my Samsung BD-J5500 Blu-Ray player again.
But, as with 15.04 the external display freezes after a rather short period of time (felt like 10s or so).

1 Like

Today’s current status:

CardDAV : the existing account from OTA3 was still there but not updated, I re-run the sh script and now I have two CardDAV accounts, so the majority of my contacts are doubled. :wink:
To do: understand how to delete one of the two accounts
To check also if the crontab was successfully set-up by the script :slight_smile:

CalDAV : strangely the script doesn’t work at all !
[INFO @caldav] @caldav/caldav: log in succeeded, but server refuses access - contact server operator
Workaround = use the interactive method (Open the Calendar app, click on the little calendar icon in the top right corner and select “Add internet calendar > Generic CalDAV”. Enter your calendar URL as well as your username and password to complete the process.) -> this works :smiley:

Anbox:

  • flash anbox-boot-FP2.img
  • launch Ingo’s script “install_anbox.sh” (cf Telegram group)
  • type anbox-tool install (it takes ~25min before saying Install done! Anbox is ready to rock! :slight_smile:
  • adb push whatsapp.apk /home/phablet/Documents
  • from the phablet-shell : adb install whatsapp.apk

And it is working :slight_smile:

2 Likes

I uploaded the script you mentioned to https://gist.github.com/Ingo-FP-Angel/63927c2d03acddfc89dd5097f5210bbe

Thanks a lot for your testings! Unfortunately, I didn’t succeed to install UT through the installer 0.1.21 on Windows 10. I tried the older versions 0.1.20 and 0.1.12 but it’s not working neither. Is there an other way to install it or do I have to try each older version of the installer? (Or is it just Windows 10 related?)

I can’t give a definitive answer. The older versions of the installer where people reported success were 0.1.9 and 0.1.12. And it is said that mac and windows versions may give more trouble than the linux versions. In the Telegram install group it is suggested to use a Ubuntu 16.04 live USB stick when the win installer doesn’t work.

If you are willing to try this version, it would be nice to hear some feedback: https://ci.appveyor.com/project/mariogrip/ubports-installer/builds/20538515/artifacts

Not sure why it fails for you, so no idea if the above version is of help at all. But it has somewhat more debug output in case of problems. So it might help finding the cause of the failure on windows.

Hello @Ingo ,

in your reviews about what works, and what does not, you don’t mention the compass. I think the fp2 has one built-in. Right? Does your work? Cause mine don’t in every ubports version.