English

TWRP for Fairphone 3

Hi there,

I’m not sure I would tell this here, if I wouldn’t, please tell me, I’ll delete my message. I’ve encountered a problem rooting my phone using twpr and magisck. May anyone help me ? I’ve created a new post in order to avoid “flooding” this one, here Problem with rooting FP3

And really sorry if my ask seems to you inappropriate.

I moved your post here.

Just to make sure, if I flashed your dump of A.0105 and was able to OTA to A.0110, I should stille be able to OTA, right?

I’m asking because my phone shows me that an update to A.0111 is avialable, but fails to install, but I haven’t modified my system since then.

What you see in the screenshot is not an error message, is there a button ‘Fortfahren’ which you can click?

Yes I can, but it simply results in an installation error:

After that, just flash the stock package again, this worked for me.

1 Like

This is going to format my userdata, right?

Edit: No it doesn’t. Found out by trying.

Could someone provide me with a full stock dump? The original link no longer works and I managed to trigger verity on my phone.

So, I’m on A0111 and rooted with Magisk. How does the update process look like for me? Can I just flash the A0111 image to restore stock boot, update, and then re-do the Magisk root procedure? Or do I have to be more careful and do something else before?

You should be able to directly do the OTA update. And you can even keep Magisk by just uninstalling it (restoring images, not full uninstall), then install the update normally but DO NOT REBOOT, then on Magisk, select “install in inactive slot (after OTA)”. This should work if you did not modify the system partition (mount read only).

Hey, thank you very much for your response. Sadly, I didn’t keep my system partition read only when rooting, so I guess flashing the stock sytem image is unavoidable for me.

This .zip is not directly flashable in TWRP, right? But can I unzip it and use its contents with the restore-option?

No, you can unzip it and flash the partitions with fastboot.
Here’s a script you can use or have a look at to see how it’s done …

Thank you very much, everything worked fine and I now have an even better understanding on how to flash around the FP3. Looking into that script was interesting, I didn’t realize that the FP3 has two slots for a bootloader.

I also stumpled upon the createTarFork() ERROR 255. These are the last lines of recovery.log:

I:addFile '/data/vendor_ce/0' including root: 1
  ==> set selinux context: u:object_r:vendor_data_file:s0
failed to lookup tar policy for '/data/vendor_ce/0' - 'b375d30057e757ba'
I:Error adding file '/data/vendor_ce/0' to '/external_sd/TWRP/BACKUPS/A209GQ1S0202/1970-05-19--13-05-18_89012A010520191217/data.ext4.win001'
Error creating backup.
I:ERROR tarList for thread ID 0
Error creating backup.
I:InfoManager saving '/external_sd/TWRP/BACKUPS/A209GQ1S0202/1970-05-19--13-05-18_89012A010520191217/data.info'
createTarFork() process ended with ERROR: 255
Backup Failed. Cleaning Backup Folder.

I’m on an unlocked FP3, Build No. 8901.2.A.0105.20191217. I have removed many Google Apps as of here. I have played around with the multi user feature, but have removed all additional users. When I started TWRP using fastboot boot <twrp.img>, I mounted system read-only.

What do you make of it?

PS.: I am going to PM you my recovery.log

what filesystem is your external sd card formatted with?

How do I find out? Can I find out using adb? Or do I have to take it out and insert the microSD card into a computer?

It’s probably easiest to check on a PC. But should also be possible using adb, although I can’t currently tell you how.
The reason I am asking is, because my guess would be that your SD-card is fat32 formatted.
And fat32 doesn’t support files larger than 4GiB, which is why backup is failing.
So you’ll have to reformat the card using exfat

1 Like

I can’t check for myself right now, but you could have a look at the Addendum at the end of this post and see whether TWRP reports the file system for the SD card that way.
(Just don’t proceed with the formatting there :wink: .)

1 Like