TWRP Experiences, Pros & Cons

Since FP Open OS comes with TWRP (Team Win Recovery Project) preinstalled I wanted to gather experiences and talk about the possibilities and limitations of TWRP.

:thumbsup: From what I have tested so far, TWRP can:

  • Make a full backup of the phone. (Way more powerful than even Titanium Backup)
  • Except it won’t back up media. :thumbsdown:
  • Restore a full backup in one step.
  • Perform a Hard Reset (“Wipe”) with advanced options.
  • Standard Setting doesn’t wipe Media. :thumbsup:

:thumbsdown: What it can’t do:

  • Perform scheduled backups
  • If you run into an issue with your phone, want to perform a wipe and don’t have a recent backup, creating a backup will probably also backup the issue.
  • Handle encrypted phones: (Works with updated TWRP)

While I agree that this list (and explanation) is good, I think it’s a bit unfair to expect scheduled backups from the recovery. You don’t run the recovery all the time, but the main system image… Scheduled backups have to be run from there… Something an app like nandroid backup should be able to do…
But still, great start for a thread about a really good recovery program


You’re right of course. I didn’t expect scheduled backups. I just mentioned it as a slight disadvantage compared to e.g. Titanium Backup.

It seems that TWRP can not mount /data when the phone is encrypted, so I can also not make any backups with this. And according to the other thread also the newer version can not.

1 Like

But I think it’s clear that TWRP is not a backup tool in the first place. Agree?

Well, not a pure backup tool, but for making “image” backups for tests, i.e. making a nandroid backup, trying Jolla, an returning to the previous installation as it was before, it’s perfect…
I think I read that the problem with/data and twrp lies in the encryption design of lollipop. Probably FP has to migrate to a newer version of twrp, as the actual version is somewhat older

hm… I did a ‘full backup’ earlier today using TWRP so I could play a little with my phone and then broke it somewhat. (F.lux didn’t work anymore after I tried installing the XPosed framework in case you are curious).

So I was happy I did the backup and restored it…

But all app data where gone; no contact, no calendars, no settings. All my apps where there, but I have to go through them one by one to put the settings right again.

Did I do something wrong, or is this what TWRP considers a ‘full backup’?

This should work the way you expected it. But then, I never tried in on the fairphone/FP osos, maybe there’s a glitch in that implementation?.. Some other things come to my mind… Did you tick all partitions to backup?

Today I made a backup with TWRP. As the backup was performed I saw the CPU-temp rising to 88°C .
Is that normal behaviour?

Are you sure it was Celsius??? It must have been almost boiling!? :confused:

PS: I do think it’s plausible that the phone gets hotter as usual because it runs at maximum CPU power for quite some time.

Yes, it was Celsius. That’s why I don’t dare to make another backup with TWRP.

Is TWRP on the FP2 able to decrypt an encrypted /data partition? This is essential for backups and my current phone with TWRP can’t do that :-/.

To my knowledge it is not. Thus I haven’t yet managed to find a way to use TWRP for backups.

1 Like

This needs to be fixed :-/. Is it listed as known bug somewhere?

[quote=“freibadschwimmer, post:13, topic:17215”]
I haven’t yet managed to find a way to use TWRP for backups
[/quote]How so? Save all images, that’s the backup …

Because I cannot mount /data.

I want to understand, but I have no clue, how.

/data is a partition and no matter what’s on that partition I can copy that partition as an image.

/The option to mount /data is IMHO for use with the filemanager.

Correct me, if you know better, but write the reason.

That would be my understanding as well, that for copying a partition it shouldn’t matter if it is encrypted or not. However, when trying to make a backup with TWRP, it fails with the error message, cannot mount /data.
So it seems that with the backup function it is not copying the partition as an image (like dd), but rather taking the files.
Anyhow, the result is that using the TWRP backup function does not work for the /data partition.

hmmm, interesting. I too thought of dd. OK, I’m still learning.

I just wanted to encrypt my datas (for trying, what happens), when I read in another thread, that once /data is encrypted, there is no way back. So I do not try, sorry.


On an old Samsung phone I had CWM installed and I had no problems making backups of an encrypted /data partition. It is a pity that this TWRP port (I am not sure if TWRP in general should be capable of this) cannot do it.

But for me personally it would be a no go to not have my data partition encrypted.

But also Titanium makes decent backups, takes less than 5 minutes to have the phone and all settings as before, after wiping the data partition.