English

TWRP 3.1.1-1 boot issue

I guess so.
Do you use a microSD card, and if so, did you set it up as additional Internal Storage?

Here’s some more from Google …

[Taking out an SD card set up as Internal Storage helped.] (https://androidforums.com/threads/twrp-stuck-on-twrp-splash-screen.1047484/) (Edit: Is it just me or does this sound kind of dangerous for data in Internal Storage?)

Copying the TWRP directory from Internal Storage to SD card set up as external storage and then deleting the Internal Storage TWRP directory helped.

Actually we use a partition called pad as there’s no misc partition on the FP2. But yes, in the fstab we refer to it as /misc.

The TWRP issue sounds weird. So @_Chris, you’re the only one here having that issue it seems. Did this TWRP version before (with/without encryption)? Also as you require the -1 version you have a new display probably. Do you have access to adb in this mode?

I will try this next - thanks for the suggestion.
It will take some time because I will copy the content of the SD card first, then delete most of the data, so that I can move the remaining data to internal storage (there is a menu for that within the settings. so I don’t think it is dangerous to do this).

Yes, this TWRP version worked before, and yes I have a new display.
adb devices shows the device, so I have access to adb.

Maybe the reason for the problem is using an SD card as adopted storage. I will remove it as described above and then try it again.

Okay then run inside adb shell (while you’re in this “splash screen hang”):
cat /tmp/recovery.log and dmesg and send me both via pastebin or some similar service.

Removing SD card finally solved the problem :smiley:

A huge thank you to @AnotherElk for spending so much time in finding a solution, and to all others who helped with this issue!

Edit: @z3ntu are you still interested in the log files?
Edit2: I added the SD card as adopted storage again and now booting into TWRP again doesn’t work. So the problems had indeed nothing to do with the update, but only with adding the SD card as adopted storage. I will send you the log files.

lol and thanks in advance.

I finally found the cause of the problem with the adopted storage:

The SD card was formatted as external storage before formatting it as adopted storage. As a side effect there was a remaining small 17 MB partition in addition to the adopted storage partition on SD card.

The solution is to delete all partitions before formatting an SD card as adopted storage. This way there is only the adopted storage partition on SD card and TWRP doesn’t get “confused” any more by multiple partitions.

So finally I am able to boot into TWRP using an encrypted device with adopted storage :slight_smile:

4 Likes

Hi @_Chris (and others)
When I take my SD card out (after moving data to internal storage) and on a linux computer I remove all partitions (even when I then create one big partition), reinsert the card in my FairPhone2 it will start the initialization sequence, but after that


I stop my device and check the partitions again in GParted:

… Still it creates this small partition.

If TWRP cannot handle this it will fail again with the next update. I think deleting this Android partition is not an option.

Do I misunderstand “Adopted Storage” here?
I chose: Use as Internal Storage and formatted it:

Hi @OmeLuuk

You are right - it seems these 2 partitions (android_expand and android_meta) should be there after formatting an SD card as internal storage. At least all search results I found about partition(s) of adopted storage had these 2 partitions.

So it seems something went wrong when I formatted my SD card and there was no android_meta partition afterwards. I wonder what this partition is used for? So far my phone works without problems …

There is an open issue about TWRP can’t handle “mixed storage” and I guess when this issue is solved booting into TWRP should work when using an SD card as adopted storage.

Unfortunately so far I don’t have any better solution than the one described here:

This topic was automatically closed after 183 days. New replies are no longer allowed.